PowerProtect DD:云层清理尝试失败。失败原因:云单元已断开连接
摘要: 云单元的云层清理失败,出现断开连接错误。
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症状
已识别的症状
已确定以下症状:
- 未进行云层清理。
- 之前的云层清理尝试失败。
- 云单元“cloud-unit”已断开连接。
- 云清理正在运行,云单元的连接问题导致连接断开。
- 云单元处于 CLEANING 状态,而不是 READY 状态。
- 云单元的空间问题。
- 云提供商或云单元的连接问题。
CLI 输出
adim@localhost## cloud clean start cloud-unit Cloud tier cleaning started for cloud unit "cloud-unit". Use 'cloud clean watch' to monitor progress. adim@localhost## cloud clean watch Cloud tier cleaning is not in progress. adim@localhost## cloud clean status Previous cloud tier cleaning attempt was unsuccessful. Failure reason: cloud unit "cloud-unit" was disconnected.
其他日志信息
08/15 11:32:45.381226 [7fad623ea7e0] INFO: CAL cal_handle_cloud_profile_status:1962 - Processing status event for profile: cloud-unit_profile, status: 1, error code: 0 08/15 11:32:45.381237 [7fad623ea7e0] INFO: CAL cal_handle_cloud_profile_status:1980 - Found cloud unit:cloud-unit using profile:cloud-unit_profile 08/15 11:32:45.381240 [7fad623ea7e0] INFO: CAL cal_handle_cloud_profile_status:2037 - Marking cloud profile:cloud-unit_profile for cloud unit:cloud-unit as UP 08/15 11:32:45.381242 [7fad623ea7e0] INFO: CAL cal_handle_cloud_profile_status:2080 - Cloud unit:cloud-unit already AVAILABLE 08/15 11:35:11.147451 [7f891defd740] INFO: CC-cpm: cp_name cloud-unit, vol_name cloud1, cp_handle 2, part_type CC_TYPE_CLOUD, part_status CLEANING, delete_credit 1005224616626
原因
问题的根本原因
- 云单元已断开连接。
- 在断开连接问题得到解决后,云单元状态仍处于 CLEANING 状态。
特定的错误消息和代码
相关错误消息和代码包括:
errno: 5160, errstr: We encountered an internal error. Please try again. errno: 5005, errstr: Insufficient storage at the cloud provider.
外部因素
可能导致该病因的外部因素包括:
- 云提供商的存储不足
- 云提供商或云单元的连接问题
adim@localhost## cloud clean status Previous cloud tier cleaning attempt was unsuccessful. Failure reason: cloud unit "cloud-unit" was disconnected.
08/10 06:05:48.963 [7f1098fd619]: Fmig: fmig2_process_cal_event: cloud-unit (path=cloud1/cp1): receiving DDR_EVENT_CAL_UNIT_UNAVAIL event 08/10 06:05:48.964 [7f1098fd619]: Fmig: setting a FMIG restart on CAL_AVAILABLE event registry key 08/10 06:05:48.968 [7f1098fd619]: Fmig: Abort requested to all the sealing jobs on CP cloud-unit (path=cloud1/cp1) 08/11 10:32:02.529772 [7f7ae3047410] INFO: CAL cal_cloudunit_set_unavail:1784 - Marking cloud unit:cloud-unit as UNAVAILABLE with errno: 5160, errstr: We encountered an internal error. Please try again. 08/11 10:44:18.687575 [7f7ab4191570] INFO: CAL cal_cloudunit_set_unavail:1784 - Marking cloud unit:cloud-unit as UNAVAILABLE with errno: 5005, errstr: Insufficient storage at the cloud provider. 08/15 11:35:11.147451 [7f891defd740] INFO: CC-cpm: cp_name cloud-unit, vol_name cloud1, cp_handle 2, part_type CC_TYPE_CLOUD, part_status CLEANING, delete_credit 1005224616626
解决方案
重新启动文件系统以解决此问题。
要解决此问题,建议重新启动文件系统。这应该有助于清理当前状态,并允许云单元返回到就绪状态。
# Run the following command to restart the DDFS service $ filesys restart
重新启动文件系统后,通过检查云单元的状态,验证云单元是否处于就绪状态。
# Run the following command to check the status of the cloud unit $ cloud unit list $ cloud clean status # Start cloud cleaning is not already running $ cloud clean start
受影响的产品
DD3300 Appliance, DD OS, DD6300 Appliance, DD6400 Appliance, DD6410 Appliance, DD6900 Appliance, DD9400 Appliance, DD9410 Appliance, DD9900 Appliance, DD9910 Appliance产品
DD9910F Appliance文章属性
文章编号: 000368192
文章类型: Solution
上次修改时间: 11 10月 2025
版本: 2
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