NMDA:IBM DB2 快照備份無回應
摘要: 適用於資料庫和應用程式的 NetWorker 模組 (NMDA) IBM DB2 快照備份沒有回應。
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
NMDA IBM DB2 快照備份沒有回應。
DB2 資料庫處於寫入掛起方式。
錯誤 db2diag.log
Warning: ---------------------------------------- 2016-05-20-15.05.16.771114+000 E7423877A808 LEVEL: Warning PID : 7733668 TID : 47390 PROC : db2sysc 0 INSTANCE: <instance_name> NODE : 000 DB : APPHDL : 0-57647 APPID: <app_id> AUTHID : EDUID : 47390 EDUNAME: db2agent (instance) 0 FUNCTION: DB2 UDB, database monitor, sqm___sqlmonssagnt, probe:1234 DATA #1 : <preformatted> This occurs when any snapshot other than list applications is attempted on a database that is write suspended. This is necessary due to latching conflicts. This database is skipped in the snapshot, but other databases should still be processed. Skipping database '<db_name>'. For more information on write suspend, please see the 'db2 set write suspend for database' command. ------------------------------------------
原因
DB2 工作流的工作方式為:
DB2 調用 db2ACSPrepare() 在 NMDA DB2 程式庫中進行初步準備,為硬體快照做好準備。完成此操作后,DB2 資料庫管理員將掛起資料庫並調用 NMDA DB2 函數 db2ACSSnapshot()。在這種情況下,DB2 不調用 db2ACSSnapshot()。工作流停止回應,以便 DB2 引擎繼續備份。IBM 支援 PMR:29538,004,000 已開啟。IBM DB2 工程需要更多的調試來確定此掛起的根本原因。
解析度
因應措施:
- 取消目前的備份
- 使資料庫退出寫入掛起模式
為了發現根本原因,IBM DB2 支援請求以下資訊以供進一步調查,
- 刪除或重新置放 db2dump 目錄中的任何堆疊或轉儲。它會創建新的堆疊或轉儲,而不會混合舊的堆疊或轉儲。(UNIX/Linux 路徑:
/$INSTHOME/sqllib/db2dump) - DB2 跟蹤一小段時間:
db2trc on -f trace.dmp wait about 30 seconds db2trc off db2trc fmt trace.dmp trace.fmt db2trc flw trace.dmp trace.flw
- 收集堆疊:
db2pd -stack all -rep 5 5
- 完成上述步驟後,請執行
procstack <PID> > db2vend.pstack.out
<PID> 是db2vend資料庫的進程。 - 然後取得快照備份工作階段,
db2 get snapshot for applications on <dbname> > db2snap.out
- 現在您可以設定寫入繼續,然後再次嘗試快照備份,查看是否完成。
- 收集db2support.zip,如下所示:
db2support . -d <dbname> -c -s
- 壓縮並傳送至 IBM PMR:
trace.dmptrace.fmttrace.flwdb2vend.pstack.outdb2snap.outdb2support.zip
受影響的產品
NetWorker Module for Databases and Applications產品
NetWorker Family, NetWorker, NetWorker Module文章屬性
文章編號: 000056670
文章類型: Solution
上次修改時間: 27 5月 2026
版本: 6
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。