Avamar - 如何收集資訊,以進行疑難解答複寫問題

摘要: 本文討論應收集哪些資訊,以了解並協助疑難解答 Avamar 復寫問題。

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

本文的目的是提供在調查 Avamar 複寫失敗時收集的信息範本。這有助於進行疑難解答,並縮短支援部門了解問題的時間。

以下列出在復寫問題期間可能會出現的錯誤範例。
  • 回報錯誤: repl_cron - 無法複製
  • 無法登入目的地 DPN
  • 結束代碼 20:許可權不足
  • MSG_ERR_PSWD_INVALID
  • 錯誤 <5445>:內部週期錯誤:中止 repldata
  • 錯誤!結束代碼 18:找不到要求的信息 (遺失數據?不合法的參數?)
  • 錯誤:來源和目的地伺服器均相同。
  • 錯誤 <5698>:來源 (hostname-x) 和目的地
  • 嚴重錯誤:<0001> 嚴重訊號 11
  • 嚴重錯誤:「無法記錄備份 
  • 線上已終止
  • 錯誤 <0000>:登入錯誤 74:在 Avamar 資料庫中找不到帳戶
  • (hostname-y)DPN 是相同的!  複製中止。
  • 週期錯誤:repldata DST_ADD_DATA中回應不良:設定狀態
  • 發生網路錯誤:重新建置連線 0

原因

不適用

解析度

請注意下列術語:
複製 來源 - NAvamar,*會 將* 資料傳送至複製目標。
複製 目標 - nAvamar,* 從復寫來源接收* 數據。
複寫 配對 - 涉及複製的兩個 Avamars 的集合名稱。
交叉複製 - 其中兩個 Avamars 相互複製。兩者皆會傳送和接收復寫數據。

如果 Avamar 與其他 Avamar 伺服器交叉複製數據,則 可以是複製 來源和目標裝置。

如果 Avamar 復寫環境有多個問題,請將問題分成較小的零件。一次使用一對複寫組。 
 

要收集的資訊與要檢查的專案:

  1. 復寫來源的完整主機名。
  2. 複製目標的完整主機名。
  3. 複寫配對是否交叉複寫?
    a) 如果是,復寫失敗是以單一方向或兩者發生? 
  4. 失敗的復寫工作是否曾經運作過?如果有,請收集記錄,以進行最後一次成功的工作。
  5. 在兩個 Avamars 上,執行主動式檢查腳本檔 (本文只有在登入 Dell Support Avamar 時才能存取:如何在Avamar Server上執行 proactive_check.pl 健全狀況檢查腳本檔)。
    a) 收集「hc_results」檔案。
    b) 以 --sched 旗標重新執行腳本。收集輸出。
    b) 以 --capacity 旗標重新執行腳本。收集輸出。
  6. 來源和目標 Avamar 之間的預期頻寬是什麼?
  7. 從來源中,ping 目標並收集輸出。
  8. 執行 每個Avamar上的 status.dpn,並收集輸出。
  9. 收集失敗的工作的復寫記錄。如需詳細資訊,請參閱本文的「備註」一節。




其他資訊

從 Avamar HTML 使用者介面 (AUI) 收集複製活動記錄。

Avamar Web 使用者介面中的活動監視器可讓您存取詳細的會話記錄。如此可進行分析和疑難解答。

步驟:
1.在左側的 AUI 導覽窗格中按一下 >>,然後按兩下「Activity」。
活動監視器隨即顯示,並顯示所有活動的清單。

2.從清單中選取活動,然後按兩下[View LOGS] (檢視記錄)。
Log」詳細數據視窗隨即顯示。根據預設,活動監視器會顯示過去72小時內所有用戶端備份活動的詳細記錄。
屏幕截圖範例
3.若要根據搜尋字串篩選內容,請在搜尋欄位中輸入字串。

4.若要下載記錄檔,請按兩下「下載」

Avamar 複製記錄



如何收集復寫記錄:

從系統管理員 UI 活動監視器中,選取「動作」> 篩選器 -> 依類型篩選「All Replication Source &destination」。

螢幕截圖,顯示複製活動篩選

根據預設,活動監視器只會顯示在72小時內執行的複寫工作,或MCS服務重新啟動後 (如果時間少於72小時)。

顯示 Avamar 複寫工作清單的螢幕截圖

選取要進行故障診斷的工作,然後連按兩下以擷取記錄。

活動深入演練

活動會話向下拉式畫面會顯示要求的記錄,或超連結檔案中的記錄檔清單。

您可以選取個別記錄。此外,還有一個選項可將記錄導出至Avamar Administrator桌面上的 html 檔案。

活動深入演練摘要 - 儲存會話記錄

或者,透過 SCP 從 Avamar 來源公用程式節點下載記錄。  
登入:/usr/local/avamar/var/client/

例如:
-rw-r----- 1 root  root  9.4K Feb 27 07:03 Default_Replication_Schedule-new-1456556402264#0-1008-Replicate-avtar.log
-rw-r----- 1 root  root   11K Feb 27 07:03 progress-Default_Replication_Schedule-new-1456556402264-1001-Unix_Progress.log
-rw-r----- 1 root  root  5.8K Feb 27 07:03 Default_Replication_Schedule-new-1456556402264-1008-Replicate.log
-rw-r----- 1 root  root  8.2K Feb 27 07:03 Default_Replication_Schedule-new-1456556402264-1008-Replicate.alg
 
 

受影響的產品

Avamar

產品

Avamar
文章屬性
文章編號: 000081711
文章類型: Solution
上次修改時間: 10 2月 2025
版本:  6
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。