Agenten kan inte registrera med servern med NullReferenceException

摘要: Agenten kan inte registrera sig i Dell Security Management Server med NullRefernceException i loggen.

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Berörda produkter:

  • Dell Endpoint Security Suite Enterprise
  • Dell Endpoint Security Suite Pro

Slutanvändaren upptäcker att Advanced Threat Prevention inte är aktiverat och kontrollerar DellAgent-loggfilerna under:

C:\ProgramData\Dell\Dell Data Protection

Följande felmeddelande visas:

2017.08.18 10:07:31 I Comm : Registering agent on server...
2017.08.18 10:07:31 E Comm : general exception - System.NullReferenceException: Object reference not set to an instance of an object.
at Dell.Client.SecurityFramework.Agent.Plugins.CommManager.CommAgentPlugin.RegisterAgent(IAgentService proxy)
at Dell.Client.SecurityFramework.Agent.Plugins.CommManager.CommAgentPlugin.ContactServer(String serverUri, Int32& SleepSecs)
at Dell.Client.SecurityFramework.Agent.Plugins.CommManager.CommAgentPlugin.OnPluginProcess()

原因

Gäller ej

解析度

Viktigt! Utför endast dessa steg om det är exakt det felmeddelande du ser, eftersom det kan få negativa effekter om det inte är problemet.
Obs! Kör följande kommandon från en upphöjd kommandotolk.

Kör det här kommandot för att kontrollera WMI-datakatalogen:

winmgmt /verifyrepository

Om det visar sig vara inkonsekvent kör du det här kommandot:

winmgmt /salvagerepository

Högerklicka på ikonen Dell Data Security i systemfältet och välj Sök efter policyuppdateringar så registreras agenten och efter några minuter blir Advanced Threat Preventiongrönt.


Om du vill kontakta support, se Dell Data Security telefonnummer till internationell support.
Gå till TechDirect för att skapa en begäran om teknisk support online.
Om du vill ha mer information och resurser kan du gå med i Dell Security Community-forumet.

其他資訊

 

受影響的產品

Dell Endpoint Security Suite Pro, Dell Endpoint Security Suite Enterprise
文章屬性
文章編號: 000124791
文章類型: Solution
上次修改時間: 04 1月 2024
版本:  7
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。