已安裝 Threat Defense v2.0.1452.6 開機時出現黑色畫面

摘要: 本文說明威脅防禦 v2.0.1452.6 導致開機時出現黑色畫面的情況。

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

注意:

受影響的產品:

  • Dell Threat Defense

受影響的版本:

  • v2.0.1452.6

原因

2017 年 8 月 14 日 (GMT -6) 下午 4:30,將組建 2.0.1452.6 推給全球威脅防禦客戶。Dell 支援發現更新有問題,並在 2017 年 8 月 15 日 (GMT- 6) 上午 6:30 移除更新。

更新未包含為新本機數學模型正確載入所需的檔案。在某些情況下,檔案變更會導致 Dell Threat Defense 代理程式無法開機,此開機是根據開機時執行的檢查總和驗證而定,且裝置上已啟用 防止服務關機原則。此原則會導致總和檢查碼無法正確載入 Dell Threat Defense 服務,且無法啟動服務會導致開機時出現黑色畫面,或在某些情況下無法登入。

由於無法更新數學模型,也導致某些應用程式和檔案在裝置上遭到不當隔離,而且有些檔案位於受保護的作業系統目錄中,例如 System32、Program Files 和 Program Files (x86)。隔離的檔案導致部分裝置無法正常開機,因此強制修復作業系統。

解析度

受影響的檔案:

  • CommonUtils.dll
  • Cylance.Engine.Utils.dll
  • Cylance.Host.InifinityModel.dll
  • Cylance.Host.InifinityModelOLE.dll
  • Cylance.Host.InifinityModelPDF.dll
  • ISampleScoring.dll
  • Newtonsoft.Json.dll
  • 範例Scoring2PE.dll
  • SharedDefinitions.dll

若有要求,可以提供遺失檔案的檢查總和。

如果您的電腦有此問題,請按照下列步驟加以解決:

  1. 將受影響的電腦開機至安全模式。
  2. 在「開始搜尋」方塊中鍵入 services.msc,然後按 Enter 鍵以開啟 Windows 服務主控台。
  3. 以滑鼠右鍵按一下 CylancePROTECT 服務,然後選取「停止」。
  4. 以正常模式重新開機電腦。
  5. 重新開啟 Windows 服務主控台。
  6. 以滑鼠右鍵按一下 CylancePROTECT 服務,然後選取「開始」。
  7. 在工作列上,以滑鼠右鍵按一下威脅防禦承載器圖示,然後選取「更新」檢查。
  8. 威脅防禦降級至代理程式 1442,可正常運作和保護
注意:2017 年 8 月 31 日發佈新組建 1452.9,並針對此問題提供修正。開機至黑色畫面的機器仍需要上述步驟,但復原後可安全升級至 1452.9。

Dell 的 Endpoint Security Suite Enterprise 不受影響。


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其他資訊

 

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受影響的產品

Dell Threat Defense
文章屬性
文章編號: 000131366
文章類型: Solution
上次修改時間: 14 8月 2023
版本:  9
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