AppSync: ripristino SQL non riuscito a causa di file ldf (registro sql) mancanti.

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀



AppSync non riesce a ripristinare un database SQL su un mount host.

Gli eventi di Service Plan indicano:
Unable to recover database MyDB on the instance MySQL-QA.  See the host plug-in log, application event log, and the SQL Server error log for details.

Il registro eventi delle applicazioni del sistema operativo mostra:
Error         Mountx 17207   MSSQLSERVER                      FileMgr::StartLogFiles: 
Operating system error 2(The system cannot find the file specified.) occurred while creating or opening file 
'L:\SourceFolder\MSSQL\logs\MyDB_2.ldf'. Diagnose and correct the operating system error, and retry the operation.

Error         Mountx 17207   MSSQLSERVER                      FileMgr::StartLogFiles:
 Operating system error 2(The system cannot find the file specified.) occurred while creating or opening file
'L:\SourceFolder\MSSQL\logs\MyDB_3.ldf'. Diagnose and correct the operating system error, and retry the operation.

Il registro del plug-in AppSync sul mount host indica:
[MountHost] SQL: Last native error: error number 5111, SQLState 01000, sql native info message [Microsoft][ODBC SQL Server Driver][SQL Server]File activation failure.
The physical file name "L:\SourceFolder\MSSQL\logs\MyDB_2.ldf" may be incorrect.
[MountHost] SQL: processSQLMessages: Message = Msg 1813, SevLevel 0, State 5, SQLState 42000, sql native info [Microsoft][ODBC SQL Server Driver][SQL Server]Could not open new database 'MyDB'. CREATE DATABASE is aborted.

[MountHost] SQL: Last native error: error number 5111, SQLState 01000, sql native info message [Microsoft][ODBC SQL Server Driver][SQL Server]File activation failure.
The physical file name    "L:\SourceFolder\MSSQL\logs\MyDB_3.ldf" may be incorrect.
[MountHost] SQL: processSQLMessages: Message = Msg 1813, SevLevel 0, State 5, SQLState 42000, sql native info [Microsoft][ODBC SQL Server Driver][SQL Server]Could not open new database 'MyDB'. CREATE DATABASE is aborted.

原因

Software bug

解析度

AppSync 4.0 risolve questo problema.

其他資訊

Le note di rilascio di AppSync 4.0 non citano questo problema come risolto nella sezione Fixed in, tuttavia è stato confermato che la correzione di questo problema è in AppSync 4.0
Eseguire l'aggiornamento ad AppSync 4.0 per risolvere il problema.

受影響的產品

AppSync

產品

AppSync
文章屬性
文章編號: 000170225
文章類型: Solution
上次修改時間: 18 9月 2026
版本:  8
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。