SourceOne: Email Management Job Dispatcher service stops Job Business Components that run >30 min

摘要: The Job Dispatcher service stops Job Business Components that run longer than 30 minutes if no keep-alive update is received. Error: The dispatcher thread received an error from the Job Business Component. ...

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症狀

If a Job Business Component (JBC) encounters a large file or message, it causes a timeout.
Example: A Historical Archive job fails when processing a mailbox with large recipient messages.  
When a large message is being processed, the JBC performs a CopyTo() MAPI call:

CExCompoundStgMsg::CreateMemoryMessage|VERBOSE|Total Recipients Count = <32265>; MaxRecips = <5000>; MaxWaitTime = <1500000>|ExCompoundStgMsg.cpp(1059)
CExCompoundStgMsg::CreateMemoryMessage|VERBOSE|Calling CopyTo in a separate thread - MaxRecips = <5000>; MaxWaitTime = <1500000>...|ExCompoundStgMsg.cpp(1063)



While the JBC is waiting for the CopyTo() to complete, it is considered unresponsive by the Job Dispatcher because it is not updating its keep-alive pulse.
The Job Dispatcher will log one or more messages in the ExJobDispatcher.exe.log indicating the job is not alive and is stopped:

CExDispatchThread::MonitorActiveJobs|INFO|Stopping job Id: <Job ID> which is not alive|ExDispatchThread.cpp(1484)


After the job is stopped, the Job Dispatcher will shows:

CExJobThread::Run|ERROR-LOGD|The dispatcher thread received an error from the the Job Business Component (JBC): <JBC Name>, HR: 0x86043243. (0x86040906)|ExJobThread.cpp(1375)


 

原因

The keep-alive poll time used by the Job Dispatcher service defaults to 30 minutes.  Any JBC s which cannot respond within this time may be terminated as they are considered unresponsive. 

解析度

This issue is resolved in patches or Service Pack versions of SourceOne Email Management on or higher than 7.2.9. Hot Fix 1

Hotfix Bundles and Service Pack kits are available for download from https://www.dell.com/support.
Hot-fixes are only available for the most current patch or Service Pack versions of the product that were available when this problem was resolved.
Upgrade to the latest version of the SourceOne release, service pack, and Hot Fix Bundle to ensure all currently resolved issues will be fixed including the issue as stated above.

An update to the timeout must be implemented in the SQL database. Contact support for assistance in making this change. Reference article 542289. 

受影響的產品

SourceOne

產品

SourceOne, SourceOne Email Management
文章屬性
文章編號: 000173285
文章類型: Solution
上次修改時間: 05 5月 2026
版本:  4
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