PowerEdge:什麼是 CTL137 事件以及如何對其進行故障排除
摘要: CTL137 事件是 iDRAC 代碼 4.xx.xx.xx 的新增事件。CTL137 事件的存在是為了通知終端使用者 iDRAC 與系統中的端點裝置失去通訊。
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
什麼是 CTL137 事件?
CTL137 事件是 iDRAC 代碼 4.xx.xx.xx 的新增事件。CTL137 事件的存在是為了通知終端使用者 iDRAC 與系統中的端點裝置失去通訊。
例如:”
位於外框 X 插槽 X 的儲存控制器 PCIe SSD 無法與 BMC 通訊,因為儲存控制器或 BMC 因為內部錯誤或匯流排處於錯誤狀態而未回應命令。」
CTL137 事件是 iDRAC 代碼 4.xx.xx.xx 的新增事件。CTL137 事件的存在是為了通知終端使用者 iDRAC 與系統中的端點裝置失去通訊。
例如:”
位於外框 X 插槽 X 的儲存控制器 PCIe SSD 無法與 BMC 通訊,因為儲存控制器或 BMC 因為內部錯誤或匯流排處於錯誤狀態而未回應命令。」
原因
觸發 CTL137 事件的原因。
iDRAC 會因各種原因 (健全狀況變更、溫度等),持續透過系統內的 i2C 通道輪詢端點裝置 (NVMe 磁碟機、PERC 等)。如果端點裝置無法回應連續 10 次 i2C 輪詢,則 iDRAC 會記錄 CTL137 事件。通知終端使用者 iDRAC 中斷與端點裝置的通訊。
通訊恢復時,iDRAC 會通知您嗎?
如果在產生 CTL137 後還原與端點裝置的 i2C 通訊。觀察 CTL138 事件會通知使用者通訊已還原至端點裝置。
例如:”
CTL138 在外框 X 插槽 X 中的儲存控制器 PCIe SSD 與 BMC 之間的通訊已恢復「
為什麼重設 iDRAC 會暫時解決問題。
執行 iDRAC 重設,即可強制系統重新清查附加的端點裝置。此外,在此過程中,每個端點裝置的 iDRAC 命令失敗計數器會針對每個端點裝置重設為 0。一旦端點裝置無法回應連續 10 次 i2C 輪詢,iDRAC 就會針對該端點裝置記錄 CTL137 事件。
為什麼我看到 CTL137 事件,而且磁碟機在作業系統中仍為線上。
在某些情況下,您可能會看到磁碟機在作業系統中仍處於線上狀態,但您會看到 CTL137 事件。這是因為與磁碟機的 i2C 通訊不會透過資料纜線傳輸。iDRAC 會使用從機板傳送到背板的單一 SIG 纜線來傳送所有 SMBus 通訊。您的問題可能出在這些元件上。
iDRAC 會因各種原因 (健全狀況變更、溫度等),持續透過系統內的 i2C 通道輪詢端點裝置 (NVMe 磁碟機、PERC 等)。如果端點裝置無法回應連續 10 次 i2C 輪詢,則 iDRAC 會記錄 CTL137 事件。通知終端使用者 iDRAC 中斷與端點裝置的通訊。
通訊恢復時,iDRAC 會通知您嗎?
如果在產生 CTL137 後還原與端點裝置的 i2C 通訊。觀察 CTL138 事件會通知使用者通訊已還原至端點裝置。
例如:”
CTL138 在外框 X 插槽 X 中的儲存控制器 PCIe SSD 與 BMC 之間的通訊已恢復「
為什麼重設 iDRAC 會暫時解決問題。
執行 iDRAC 重設,即可強制系統重新清查附加的端點裝置。此外,在此過程中,每個端點裝置的 iDRAC 命令失敗計數器會針對每個端點裝置重設為 0。一旦端點裝置無法回應連續 10 次 i2C 輪詢,iDRAC 就會針對該端點裝置記錄 CTL137 事件。
為什麼我看到 CTL137 事件,而且磁碟機在作業系統中仍為線上。
在某些情況下,您可能會看到磁碟機在作業系統中仍處於線上狀態,但您會看到 CTL137 事件。這是因為與磁碟機的 i2C 通訊不會透過資料纜線傳輸。iDRAC 會使用從機板傳送到背板的單一 SIG 纜線來傳送所有 SMBus 通訊。您的問題可能出在這些元件上。
解析度
看到 CTL137 事件時要注意的事項。
- 尋找磁碟機無法回覆 iDRAC 的 i2C 輪詢的明顯原因。
- 是否有磁碟機故障?
- PCIe 連結訓練失敗
- PCI 下行錯誤
- 確認系統 NVMe 磁碟機、背板、iDRAC 中的所有元件均採用最新程式碼。
- 執行步驟 1 和 2 後,如果仍看到重複的 CTL137 事件,則接續 CTL138 事件。然後,您可能會在 iDRAC 和端點裝置之間看到間歇性的訊號問題。
- 嘗試將磁碟機和/或背板纜線重新拔插至平面機。
受影響的產品
PowerEdge文章屬性
文章編號: 000182797
文章類型: Solution
上次修改時間: 08 5月 2026
版本: 4
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。