AppSync:AppSync 4.2 代理程式當機,ucrtbase.dll 為故障模組

摘要: 安裝 AppSync 4.2 時,使用者可能會發現間歇性代理程式當機。在執行服務計劃期間,這些狀況的特性為間歇地無法與代理程式通訊,而且主機系統和應用程式事件記錄中會出現許多事件。此問題可能會在 Windows 2016 和 2019 上出現。

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

使用者可能會遇到 AppSync 4.2 或 AppSync 4.2.0.1 代理程式間歇性的當機。此問題可透過以下症狀加以識別。

首先,AppSync 服務計劃的事件可能會出現下列錯誤:
 
AppSync 伺服器無法連線至代理程式主機:<主機名稱>。確定代理程式主機已上線並可從 AppSync 伺服器連線。如果這是 Windows 代理程式主機,請確定 AppSync 主機附掛程式服務處於執行中狀態。
 
檢查主機時,可在主機應用程式事件記錄中看到下列訊息:
 
03/05/2021 12:56:47 PM  資訊   <主機名稱> 1001    Windows 錯誤報告          錯誤容器,類型 0 事件名稱:BEX64 回應:無法取得 Cab ID:0 問題簽名:  P1:APPSYN~1.EXE  P2:4.2.0.0  P3:602b55dd P4ucrtbase.DLLP5:10.0.10240.16390  P6:55a5b718  P7:0000000000064388  P8:c0000409  P9: 0000000000000005  

原因

這可能是由執行與 AppSync 不相容的 ucrtbase.dll 版本的主機系統所造成。或由 AppSync 代理程式中的程式碼錯誤所造成。 

解析度

採取下列步驟以解決此問題:
  1. 在主機上執行所有累積的 Windows 更新和安全性更新,並視需要將主機重新開機。
    請確定 ucrtbase.dll 檔案包含以下最低版本:
若為 Windows Server 2016,請確認 ucrtbase.dll 的最低版本為 10.0.14393.2097。
若為 Windows Server 2019,請確認 ucrtbase.dll 的最低版本為 10.0.17763.719。

將主機附掛程式服務重新開機,然後再次執行服務計劃。
  1. 如果此問題目前尚未解決,則已為此問題建立修正程式。申請服務要求即可取得。 
文章屬性
文章編號: 000185071
文章類型: Solution
上次修改時間: 09 5月 2026
版本:  5
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。