VxRail:vCenter 錯誤「虛擬硬碟『根』已滿。 因此,無法寫入檔。
摘要: vCenter 顯示主機的錯誤: “虛擬硬碟'根'已滿。 因此,無法寫入檔 *。
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
症狀 1:虛擬硬碟的根目錄為100%。
根目錄顯示 Use% 100%。
症狀 2:虛擬硬碟的根目錄已滿,運行時出現以下錯誤:
您會看到以下列字結尾的錯誤
/var/log/ 中的紀錄檔遺失或未更新。
或者
您無法在受影響的 ESXi 主機上安裝 HA 代理程式。
- 使用 putty 以 SSH 連線至 ESXi 主機。
-
vdf -h
- 確認根帳戶顯示 100%。
輸出範例:
根目錄顯示 Use% 100%。
症狀 2:虛擬硬碟的根目錄已滿,運行時出現以下錯誤:
esxcli software vib list
您會看到以下列字結尾的錯誤
"socket.error: [Errno 2] No such file or directory"或
/var/log/ 中的紀錄檔遺失或未更新。
或者
您無法在受影響的 ESXi 主機上安裝 HA 代理程式。
原因
兩個可能的原因:
1.將檔案手動複製到主機,並使用了不正確的路徑 (即 /vmfs/volumes 外部的路徑)。
1.將檔案手動複製到主機,並使用了不正確的路徑 (即 /vmfs/volumes 外部的路徑)。
2.如果永久暫存空間不可用,ESXi 會將此臨時數據存儲在虛擬硬碟上。這在空間上是有限的。這在記憶體不足的情況下可能會有問題,但對 ESXi 的運作來說並不重要。存儲在虛擬磁碟上的資訊不會在重新啟動后保留,因此日誌和核心檔等故障排除資訊可能會丟失。如果主機的持久暫存位置配置不正確,則由於臨時檔和日誌檔未更新的空間不足,可能會出現間歇性問題。
解析度
1.針對檔案問題,請參閱 Broadcom KB: https://knowledge.broadcom.com/external/article?legacyId=2001550,然後依照以下步驟操作。
2.若要解決此問題,請參閱 Broadcom KB:https://knowledge.broadcom.com/external/article?legacyId=1033696,然後依照以下步驟操作。
- 如果管理操作導致錯誤,請刪除使用不正確路徑的檔或將其移動到數據存儲。
或
- 使用 putty 以 SSH 連線至 ESXi 主機。
-
find / -size +1024k -exec du -h {} \; | less - 移動或刪除任何舊的或過時的 ESXi 主機記錄套裝。
2.若要解決此問題,請參閱 Broadcom KB:https://knowledge.broadcom.com/external/article?legacyId=1033696,然後依照以下步驟操作。
- 使用 putty 以 SSH 連線至 ESXi 主機。
-
df -h

- 為「檔案系統」「VMFS-L」的檔案路徑加上註解,該路徑顯示在「掛接於」下。注意: 這是象徵性連結,可前往開頭沒有「OSDATA-」的磁碟區目錄。例如,使用以上螢幕擷取畫面的資訊,VMFS-L 「掛接」的檔案路徑顯示為「/vmfs/volumes/OSDATA-604f7166-b35be91f-0d4c-005056281a17」。

- 登入 vCenter。
- 按一下有問題的主機。
- 前往設定 > 系統 > 進階系統設定。
- 篩選「scratchconfig」的金鑰。
- 找
'ScratchConfig.ConfiguredScratchLocation'.
- 插入步驟 3 的檔案路徑,且不包含「OSDATA-.」。例如:
'/vmfs/volumes/OSDATA-604f7166-b35be91f-0d4c-005056281a17' should be entered as '/vmfs/volumes/604f7166-b35be91f-0d4c-005056281a17'.
- 讓主機進入維護模式,然後將主機重新開機。
- 當主機重新開機時,請登入 vCenter 以確認
'ScratchConfig.ConfiguredScratchLocation' AND 'ScratchConfig.CurrentScratchLocation'
顯示在步驟 9 中添加的正確目錄路徑。
受影響的產品
VMware ESXi 6.7.X, VMware ESXi 7.x, VMware ESXi 8.x文章屬性
文章編號: 000193942
文章類型: Solution
上次修改時間: 12 5月 2026
版本: 4
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。