Dell EMC Networking OS10 登入時記錄訊息「syslog-ng.service 未啟用,無法重新載入」 解決方案

摘要: 如果您在登入時看到訊息「syslog-ng.service 未使用中,無法重新載入」,請遵循此內容以取得因應措施和解決方案。

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

登入交換器後,可能會看到下列行:
 
syslog-ng.service is not active, cannot reload


原因


在極少數情況下, /var/lib/syslog-ng/syslog-ng.persist 可能會損毀。發生這種情況時, syslog-ng 服務 將無法啟動,並將進入故障狀態。

執行下列命令時,您會看到狀態為失敗。

OS10# system “sudo systemctl status syslog-ng”
syslog-ng.service - 系統記錄程式精靈
已載入:已載入 (/lib/systemd/system/syslog-ng.service;已啟用;廠商預設:已啟用)
作用中:失敗 (結果:核心傾印),自 Tue 2021-10-01 11:58:22 UTC 開始;3 週

解析度

因應措施



刪除 /var/lib/syslog-ng/syslog-ng.persist 檔案並啟動服務,即可啟動故障的 syslog-ng.service

在排程前還原服務的短期修正 升級-

OS10# system “sudo rm /var/lib/syslog-ng/syslog-ng.persist”
OS10# system “sudo systemctl start syslog-ng”
OS10# system “sudo systemctl status syslog-ng”

syslog-ng.service - 系統記錄程式精靈
已載入:已載入 (/lib/systemd/system/syslog-ng.service;已啟用;廠商預設
) 啟用:啟用 (執行中),自 Thu 2021-10-28 22:05:58 UTC; 1分 35秒前


解析度


升級至 10.5.2.2 或更新版本以獲得解決方案。

受影響的產品

SmartFabric OS10 Software
文章屬性
文章編號: 000193969
文章類型: Solution
上次修改時間: 05 6月 2025
版本:  3
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。