Avamar:SQL 備份因高資源使用率逾時而失敗
摘要: 當 SQL 用戶端系統遇到高 CPU 和記憶體使用率時,Avamar SQL 備份可能會失敗並出現逾時和 I/O 錯誤。當其他伺服器程序消耗關鍵資源,導致 Avamar 備份程序無法順利完成時,就會發生此問題。
本文章適用於
本文章不適用於
本文無關於任何特定產品。
本文未識別所有產品版本。
症狀
- 在 Avamar Administrator UI 或 Avamar 使用者介面 (AUI) 活動監視器中,SQL 備份失敗或異常終止。
- SQL 備份作業似乎完成數據傳輸,但在 SQL 處理過程中失敗。
- SQL 用戶端記錄報告 I/O 和超時相關的錯誤。
- 在備份視窗期間,SQL 用戶端上的 CPU 和 RAM 使用率始終居高不下。
SQL 備份紀錄中出現以下錯誤(在 SQL 用戶端上):
C:\Program Files\avs\var\SxOMxxxxx_SQL1_hpxxn_uxxmdb_test_SQL_Schedule-test_SQL_Backups-1722556800070-3006-SQL.log
2024-08-02 08:20:38 avsql Info <6688>: Process 17036 (C:\Program Files\avs\bin\avtar) finished (code 0: success)
2024-08-02 08:20:38 avsql Info <6446>: SQL VDI transfer of 'SxOMxxxxx\SQL1/hpxxn_uxxmdb/f-0.hpxxn_uxxmdb' to 'SxOMxxxxx_SQL1_hpxxn_uxxmdb_test_SQL_Schedule-test_SQL_Backups-1722556800070-3006-SQL' successful
2024-08-02 08:20:38 avsql Error <40258>: sqlconnectimpl_smo::execute Microsoft.SqlServer.Management.Common.ExecutionFailureException: An exception occurred while executing a Transact-SQL statement or batch. ---> System.Data.SqlClient.SqlException: Write on "SxOMxxxxx_SQL1_hpxxn_uxxmdb_test_SQL_Schedule-test_SQL_Backups-1722556800070-3006-SQL" failed: 995(The I/O operation has been aborted because of either a thread exit or an application request.)
A nonrecoverable I/O error occurred on file "SxOMxxxxx_SQL1_hpxxn_uxxmdb_test_SQL_Schedule-test_SQL_Backups-1722556800070-3006-SQL:" 995(The I/O operation has been aborted because of either a thread exit or an application request.).
BACKUP DATABASE is terminating abnormally.
在 SQL 用戶端 的工作管理員 中查看性能指標時,很明顯存在顯著的 CPU 利用率:
圖 1.工作管理員 CPU 使用率
在檢查消耗大量 CPU 和 RAM 的進程時,發現還有其他進程使用最大可用資源:
圖 2.工作管理員程序執行中
原因
當其他伺服器進程(如 SQL Server、Windows NT 服務或第三方代理)消耗大部分可用的 CPU 和 RAM 時,就會發生此問題。
高資源使用率會使 Avamar 備份程序無法維護所需的 I/O 作業,而導致 SQL 備份逾時和失敗。
解析度
與 SQL/Wintel 管理團隊合作,以減少 SQL Server 和其他代理程式對 CPU 和 RAM 的使用。
有關其他資訊,請參閱下列文章:
-
資源池「內部」中沒有足夠的系統記憶體來運行此查詢
(外部連結 - microsoft.com)
-
資源池「預設」中沒有足夠的系統記憶體來運行此查詢。 在 SQL
上 (外部連結 - stackoverflow.com)
-
伺服器記憶體組態選項
(外部連結 - microsoft.com)
文章屬性
文章編號: 000227635
文章類型: Solution
上次修改時間: 10 6月 2026
版本: 7
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。