No Auto Rotation on XPS 13 9365 and Latitude 7389 2-in-1

Summary: Touchscreen does not autorotate on XPS 13 9365 and Latitude 13 7389 2-in-1.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The autorotate mode button may be missing from the Action Center on XPS 13 9365 and Latitude 13 7389 2-in-1 preventing the screen from automatically changing from portrait to landscape (or reverse) automatically. Using Ctrl-Alt-> hot key combination to force the rotation works. Reinstalling the sensor in Device Manager has no effect on the issue.

Note: This issue may also occur on other 2-in-1 models.

Cause

This is due to a fault in the Intel Integrated Sensor Solution driver.

Resolution

Reinstallation of the Intel Integrated Sensor Solution Driver installs the sensor drivers for the computer. Once this chipset package is installed, all the controls for screen rotation reappear. A message on the bottom right of the screen may appear when the device is rotated. Click Do not ask me again in the message. In Settings, turn off Rotation Lock to enable auto rotation. If Rotation Lock is enabled, the device stays in Tablet Mode.
 

Note: The rotation controls are unavailable and when the display is tilted at an angle beyond 200–225 degrees transitioning to tablet mode.

The keyboard and touchpad is also disabled. When transitioning back to laptop mode, the input devices are reenabled when transitioning back within the 200 to 225-degrees open angle.

Affected Products

Latitude 7389 2-in-1, XPS 13 9365 2-in-1
Article Properties
Article Number: 000145205
Article Type: Solution
Last Modified: 02 May 2026
Version:  9
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