Omitir para ir al contenido principal
  • Hacer pedidos rápida y fácilmente
  • Ver pedidos y realizar seguimiento al estado del envío
  • Cree y acceda a una lista de sus productos
  • Administre sus sitios, productos y contactos de nivel de producto de Dell EMC con Administración de la empresa.

Unisphere for PowerMax: O SMAS continua falhando com o erro "Address already in use: bind 127.0.0.1:9999"

Resumen: SMAS inoperante com 5 segundos

Es posible que este artículo se traduzca automáticamente. Si tiene comentarios sobre su calidad, háganoslo saber mediante el formulario en la parte inferior de esta página.

Contenido del artículo


Síntomas

O Unisphere for PowerMax
recém-instalado não pode ser iniciado. O SMAS cai em 5
segundos Em alguns cenários, somente run.log é gerado porque o SMAS
nunca foi executado corretamente após a instalação Em alguns cenários, o smas.log

também é gerado Abaixo, os erros são vistos em todos os logs

Erro msg (smas.log):
 
[Controlador de host] ERRO 21:43:20.514 [org.jboss.msc.service.fail] (MSC service thread 1-2) MSC00001: Falha ao iniciar o serviço jboss.remoting.server.management: org.jboss.msc.service.StartException
no serviço jboss.remoting.server.management: JBAS017112: Endereço já em uso: bind 127.0.0.1:9999

Erro msg (run.log):
 
[Controlador host] 21:43:20.529 FATAL [org.jboss.as.host.controller] (Thread de inicialização do controlador) xxxx010933: A inicialização do controlador de host apresentou falha de maneira irrecuperável; Sair. Consulte as mensagens anteriores para obter detalhes.
[Controlador de host] 21:43:20.576 INFO [org.jboss.as] (MSC service thread 1-5) xxxx015950: JBoss AS 7.1.3a. OCI-emc "xxxxx" foi interrompido em 9 ms
21:43:21.075 INFO [org.jboss.as.process.Host Controller.status] (somente para controlador host) xxxx012010: O processo "Host Controller" terminou com o status de saída 99
21:43:21.075 INFO [org.jboss.as.process] (Thread-8) xxxx012016:
Controladora de processo de desligamento 21:43:21.075 INFO [org.jboss.as.process] (Thread-8) xxxx012015: Todos os processos concluídos; exiting

[Host Controller] ]) - descrição da falha: {"WFLYCTL0080: Failed services" => {"jboss.remoting.server.management" => "WFLYRMT0004: Endereço já em uso: bind 127.0.0.1:9999

 

Causa

Erros acima significam que há uma falha nas portas do Unisphere com algum outro aplicativo

Resolución

O Unisphere for VMAX/PowerMax precisa ser instalado com acesso exclusivo às portas abaixo: 
  • 8443 para https
  • 3324 para SMAS_DB
  • 8088, 8089 para RCA, RT
  • 4447, 9990, 9999 para o servidor Unisphere for VMAX (não editável)
    • A porta :9999 é usada como a comunicação intraatendimento , geralmente chamada de MANAGEMENT_NATIVE.
  • 5988/5989 para ECOM
  • 2707 para client/servidor
  • 10123 para vWitness

Para resolver esse problema, identifique o aplicativo que está utilizando qualquer uma das portas acima e desinstale-o. Em seguida, inicie o SMAS normalmente.
Em alguns cenários, uma reinstalação do Unisphere pode ser necessária.

A seguir estão alguns dos aplicativos em que tais erros foram observados:
Splunk
CISCO
Dell EMC Data Protection Advisor (DPA)
AppSync

Propiedades del artículo


Producto comprometido

Unisphere for VMAX, Unisphere for PowerMax

Producto

Unisphere for VMAX

Fecha de la última publicación

08 sept 2023

Versión

3

Tipo de artículo

Solution