Gå vidare till huvudinnehållet
  • Lägg beställningar snabbt och enkelt
  • Visa beställningar och kontrollera leveransstatus
  • Skapa och kom åt en lista över dina produkter
  • Hantera dina webbplatser, produkter och kontakter på produktnivå från Dell EMC med hjälp av företagsadministration.

Windows 8和Windows 8.1 STOP错误(蓝屏)故障诊断

Sammanfattning: 本文有助于诊断和解决Windows 8.1系统上的蓝屏错误。

Den här artikeln kan ha översatts automatiskt. Om du har feedback angående kvaliteten kan du meddela oss via formuläret längst ned på den här sidan.

Artikelns innehåll


Symptom

目录:

  1. 什么是蓝屏错误?
  2. 检查操作中心以了解问题和解决方案
  3. 运行在线诊断程序
  4. 诊断出现常见蓝屏错误消息的问题
    1. UNMOUNTABLE BOOT VOLUME(“无法安装的启动卷”)和INACCESSIBLE BOOT DEVICE(“无法访问的启动设备”)
    2. NTFS FILE SYSTEM(“NTFS文件系统”)
    3. SYSTEM THREAD EXEPTION NOT HANDLED(“系统会话异常未处理”)和KERNEL MODE EXCEPTION NOT HANDLED(“内核模式异常未处理”)
    4. PAGE FAULT IN NON PAGED AREA(未分页区域中的页面错误)
    5. DRIVER IRQL NOT LESS THAN OR EQUAL TO(驱动程序IRQL不是LESS THAN或EQUAL TO)
    6. THREAD STUCK IN DEVICE DRIVER(设备驱动程序中的线程阻塞)
  5. 查找有关错误消息的信息

本文适用于Microsoft Windows 8。
单击下面以更改操作系统。


对 Windows 中的蓝屏问题进行故障处理

持续时间:03:58
关闭的字幕:以多种语言提供 单击“Closed Caption”图标,然后选择所需的语言。


什么是蓝屏错误?

当 Windows 遇到某些情况时,它会停止并显示蓝屏,且以白色文本显示生成的诊断信息。这些错误的外观是术语“蓝屏”或“蓝屏”的来源。对于 Windows 8,蓝屏已更改,现在显示 ASCII ffrown face 和语句“Your PC ran into a problem that it not handle, and now it must restart.”,然后显示错误类型。熟悉的“OxXXXXXXXX”错误代码已删除。
在以下时间出现蓝屏错误:

  • Windows 检测到一个无法在不丢失数据的情况下恢复的错误
  • Windows 检测到关键的操作系统数据已损坏
  • Windows 检测到硬件出现不可恢复的故障
  • 这些年来,显示的确切文本已发生变化:Windows NT 4.0中显示密密麻麻的信息,而Windows现代版本中采用的信息相对较少。

步骤 1:检查操作中心以了解问题和解决方案

Windows 8的崩溃错误收集在“操作中心”中,为其它可联机获得的崩溃数据提供参考。要访问操作中心,请按照以下说明操作:

  1. 在开始屏幕中键入“问题报告和解决方案”,然后选择 查看所有问题报告 以查看计算机上发生的错误列表及其可能的解决方案,例如更新驱动程序、刷新系统 BIOS 或检查软件更新。
  2. 备选方法说明:
    1. 从屏幕右侧滑入以打开超级按钮栏(如果使用鼠标,请将鼠标悬停在屏幕右上角,然后向下移动指针以打开超级按钮栏),然后选择 Settings (设置)。或者按Windows+I键直接转到“设置”超级按钮。
    2. 选择Control Panel(控制面板)。
    3. 选择System and Maintenance(“系统和维护”)。
    4. 选择Problem Reports and Solutions(问题报告和解决方案)。

步骤 2:运行在线诊断程序

戴尔创建了一组在线诊断程序,可以识别计算机硬件的问题或可能造成问题的配置。浏览至 Dell Online Diagnostics 以获取更多信息并运行计算机扫描。


步骤 3:诊断出现常见蓝屏错误消息的问题


无法安装的启动卷

无法访问的启动设备

这两个错误都有类似的原因,相同的故障排除步骤也适用于这两个错误。这些Stop代码通常会在启动过程中出现。当您遇到其中一个Stop代码时,将会出现以下情况:

  1. 系统已完成开机自检(POST)。
     
  2. 系统已加载NTLDR,并将启动过程的控制权移交给NTOSKRNL(内核)。
     
  3. NTOSKRNL被混淆。它无法找到剩下的部分,也无法在认为被存储的位置读取文件系统。
    诊断此错误时,您的任务就是确定导致Windows内核混淆的原因,并解决此混淆问题。
检查事项
  • 系统 BIOS 中的 SATA 控制器配置如果 SATA 控制器从 ATA 切换到 AHCI 模式(或相反),则 Windows 无法与 SATA 控制器通信,因为不同的模式需要不同的驱动程序。尝试在 BIOS 中切换 SATA 控制器模式。
  • RAID 设置如果您一直在尝试 RAID 控制器设置,则可能会收到此错误。尝试将RAID设置恢复为自动检测(通常十分准确)。
  • 电缆拔插不当或错误 尝试重新拔插连接驱动器及其控制器的数据线两端。
  • 硬盘故障在硬盘上运行集成诊断程序。请记住:代码 7指示的是可更正的数据损坏,而非磁盘故障。
  • 文件系统损坏 从Windows安装光盘启动恢复控制台,并运行chkdsk/f/r
  • 未正确配置引导。INI (Windows Vista) 如果您无意中擦除或修补了 boot.ini 文件,则在启动过程中可能会收到停止代码0x7B。从Windows安装光盘启动恢复控制台,并运行BOOTCFG/REBUILD

NTFS_FILE_SYSTEM

此停止代码表示 NTFS 文件系统驱动程序遇到无法处理的情况,并且几乎总是由 3 件事引起:

  • 磁盘上的数据损坏
  • 内存中的数据损坏
  • 系统内存用竭(此情况通常只会在过载的服务器上出现)
检查事项
  1. 重新拔插内存和所有驱动器数据线,以避免出现因硬件安装不当或错误而造成的数据损坏问题。
     
  2. 运行内存和硬盘全面诊断程序。无法在此进行彻底的快速测试。您必须运行完整的系统诊断程序。
     
  3. 如果这些诊断程序均已通过,则请从Recovery Console(“恢复控制台”)运行全面系统检查(chkdsk /f /r),以检测并(可能)修复所有损坏的数据。
     
  4. 如果以上措施均无法解决此问题,则请重新安装Windows。
     
  5. 如果重新安装Windows也无法解决此问题,请更换硬盘。

     


系统会话异常未处理

内核模式异常未处理

这两个错误表示内核中运行的程序遇到了无法恢复的意外情况。它们具有相同的故障诊断和解决步骤。您可能需要使用Windows调试程序找出导致此错误的原因。

检查事项
  • 如果蓝屏信息中提到了某驱动程序或库文件,则请找出此文件隶属的驱动程序或应用程序,然后更新或禁用它。
  • 将系统BIOS更新为可用的最新版本。
  • 卸载所有最近安装的程序,并回滚所有最近安装的驱动程序。
  • 对计算机内存运行诊断程序。
 

PAGE FAULT IN NON PAGED AREA(未分页区域中的页面错误)

此 Stop 代码表示系统几乎总是出于以下原因尝试访问不存在的内存:

  • 驱动程序尝试访问一页不存在的内存
  • 系统服务(如病毒扫描仪)出现意外情况
  • 故障或未正确安装内存
  • 硬盘上的数据损坏

使用Windows调试程序查明导致这些错误的确切原因。

检查事项
  1. 如果蓝屏错误中提到了某驱动程序或库文件,则请找出此文件隶属的驱动程序或应用程序,然后将其更新为最新版本或卸载此驱动程序或程序。
     
  2. 如果在启动过程中出现错误,则请尝试启动至最后一次正确配置。
     
  3. 如果安装程序或驱动程序后出现错误,则请卸载此程序或驱动程序。
     
  4. 重新拔插内存和硬盘数据线后,请尝试对硬盘和内存运行全面诊断。

 

DRIVER IRQL NOT LESS THAN OR EQUAL TO(驱动程序IRQL不是LESS THAN或EQUAL TO)

此 stop 代码表示驱动程序尝试访问它不应访问的特定内存区域,即驱动程序本身存在缺陷。故障诊断的目的是找到此驱动程序,并禁用或更换它。使用 Windows 调试程序对此错误进行故障处理。
如果没有此调试程序,则您只能卸载/更新/回滚蓝屏信息中提到的包含驱动程序文件的驱动程序。


THREAD STUCK IN DEVICE DRIVER(设备驱动程序中的线程阻塞)

此蓝屏错误表示设备驱动程序(通常是显卡驱动程序)停滞以等待下一项操作(通常是硬件操作)。你们大多数人可能见过与此蓝屏关联 的nv4_disp.sys

检查事项:
  1. 请确保显卡驱动程序已更新为戴尔的最新版本。
     
  2. 系统 BIOS 已完全更新。
     
  3. 如果视频驱动程序和系统BIOS均已完全更新,则请咨询制造商以确定是否已将驱动程序更新为最新版本。
     
  4. 最后一种解决办法是尝试更换显卡。
提醒:重新安装 Windows 不可能阻止此错误再次出现。

 

其他信息

如果这些解决方案尚未解决您的问题,请尝试在 Web 上搜索其他解决方案。
单击下面的首选搜索引擎,然后描述您的问题,包括任何特定的错误消息。

 
提醒:Microsoft 错误检查代码参考网站有一个列表,详尽列出了各种蓝屏错误代码说明和可能的原因。如果您已记录 STOP 0xXXXXXX 代码,并且上述步骤未解决您的问题,请尝试在此站点上查找。
 

搜索 Dell  Search Microsoft  搜索 Google  Search Bing  此超链接会将您带往 Dell Technologies 之外的网站

 

Orsak

无可用的原因信息。

Upplösning

无可用的解决方案信息。

Artikelegenskaper


Berörd produkt

Inspiron, Latitude, Vostro, XPS, Fixed Workstations

Senaste publiceringsdatum

14 sep. 2023

Version

5

Artikeltyp

Solution