Alienware Desktops

Last reply by 07-27-2022 Solved
Start a Discussion
2 Jasper
2 Jasper

Aurora R8, AWCC buggy

Your latest Alienware Command Center is buggy. It automatically updated via the Microsoft Store, when I opened your app it downloaded some things and installed them. Restarted my computer it says again additional components required. I click download it goes to a box saying the same thing but the only way to close is to click and isn't downloading anything. When I close that it shows an update available in the top right in green, I click that shows the same box. I download your file on your website for the latest Alienware cc and that will not do anything. It just shows a white box that locks up and the only way to close that is task manager. 

Replies (21)
4 Tellurium

Sometimes you have to open and close AWCC a few times. After start up I always wait about 5-10 mins before opening up AWCC. Every once in awhile it will get confused and I just close out and open it back up. Sometimes it takes 2-3 times before it up and normal. 

3 Argentum

I got the new version working ok. IMO this new installer does not do a good cleanup, I mean deep cleaning. I had to check folders on the drive and remove a few old awcc install data etc. I tried to regular window  uninstall and remove the window store apps but still had the same  problem. Then I uninstall the alienware update app and cleaned out anything awcc in the update folders. Care must be taken not erase anything not related to awcc. Alienware update has to be reinstalled. You can use the new installer to repair awcc. it will make things right again. Also they seem to have shifted a few thing over to the window store installations. The service take a little longer to start, no big worry. So... it looks like a few conflicts between the old install and the new. But , for now it works.

2 Bronze
2 Bronze

I have the same problem with the Inspiron G15 5520. I tried everything:

Nothing helped. I put back the old version, but now the thermal sensors are missing (only the "loading" icon).

3 Argentum

If you want to stick with the old one you can go into windows /settings/apps and do a repair or download the apps from Dell website and re install. The ones on the windows. store have a newer version.

They seem to have change the way awcc is installed. So you may end up with a mix.

I can tell you my last step, that I believe made the new install work. I would suggest:

1- download Dell Update/Alienware Update Universal Application latest version.

2-Do a new manual windows restore point

3-uninstall the update universal app./restart

4-goto /promgram data/Dell folder   and delete the updateService folder

5-re-install the alienware universal app. restart computer by doing that a new folder is created.

6- retry the new installer.  After the restart it takes about 5-10 minutes for the new services to start

7- if anything goes wrong and you want to go back use the restore point you created.

You may want to get the free revo uninstaller program.

List of programs after new install with the new version numbers.awcc and oc service does not appear in the regular window section anymore









I received information today that the Dell Alienware Engineering team is looking into this issue. If we have more information, we will update everyone on this thread. Thank you for your patience.

Note, Inspiron Desktops user should be posting on the Inspiron Desktops board.

Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.


Our engineering team is requesting the logs from your computers. You can upload the files online and share the link with us. Thank you for your assistance. Below are the locations.







Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

Community Manager

Disable AWCC automatic updates

Method 1: Disable using Killer Control Center
* Open the Killer Control Center
* Find AWCC and Download/upload Host and click Block on the right
* At this point, when you open AWCC, the screen may be blank and the application would require some time to load up
* Once AWCC application, go to settings, then select field Misc. and disable Diagnosis Data and close the Window

Method 2: Disable using McAfee
* Open McAfee Firewall
* Click Change settings
* In McAfee Firewall, select Internet Connections and Programs, find AWCC and select it and scroll down till you see buttons Add/Edit/Delete -> Select Edit button
* Select Block and save

Method 3: Disable using Windows Defender Firewall
* Use "CTRL+R" or Win key and type “wf.msc” to open Windows Defender Firewall
* Within the left panel select Outbound Rules and within the list at the middle panel find AWCC and double-click or right click and select Properties. New Window would open. Within the General field select Block the Connection Apply the changes and Click OK

AWCC (Alienware Command Center), AW OC (Alienware OC Controls) Installation instructions

* Download/save the latest AWCC directly from the Aurora R8 drivers page (or your specific PC model drivers page) to your Windows desktop
* Download/save the latest Alienware OC Controls Application directly from the Aurora R8 drivers page to your Windows desktop
* Right click the saved AWCC, click Run as administrator. Follow the prompts
* Right click the saved Alienware OC Controls Application, click Run as administrator. Follow the prompts
* When done, restart the PC

Social Media Support

Locate your Service Tag or Serial Number

Community Manager

* Uninstall Windows update KB5014019
* Restart the PC
* Then try to install AWCC

Social Media Support

Locate your Service Tag or Serial Number

Community Manager

The new AWCC 5.x User's Guide page 10 has new installation instructions.


Social Media Support

Locate your Service Tag or Serial Number

Community Manager

AWCC is now available. Please update to the latest version and let us know if it helps.


Latest Solutions
Top Contributor