Highlighted
2 Bronze

17 R4, changing SATA Operation in BIOS from RAID to AHCI, Windows 10

Jump to solution

I bought a used Alienware 17 R4 that came with one SSD and an HDD with Windows 10 installed on the HDD.  The system SATA setting in BIOS was RAID when I got it. I changed the setting to AHCI and this locked me into a permanent Windows Repair loop, the only way out of which seemed to be reinstalling Windows.

I changed the setting back to RAID and the computer booted as normal. Did I miss a step or will I have to reinstall windows in order to change the SATA setting to AHCI?

BACKGROUND:

I'm trying to move the Windows installation to the SSD disk, but after cloning I can't get the BIOS boot setting to recognize the SSD as a boot device.  Many of the howto articles I found insist that you have to change the SATA setting to AHCI in order to see a second boot device so that's why I'm trying to change the setting.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
3 Argentum

Re: 17 R4, changing SATA Operation in BIOS from RAID to AHCI, Windows 10

Jump to solution

go to run >msconfig >boot and choose safe boot.

restart and immediately enter bios. change the setting from raid to ahci >save the changes and restart.

you will boot up in safe mode. now go back to msconfig and uncheck safe boot.

restart and your system should be using ahci mode when you get to the desktop.

View solution in original post

2 Replies
Highlighted
3 Argentum

Re: 17 R4, changing SATA Operation in BIOS from RAID to AHCI, Windows 10

Jump to solution

go to run >msconfig >boot and choose safe boot.

restart and immediately enter bios. change the setting from raid to ahci >save the changes and restart.

you will boot up in safe mode. now go back to msconfig and uncheck safe boot.

restart and your system should be using ahci mode when you get to the desktop.

View solution in original post

Highlighted
2 Bronze

Re: 17 R4, changing SATA Operation in BIOS from RAID to AHCI, Windows 10

Jump to solution

Thank you Bacillus1, that worked perfectly!

0 Kudos