WilliamEI
Phosphor

error code 10007

Jump to solution

Hello,

I have a little question about error of backup since 2 days.

After windows update, lot of avamar backup failed with 10007 error code.

Log says:

2013-12-13 09:46:28 avtar Info <6074>: VSS snapshot set creation successful

2013-12-13 09:46:28 avtar Info <5811>: - Traversing drive 'C:' kind 'Local Fixed Disk'

2013-12-13 09:46:28 avtar Info <7324>: Volume Type for "C:\" is "NTFS", Supports Compression=1, Encryption=1, ACLS=1, DataStreams=1, Reparse=1, Sparse=1

2013-12-13 09:46:28 avtar Info <5811>: - Traversing drive 'D:' kind 'Local Fixed Disk'

2013-12-13 09:46:28 avtar Info <5810>: - Not traversing drive 'Z:' kind 'CDROM'

2013-12-13 09:51:18 avtar Info <5163>: Backup complete, wrapping-up session with Server

2013-12-13 09:51:18 avtar Info <11035>: Reading 33 user profiles

2013-12-13 09:51:21 avtar Warning <16147>: AuthzInitializeContextFromSid failed: 2

2013/12/13-08:51:22.67899 [avtar]  ERROR: <0378> nbackmain - Windows structured exception ACCESS_VIOLATION in threadID 8344

2013-12-13 09:51:22 avtar FATAL <0378>: nbackmain - Windows structured exception ACCESS_VIOLATION in threadID 8344

2013/12/13-08:51:22.71000 [avtar]  ERROR: <5372> 0: ExpInterlockedPopEntrySListFault()+0x0 [0x7c81bb52]

2013/12/13-08:51:22.71000 [avtar]  ERROR: <5372> 1: 0x0019ffff

2013-12-13 09:51:22 avtar FATAL <5372>: 0: ExpInterlockedPopEntrySListFault()+0x0 [0x7c81bb52]

2013-12-13 09:51:22 avtar FATAL <5372>: 1: 0x0019ffff

2013-12-13 09:51:22 avtar Info <0000>: Starting graceful (staged) termination, error reported in nbackmain (wrap-up stage)

2013-12-13 09:51:22 avtar Info <7883>: Finished at 2013-12-13 09:51:22 Romance Standard Time, Elapsed time: 0000h:05m:02s

2013-12-13 09:51:22 avtar Error <5371>: Unhandled exception ACCESS_VIOLATION [0xc0000005], stack trace:

2013-12-13 09:51:22 avtar Error <5372>: 0: wcslen()+0x2fe [0x7c82a6ec]

2013-12-13 09:51:22 avtar Error <5372>: 1: Ordinal326()+0x12d4 [0x76f112d4]

2013-12-13 09:51:22 avtar Error <5372>: 2: Ordinal326()+0x1257 [0x76f11257]

2013-12-13 09:51:22 avtar Error <5372>: 3: Ordinal326()+0x1291 [0x76f11291]

2013-12-13 09:51:22 avtar Error <5372>: 4: Ordinal326()+0x1176 [0x76f11176]

2013-12-13 09:51:22 avtar Error <5372>: 5: LdrInitializeThunk()+0x24 [0x7c81a19a]

I saught it was a problem of DLL so I stop/start the avagent on client...  but it's always the same problem when I restart the backup...

If anybody has an idea

ps: the grid on 6.1 and client in 6.1.100-402

Ce message a été modifié par : WilliamEI

0 Kudos
9 Replies

Re: error code 10007

Jump to solution

Hello William,

Few questions. what is the windows client version you are running for backup ? Are they VM ? Did you make any changes to client properties ?

Recently I saw ACCESS_VIOLATION error in VMware which was a VMware issue.

I would suggest you to review event logs on client and try to find out any abnormal event related to windows and avamar backup.

Error code 10007 may occur if you have not updated FQDN for client.

Regards,

Pawan

0 Kudos
WilliamEI
Phosphor

Re: error code 10007

Jump to solution

Hello,

No, windows clients are not VM but physical machines in windows Server 2003 SP2.

News elements : we have lot of modification in all machines with error code 10007...  For example, for 5Gb of Datas, I have 2Gb of deleted files...

0 Kudos
Moderator
Moderator

Re: error code 10007

Jump to solution

Hey William,

Have you tried On-demand backup? Also have you tried with client initiated backup? What about these, does these work properly?

0 Kudos

Re: error code 10007

Jump to solution

Hello William,


Looks like your issue has been resolved. Just want to know what steps you took to resolve this issue ? Was it FQDN issue or Windows issue ? Please reply so that other users also can use this information.


Regards,

Pawan

0 Kudos
WilliamEI
Phosphor

Re: error code 10007

Jump to solution

Hello,

The "error code 10007" isn't resolved but we know why we have this problem and how to modify the config to ponctually solve.

I explain.

in local file avtar.cmd, we add parameter "--x05=65536".

We don't know this x05 parameter but the next backup succeed.

Support gave us this parameter for another problem, and we suppose it's about local memory of local hash file.

We ask and re-ask to EMC support to have an answer but nothing.

We suppose that we can change this parameter on grid (global evolution) but we are waiting for a answer...

The "error code 10007" is a global error, with lot of possibility of problems...  but we don't know why we had it on several windows server 2003 machines !

0 Kudos
ianderson1
Ruthenium

Re: error code 10007

Jump to solution

The --x05=65536 flag disables the collection of information from the user profiles on the system. The DTLT interface will not work for any backup created using this flag.

WilliamEI
Phosphor

Re: error code 10007

Jump to solution

Thank Ian,

I would be interested in documentaion about this parameter x05 : have you got ??   because I can't find it in all pdf avamar !

0 Kudos
ianderson1
Ruthenium

Re: error code 10007

Jump to solution

The "x" flags are (intentionally) not documented. They should not be used except when directed by support. Using them may cause unanticipated problems later (e.g. during restores).

0 Kudos
Karkee
Copper

Re: error code 10007

Jump to solution

This flag is workable and able to resolve my problem by using this but have doubt on Ian comment as now done restoration and same also has completed successfully.

Thanks,

Prem

0 Kudos