Highlighted
5ctbimb
Copper

Dell Optiplex 3040 - Boots but no video output

Hi there,

I've got a Dell Optiplex 3040 in my workshop at the moment. The computer seems to turn on: there's a light on the PSU, the HDD indicator flashes, the num lock toggles on and off and the traffic light on the ethernet port is active. However, there's no output from the HDMI port or the display port. The machine only has onboard graphics.

I'm thinking that the onboard graphics are at fault, but I don't have a graphics card that will fit in with the PSU in it's current location.

Any ideas for fixes on this? Thanks in advance!

0 Kudos
4 Replies
Mary G
Diamond

RE: Dell Optiplex 3040 - Boots but no video output

Did you try a diff monitor and new cable? Hard to solve this without any screen. Which model do you have? Only a couple of model 3040's support a discrete card. If you don't have MT or SFF model you can't install a card.

Supports optional discrete graphics (MT/SFF only): AMD Radeon™ R7 350X, AMD Radeon™ R5 340X

0 Kudos
5ctbimb
Copper

RE: Dell Optiplex 3040 - Boots but no video output

Thanks for the reply Mary. I've tested a new HDMI to DVI link cable and monitor and I'm still getting no results. Thank you for letting me know about the compatible cards. I did try removing the PSU and fitting the card I had in the workshop and it didn't work, which makes sense after your post. It's very frustrating when I can't even get into the BIOS to try and reset or flash new firmware etc. Thinking this may be a dud now as it's integrated. Spent my afternoon doing data recovery just in case.

0 Kudos
RoHe
Diamond

RE: Dell Optiplex 3040 - Boots but no video output

Have you tried clearing BIOS by removing the motherboard battery and pressing/holding the power button for ~30 sec, and then reinstalling the battery?

The problem testing an add-in video card is that unless the video setting in BIOS is set to Auto, instead of to Intel HD Graphics, the add-in card won't be recognized and only onboard video will work.  

From the 3040 service manual: NOTE: If you do not select Auto, the on-board graphics device will be present and enabled.

Hard to check that setting when there's no video output.

Possible CPU failure...??

Ron

   Forum Member since 2004
   I am not a Dell employee

0 Kudos
5ctbimb
Copper

RE: Dell Optiplex 3040 - Boots but no video output

I did try removing the CMOS battery but no joy there. As you say, there's so little can be done with no video output. I'm going to have to get it sent off I think, which is frustrating. Thanks for the ideas though!

0 Kudos