AtulC
1 Nickel

Do all Precision T7810 workstations support Intel E5-26xx v4 processors?

I have an year old Dell Precision T7810 workstation with an E5-2630 v3 processor. Dell has recently started selling T7810s with the newer v4 processors. How can I be sure that my workstation would work with a v4 processor? Does it require a certain Bios version? Are there other prerequisites for v4 processor support?

0 Kudos