Mark Goldhamer
1 Copper

RE: Opti 9020s with Intel I217-LM nics causing network issues

Everyone in this thread is seeing the symptoms of a common issue.  Your mileage varies depending on how much you have to go wrong when you get devices with this NIC.  Depending on the model you have, you may have a BIOS version that mishandles the Energy Efficient Ethernet feature.  You may have a driver that mishandles the EEEF.  You may have switches that get very confused by the TCP/IP v6 anycast traffic that results from these problems.

Bottom line....get the right BIOS and driver.....then when these devices go to sleep they wont spew data.  Enabling and disabling the NIC or messing with the power settings just restarts the timer until it will start spewing again.  Messing with the TCP/IP v6 settings might fool it is to not doing the anycast.  My situation was that things when VERY wrong when 3 or more slept on the same network switch.

This is one of those problems where you don't diagnose it....you just fix your systems and move on.

0 Kudos
AnguelS
2 Bronze

RE: Opti 9020s with Intel I217-LM nics causing network issues

Hi Anguel,

The problem you are describing does not appear to be the same problem we were having with the multicast storms occurring. At first glance, it appears that it might be a software/windows issue and not specific to the NIC itself.

Do you see this behavior on other machines on your network that do not have this NIC?

-Gordon

Hi Gordon,


Thank you for the reply. Now I finally could solve the problem. It turned out that it was caused by the VirtualBox bridged network driver. I have described my findings in my blog in details:

http://techie-blog.blogspot.de/2014/10/solved-network-connection-problems.html

Regards,

Anguel

0 Kudos
DMK111
1 Copper

RE: Opti 9020s with Intel I217-LM nics causing network issues

Hi

I have a similar problem, but with Dell Precision Tower 5810.

Im not sure about the others, but we are running 802.1x and having problems with this driver.

It will not authenticate and gives me a 169.x IP.

If I unplug and replug in the cable, it comes good. Then if I reboot, then I lose the IP again.

I have tried number of different DELL drivers and Intel drivers, and same problem.

If I plug it into NON 802.1x port, then all is good.

So, it seems to be an issue with 802.1x authentication with this driver.

I am working around this by the fix provided in this forum, which is to hard set to 100/full with reg change.

However, I cannot get it to work properly with 1G/Full. Has anyone tried this? We have 1G switch.

As usual, if you unplug and replug it comes good.

Any other suggestions to get it working on 1g/full is appreciated.

 

Thanks, DM.

0 Kudos
gtirmont
1 Copper

RE: Opti 9020s with Intel I217-LM nics causing network issues

Solution I have found is to boot on PXE before boot Linux. Then I can have WOL activated on Windows and I have Network on Linux. Boot On PXE first seems to reinit the card.

0 Kudos
Karvon
1 Copper

RE: Opti 9020s with Intel I217-LM nics causing network issues

Hello,

As I followed your topic to check the solution, I would like to share with you my fix.

Issue: Randomly the computer lost connection (many of you mentioned only when going to sleep, etc, not my case).

Solutions tried: Power management on NIC (disabled IPv6, not to sleep, etc), installed drivers offered in this topic, new ones, etc, nothing worked.

Real fix for me: Upgrade bios from A2 to A15, automatically it worked fine and didn't face the same problem again for more than 30 hours now. I did it remotely, very easy to "flash" the bios online.

The event viewer was reporting: 

e1dexpress

Intel(R) Ethernet Connection I217-LM

Network link is disconnected.

Hope this helps to someone.