Highlighted
JerryEco2
Bronze

Wake on LAN not working on Optiplex 9020

Jump to solution

I am not able to get Wake on LAN to work on an Optiplex 9020 (small form factor).  I have the following BIOS settings under Power Management:
- Deep Sleep Control -> Disabled- Wake on LAN -> LAN Only
- Block Sleep -> Block Sleep (S3 State)

I have the following settings for the Intel Ethernet I217-LM card:
- Wake on Magic Packet from power off state -> Enabled
- Wake on Magic Packet - > Enabled
- Wake on Pattern Match -> Enabled

When the computer is powered off, the network card has NO LIGHTS.  Does that mean that Wake on LAN is not properly configured?  What setting am I missing?

In case this is relevant: Windows 7 Pro 64-bit.
Thank you.
Jerry

Tags (1)
0 Kudos
86 Replies
wtmsin1
Bronze

RE: Wake on LAN not working on Optiplex 9020

Jump to solution

Hi,

I've 40 dell gx9020 SFF in my laboratory and I've got this same problem, pls advice.

Thanks.

--william

0 Kudos
Rune Lima
Copper

RE: Wake on LAN not working on Optiplex 9020

Jump to solution

I got the same problem aswell, two 9020 systems running Windows 7 Pro x64. I am guessing this is related to mailfunction of the bios from dell, because it always turns off the lan port, even in S3.

Fix this DELL!

Rune

0 Kudos
Dannnnno
Bronze

RE: Wake on LAN not working on Optiplex 9020

Jump to solution

We have many Dell Optiplex 9020s (Tower form factor), and I'm not able to get Wake on LAN working for them, either.  Have never had a problem with prior Optiplex models (GX620, 745, 755, etc), but these are the first 64-bit Windows 7 machines to go into production (the others are running 32-bit Windows XP).  Hope this gets fixed soon!!

Tags (1)
0 Kudos
Dannnnno
Bronze

RE: Wake on LAN not working on Optiplex 9020

Jump to solution

After quite a bit of trouble-shooting and testing, I have discovered a way to work around the problem:

  1. Make sure the BIOS is at version A02 (downgrade, if needed).
  2. Within the BIOS - Power Management, set "Wake on LAN" to LAN only
  3. Within the BIOS - Power Management, set "Deep Sleep Control" to Disabled

Once I made the above changes, the Optiplex 9020s now were able to be powered on remotely with the same WOL utilities I use for all of the other Dell computers on our network.  In my testing, I started with the latest BIOS version (A05) and kept backing off, and A02 was the first version where the above settings worked successfully.  Of course, I would like the ability to update to the latest BIOS, so hopefully Dell will offer an update to fix the issue.

0 Kudos
m.j.h.
Copper

RE: Wake on LAN not working on Optiplex 9020

Jump to solution

Thank you - this worked for me! I was on A04 before, and after trying A05, where it also did not work, I downgraded as per your suggestion. I immediately noticed that now the network card is on when the PC is in standby mode or power off mode (blinkenlights on network card still active), and wake-on-LAN finally works.

Note: Although the network adapter stayed on after my first poweroff, wake-on-LAN did not work until I did a complete power cycle (boot to Windows, shut-down from Windows). I assume that some things are not properly loaded unless you do a full boot sequence.

I am surprised how painless a BIOS-Upgrade and BIOS-Downgrade is. All my previous settings are still there, which is nice.

0 Kudos

RE: Wake on LAN not working on Optiplex 9020

Jump to solution

I can confirm that downgrade to BIOS A02 (as long as you're not running UEFI boot) works to fix WOL both in S3 and S5 power states.  I can also say that a Dell rep has suggested to me that it takes a motherboard replacement to get WOL working with any BIOS more recent than A02.  So, that doesn't bode well for enterprise clients.  I will post back when/if I can verify or deny that the replacement motherboards for these systems that won't WOL with later BIOSes will allow WOL to work with later BIOS and new MB.

Tags (1)
0 Kudos
RoHe
Diamond

RE: Wake on LAN not working on Optiplex 9020

Jump to solution

I pinged my Dell tech contacts about this, especially you've shown Wake on LAN works with A02, but not later versions.  Let's see what they have to say... 

But this brings back the old adage:   Unless a new BIOS release fixes a problem you actually have, don't update to the newer version.

Ron

Forum Member since 2004
I am not a Dell employee

0 Kudos

RE: Wake on LAN not working on Optiplex 9020

Jump to solution

Fair enough about the caveat, but they've had THREE BIOS revisions since breaking WOL; I'd think they could get it right in all that revision.  Moreover, their own Dell Update (or whatever it's called) utility with default settings will automatically upgrade 9020s to BIOS A04 which also breaks WOL.  There was a time when I would have agreed with you about not updating BIOS unless there's a known problem with a known solution in an upgraded version, but I've been berated by support reps too many times about running "out-of-date" BIOS on desktops and laptops; so, I routinely update to current on brand new PCs prior to deployment.

0 Kudos
RoHe
Diamond

RE: Wake on LAN not working on Optiplex 9020

Jump to solution

they've had THREE BIOS revisions since breaking WOL

Well, maybe you're the first ones to report the WOL problem in versions after A02. And if nobody told 'em WOL got broken... 

Ron

Forum Member since 2004
I am not a Dell employee

0 Kudos