rmfalconer
1 Nickel

Enable TPM with Command Configure

I've tried many times to enable TPM using an .exe created with the Command | Configure 3.0.0 utility. No matter what I try, when I try to activate TPM, I get an error in the log that says:

cctk - Error in Setting the Value.

Note: To set TPM - 1. Admin Password must be set , 2. TPM must not be owned and 3. TPM must be deactivated.

I have tried with a password and without a password. When I run the .exe, all of the above 3 items are valid.

I am able to enable TPM but it will never switch to 'Activated'

Any thoughts?

7 Replies

RE: Enable TPM with Command Configure

Hi RMFALCONER, 

Please try the below options and if you are still facing issues,  please help us with more information on the Configuration and Bios Version. 

1. Try to clear the TPM in Bios/F2 screen and try the steps again.

2. System must be restarted once when the TPM is made ON ( enabled ) .

3. Also please check if steps in video are working fine manually after installing DCC. 

 

Regards,

Karthik.C

Tags (3)
0 Kudos
rmfalconer
1 Nickel

RE: Enable TPM with Command Configure

Karthik,

When I get to step 6 in the video, I receive the same error message as when using the packaged executable:

Note: To set TPM - 1. Admin Password must be set , 2. TPM must not be owned and 3. TPM must be deactivated.

I received this error even if I restart the computer after completing step 5, which is enable TPM.

CCTK version is 3.0.0

Bios version is A24

0 Kudos
rmfalconer
1 Nickel

RE: Enable TPM with Command Configure

If I just enable and activate the TPM settings in the bios manually, it works fine.

0 Kudos
djbrightman
1 Nickel

RE: Enable TPM with Command Configure

We don't put together a .EXE, but have a WinPE USB with CCTK.  From that we have an 'EnableTPM.cmd' BATch file that runs and works OK on devices that HAVE NOT had any previous TPM settings.

The commands we use are:

x:CCTK.exe --setuppwd=P4$$w0rd
x:CCTK.exe --tpm=on --valsetuppwd=P4$$w0rd
x:CCTK.exe --tpmactivation=activate --valsetuppwd=P4$$w0rd
x:cctk.exe --setuppwd= --valsetuppwd=P4$$w0rd

i.e. we set the password, turn tpm on, activate tpm, then remove the password

Not sure if this helps your situation but maybe it will?!?

All the best

David

0 Kudos
Sid.A
1 Copper

RE: Enable TPM with Command Configure

I am having the same problem on E7250 laptop.

the first 2 command run just fine bit when it comes to activating TPM, I get same message that TPM must be deactivated,....

Enable123
1 Nickel

RE: Enable TPM with Command Configure

Have you tried creating 2 EXE files: One to set the password and one to enable TPM?

0 Kudos
Enable123
1 Nickel

RE: Enable TPM with Command Configure

This is how i fixed it for E7250:

Create one EXE file to setup password

Create another EXE to enable and activate TPM, when clicking Export EXE select the option to use password information and put th epassword you have set in EXE file 1

Install first EXE file then second one

All the information is here: http://media.community.dell.com/en/dtc/attach/enabling_tpm_with_cctk_sce.pdf