LHDell7
1 Copper

MEM not seeing more than 1 path

Jump to solution

Hello.  I am having an issue with the Dell EqualLogic Multipathing Extension Module for VMWare and hope someone can help.  After following the installation steps in the included documents, I am only seeing one path for each LUN although I have 4 iSCSI adapters setup.

iSCSI networking was setup via the setup.pl script.  Installation of this script as well as the MEM module was done through the VSphere CLI.  After installation I only see one path at a time for each LUN.  According to the installation documentation, I should see multiple paths.  I have verified that failover works (pulled a cable, and another iSCSI port takes over), but I am concerned I will not get any load balancing features. 

Is this expected behavior? Since the documentation has pictures that show otherwise, I want to be sure.

 

Here is a brief rundown of the configuration. I can provide more info if needed.

Storage – EquaLogic PS4000 (firmware 5.1.2)

Group IP – 10.10.10.1

Access to LUN – setup for iQN to ESX software adapter only right now

Shows only one iSCSI connection to each LUN.

 

Switches

                Two Dell 6224 switches connected with stacking module.  iSCSI specific settings setup for iSCSI VLan (MTU 9216, flow control, STP disabled, fast port)

 

Server – Dell R710 with 12 Broadcom 5709 NICs (latest firmware)

ESXi 5.0 managed with VCenter 5.  Latest updates with Update Manager as of about 3 weeks ago.

Networking (created by the setup.pl switch)

                1 switch tied to 4 iSCSI vmkernels and 1 storage hearbeat

                iSCSI0 – 10.10.10.151 – NIC 2

                iSCSI1 – 10.10.10.153 – NIC 3

                iSCSI2 – 10.10.10.155 – NIC 4

                iSCSI3 – 10.10.10.157 – NIC 6

                Storage Heartbeat – 10.10.10.161

                MTU - 9000

Storage

                When I go to the Managed Paths option under a LUN’s properties, I only see 1 path.

                Dell_PSP_EQL_Routed is selected

Storage Adapters

                Under the software iSCSI adapter, I only see 1 path per LUN.

0 Kudos
1 Solution

Accepted Solutions
LHDell7
1 Copper

Re: MEM not seeing more than 1 path

Jump to solution

Found the problem.  Corrupt switch config on one of the 6224's.  All indicator and activity lights looked fine on the display, but going into managment, it was hosed.  Moved the iscsi ports over to the other switch and refreshed everything.  Picked up all 4 ports as active.   Thanks again!

9 Replies

Re: MEM not seeing more than 1 path

Jump to solution

Hello,

That's not expected behavior.   Do you have an Enterprise or Enterprise Plus license?

If you manually switch to VMware Round Robin, do you get multiple connections then?

If not, then there's a problem with the configuration not MEM.

Make sure you have build 515841 or better.  That has two important iSCSI fixes, not related to this issue.

Regards,  

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

LHDell7
1 Copper

Re: MEM not seeing more than 1 path

Jump to solution

Thanks for the quick response Don.  

We have Enterprise licenses.  Switching to RR had no effect.

Our build is 5.0.0 - 469512.   I setup Update Manager and ran all the latest Critical and Recomended updates a few weeks ago.  I will need to double check to see why it is not at the 515841 level.

Also wanted to mention that in the software iSCSI adapter properites page, under Network config....all 4 iSCSI adapters are listed, but only one is listed as "Last Active".  The others are "Not Used."

0 Kudos

Re: MEM not seeing more than 1 path

Jump to solution

You've named your problem.  The "unused" ports mean they're not bound properly to the iSCSI adapter.  That binding is what causes the iSCSI initiator to create sessions via those ports.  Otherwise it just uses the default.  Make sure on those VMKs that the other physical ports are set to UNUSED.  I.e.  VMK1/NIC1 is active and NIC0,2,3 are UNUSED.  Then VMK2/NIC2 is active and NIC0,1,3 are UNUSED, etc....

The latest build came out very recently, near end of Dec.  Might have just missed it.

Regards,

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

LHDell7
1 Copper

Re: MEM not seeing more than 1 path

Jump to solution

My mistake on the version number.  Looking at the wrong number.  At the ESX console it states VMKernel Build 515841.

I beleive the networking is already setup the way you described.  

vSwitchISCSI

Under properties, there is a listing for iSCSI0, iSCSI1, iSCSI2, and iSCSI3.

For each one, iSCSI Port Binding is enabled.  Under the NIC Teaming tab, the checkbox for "Overide Failover Options" is set.  There is 1 Active NIC and 3 Unused.  Fore each iSCSI kernel, they use a different NIC.

0 Kudos

Re: MEM not seeing more than 1 path

Jump to solution

I would suggest opening a case with Dell/EQL support.  A quick WebEx will probably fix it.  Somewhere in the binding process it's broken.  My personal process has been to manually configure (or via shell script) configure iSCSI then layer on MEM afterwards.   That's a personal prejudice on my part.

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

0 Kudos
LHDell7
1 Copper

Re: MEM not seeing more than 1 path

Jump to solution

I will look into doing that.  Thanks for your help, much appreciated.

0 Kudos

Re: MEM not seeing more than 1 path

Jump to solution

You're welcome.  Sorry didn't have pat answer ready.  That's not an error condition I've seen before.

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

0 Kudos
LHDell7
1 Copper

Re: MEM not seeing more than 1 path

Jump to solution

Found the problem.  Corrupt switch config on one of the 6224's.  All indicator and activity lights looked fine on the display, but going into managment, it was hosed.  Moved the iscsi ports over to the other switch and refreshed everything.  Picked up all 4 ports as active.   Thanks again!

Re: MEM not seeing more than 1 path

Jump to solution

Excellent catch!  

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

0 Kudos