Highlighted
2 Bronze

CPU is always at max frequency [SOLVED]

Jump to solution

It's been a couple of weeks(?) that the CPU of my Dell inspiron 7370 is always running at maximum frequency (around 3.80 GHz), even if the system is idle. For this, the fan runs at full speed making noise.

Windows 10 (build 10.0.18362.295, always updated).
Periodically checking with Dell Command Update for updated components.

This is my Task Manager, you see idle state but high frequency.

task.JPG

 

I use the Balanced power plan with minimum 5% frequency. But it is ignored and it is always at full speed.
Weird thing is that I tried to lower the 100% value to 50%... 20%.... 5%... but nothing. CPU is always at full speed. And only if I switch to Power Saver, then the CPU frequency drops correctly!

power.JPG

 

What could be the reason?

 

Labels (3)
0 Kudos
1 Solution

Accepted Solutions
Highlighted
2 Bronze

Re: CPU is always at max frequency

Jump to solution

SOLVED!

Intel SpeedStep is enabled. PowerPlan has minimum CPU set to 5%. So what other component is responsible to keep the CPU at 100%??

Well... turns out that this Windows 10 dialog is another thing that affects CPU frequency:

Capture.JPG

 

If the slider is set to "Best", this guy keeps the CPU at 100%. I moved it to "Better" (middle) and finally the CPU works as configured in power plan!

 

 

View solution in original post

5 Replies
Highlighted
2 Iron

Re: CPU is always at max frequency

Jump to solution

Check if Intel speedStep is activated. You have to go to the BIOS menu to check. 

 

0 Kudos
Highlighted
2 Bronze

Re: CPU is always at max frequency

Jump to solution

It is checked in BIOS.

0 Kudos
Highlighted
2 Bronze

Re: CPU is always at max frequency

Jump to solution

SOLVED!

Intel SpeedStep is enabled. PowerPlan has minimum CPU set to 5%. So what other component is responsible to keep the CPU at 100%??

Well... turns out that this Windows 10 dialog is another thing that affects CPU frequency:

Capture.JPG

 

If the slider is set to "Best", this guy keeps the CPU at 100%. I moved it to "Better" (middle) and finally the CPU works as configured in power plan!

 

 

View solution in original post

Highlighted
1 Copper

Re: CPU is always at max frequency

Jump to solution

Well done. This was indeed the issue. Was vexed by this for a month.

0 Kudos
Highlighted
1 Copper

Re: CPU is always at max frequency [SOLVED]

Jump to solution

He, 

problem was solved for XPS 15 BIOS XPS_9550_1.12.0 but now occurs again with latest BIOS XPS_9550_1.13.1;

so, problem seems to be with the BIOS; ever since I did a BIOS update, I found similar problems of staying at maximum frequency and not going below 3.2GHz, even system is almost 100% idle.

so, at least for the XPS 15 9550 the following BIOS have or have not such problems:

  • older or equal XPS_9550_1.9.0 => no problems with "maximum frequency"
  • XPS_9550_1.11.2 => system always runs close to maximum frequency, even if powersave governor is used with almost 100% idle time 
  • XPS_9550_1.12.0 => runs again perfect, no problems with "maximum frequency"
  • latest XPS_9550_1.13.1 => again; system always runs close to maximum frequency, even if powersave governor is used with almost 100% idle time

 

regards,

Oliver

0 Kudos