Inspiron

Last reply by 11-07-2021 Unsolved
Start a Discussion
3 Argentum

Dell 7706 with WD19 - UHD support

Hi.

I own the upper combination and also a WD19TB. I get UHD 60Hz working for the external monitor with WD19TB only but from the specs it should be possible with single monitor also with WD19. Perhaps it is constrained by 7706 DisplayPort support but I cannot find any specification for DisplayPort over USB-C with 7706. Is there something wrong or simply not supported?

Cheers

Nils

Replies (12)
7 Thorium

@Augur  That would be up to them. But since I linked your thread, they know how to find you. I agree it should be easy to reproduce at this point based on the data points available. But the claim of HBR3 support in the dock manual isn’t a mistake, because other setups that would only work if the dock supported HBR3 do work. But this type of stuff happens. The XPS 13 9300 at least initially wasn’t able to run dual 4K 60 Hz through a WD19TB even though it should’ve been able to, and it could run that display setup through other docks, and other systems could run dual 4K 60 Hz through a WD19TB. I just yesterday got a CalDigit dock for my wife and found that it has an issue with her dual display setup where the display on one of the HDMI outputs cuts in and out, even after swapping cables. But if I try another laptop with that dock and display setup, it’s fine. If I try her laptop with another dock but the same displays, it’s fine. And if I try her laptop and this dock with another display model, it’s fine. But the one setup that I actually need to work properly doesn't, even though it obviously should.


3 Argentum

If it would be helpful your contact can contact me. But I think it would be very easy to reproduce it. Looking forward to know if it is a bug or perhaps a mistake in the manual.

7 Thorium

@Augur  You might want to take a look at this thread that reports the same problem with two other systems, and where I linked to two more threads that describe this issue with yet another system model. It’s also where I posted mentions about this to a helpful Dell contact, which I’ve now just done about your own thread here.


7 Thorium

@Augur  The explanation is that the dock is not operating as designed. The documentation for both products, which you can find on Dell Support, indicates that they support 4K 60 Hz when paired with a system capable of DP 1.3/HBR3 over USB-C. Your system supports that, but your system and others do not get 4K 60 Hz output through a WD19. I strongly suspect a firmware issue here. Unfortunately, wanting to get it solved is unlikely to result in a fast solution. I already raised this issue with an internal Dell contact after seeing the other reports of this problem I alluded to earlier, since that person has previously been helpful in getting problem reports like this to the people in a position to fix them, but I haven’t heard back on this yet. And even when I have on previous issues, firmware fixes take time to investigate the problem, find a solution, test it, etc.


3 Argentum

@jphughan @DELL-Cares : The situation is like this:

DA300: 4k 60Hz
WD19: 4k 30Hz

DA300 behind WD19: 4k 30Hz

It seems that somehow WD19 dock not get the bandwidth trough that is needed. If this is explainable it would be fine but if this is a bug in the docks firmware I would like to get it solved. Actually I cannot find any good information about it.

7 Thorium

@Augur  The DA300 is a great data point to have.  I hadn't seen that before.  That reinforces my suspicion that in cases where this issue exists, the problem is with the dock firmware rather than some issue that affects multiple systems.  The WD19 and DA300 should behave identically in this regard because they both configure the USB-C link to support video and USB 3.x data, and both support DisplayPort HBR3 over USB-C in order to achieve 4K 60 Hz even in this USB-C link configuration.  At least that is what is supposed to happen.  Obviously the WD19 isn't behaving as designed in certain cases.


3 Argentum

As I own some Dell models and also my company I tested it with a DA300 mobile dock. My monitor is driven correctly with UHD 60Hz. So it looks like a bug for me with WD19?! Or is there a explanation for this different behavior of the docks?

@Augur  It’s true that Intel’s GPU specs can potentially be constrained by what the system manufacturer decides to design. For example if the GPU can handle four displays but there aren’t enough outputs on the system to run that many, then that particular system wouldn’t be able to run four displays. But I personally don’t think that is what’s happening with the dock. This sounds more like a firmware issue to me. But since you mentioned outputs, what output on the dock are you using? Have you tried any others? I know that with both the WD19 and WD19TB, some users have worked around various glitches by using the USB-C port on the back of the dock as a video output. If your display has a DP input I’d suggest a USB-C to DP cable. If it only has HDMI, then go with USB-C to HDMI 2.0. That shouldn’t be necessary, and I don’t even know if it will solve this specific issue, but sometimes workarounds that should be unnecessary do solve issues.


Hi


Social Media Support

#IWork4Dell
Find your Service Tag


If still under warranty, click the "Get help now" icon on the right to start a live chat session. Currently only available in the USA.

3 Argentum

Let me add that after disable FreeSync in the monitor I can reach UHD with 30Hz. So additional 30Hz are missing according the manual...

I upgraded from WD15 to get most out of my monitor but actually the max. output is the same...

Top Contributor
Latest Solutions