Inspiron

Last reply by 05-26-2022 Solved
Start a Discussion
2 Bronze
2 Bronze
5819

Dell G5 15 5587 does not boot GRUB or systemd-boot

So I have a Dell G5 15 5587 laptop with an NVMe SSD. I have replaced the original 128 GB NVMe SSD with a 512 GB NVMe SSD. I have installed Windows on it and then shrunk the Windows partitions to about half of each drive (half of SSD and half of HDD) to create place for my Linux install.

So I started by attempting to install Arch Linux on it. All went fine with the install and I installed GRUB without an issue until I had to reboot. When I rebooted it waited a second or so and then went to Windows. I then used the one-time boot menu to force it to go the the UEFI entry that points to the installed GRUB. It then went black for a second and then went to the Dell system check /  recovery environment. So I then attempted to place it on the fallback path for the EFI boot but that did not work.
So I attmpted to install sytemd-boot (using the bootctl command) but here when I attempted to boot it also failed in the same manner that GRUB did.

I then used a USB stick containing Linux Mint (which directly uses the Ubuntu installer) to install a Linux Mint. It all seems to install rather fine without any errors but when I attempt to boot the same behaviour as with the previous two attempts occurs (skipping if not explicitly booting it and system check environment if explicitly booting to it).

So I have disabled secure boot and Legacy ROM boot options and the system boots in UEFI mode.
The weird thing is that the sticks boot fine (the Arch stick uses systemd-boot iirc and the Mint stick uses GRUB) but when attempting to boot from an internal drive it just straight up fails.

tl;dr: system does not boot GRUB or sytemd-boot but does boot fine from USB stick

Solution (1)

Accepted Solutions
2 Bronze
2 Bronze
4006

So I know it's been ages and I found the solution a long time ago and then forgot what it was. Recently I had someone else try a solution that ended up working, so I am pretty sure this was what I did as well.

The issue is that the tools like efibootmgr for some reason are in capable of actually writing the path correctly for the entry they create on these dell systems. So what you have to do is you need to go through a normal install and once that install is done, you need to reboot and go into the bios.
Once in the bio you will find the boot options and you need to go to the boot options and change the new boot option that was created with your last install. What you need to change about it is the path that it points to within your EFI partition. Once you change that you can set it to your default option and it should simply boot to GRUB or whatever that boot entry points to.

View solution in original post

Replies (5)
2 Bronze
2 Bronze
5050

Hello,

I am not sure if you still have this problem, but I have the same laptop and the same problem as you did. However, I finally managed to fix it.

What I was apparently doing wrong was that I was placing the grub and the /boot partition on separate drives. Once I moved my /boot partition to the /dev/nvme by creating a new partition, it started working. I also had experimented with placing both the grub and the /boot on the HDD. That had worked too. Hope this helps.

2 Bronze
2 Bronze
4360

i have the same problem

 

2 Bronze
2 Bronze
4104

Any luck with this? I have the same problem. Tried doing a fresh install of Arch and can't boot internal storage UEFI bootloaders other than Windows anymore. Given I've had the previous install which worked just fine for nearly 2 years, I suspect one of the BIOS updates borked it.

2 Bronze
2 Bronze
4007

So I know it's been ages and I found the solution a long time ago and then forgot what it was. Recently I had someone else try a solution that ended up working, so I am pretty sure this was what I did as well.

The issue is that the tools like efibootmgr for some reason are in capable of actually writing the path correctly for the entry they create on these dell systems. So what you have to do is you need to go through a normal install and once that install is done, you need to reboot and go into the bios.
Once in the bio you will find the boot options and you need to go to the boot options and change the new boot option that was created with your last install. What you need to change about it is the path that it points to within your EFI partition. Once you change that you can set it to your default option and it should simply boot to GRUB or whatever that boot entry points to.

660

I have the same problem here in may 2022. I have replaced the original ssd with a 1 tb ssd and there's still a combi hdd 1 tb too on which I tried to install ubuntu and later Manjaro. Everything went fine when I boot into Manjaro, but then i chose windows from the bootloader and guess what happened? After a little while, "wait a little while" the sign said and then i got a screen where I should choose keyboard language, which I did and then, nothing. Tried to repair windows boot, but no. I could still boot into Manjaro though, but that was not the point.
I thought I was fine dual booting on separate hdd. I have done this 1000's of times on other computers, why doesn't this model work?

Latest Solutions
Top Contributor