Inspiron

Last reply by 06-14-2022 Solved
Start a Discussion
2 Bronze
2 Bronze

Inspiron 5510, Dell Adaptive Brightness

My laptop is a Dell Inspiron 5510 with an i7 processor and Intel Iris Xe Graphics. My problem is that the computer automatically adjusts the screen brightness based on what images are being displayed on the screen. (This happens only when the laptop is running on battery when it's plugged in there's no problem) For instance, when I open up a word document the screen becomes very bright because of the white background it is displaying but when the screen displays a darker image like a webpage with a black background the screen brightness noticeably dims. At first, I just assumed this was some graphics or power-saving setting. Is there some well-hidden setting causing this, is my laptop screen defective, or is this just the way the laptop is? I need to know. It's driving me nuts. ( I don't see an option of adaptive brightness in advanced power settings>>display)

Replies (13)
2 Bronze
2 Bronze

me too have the same issue.

and there is no ''eco mode" in bios either

2 Bronze
2 Bronze

On my 7506 2-n-1 with Intel iRIS MAX graphics, it took an updated driver from Intel for my auto brightness issue to be solved. None of the solutions above worked for my device.

2 Bronze
2 Bronze

Yes, it was the Eco Power setting in the BIOS that worked for me. I have an Inspiron 3511 and this had been driving me nuts for months!

Finally issue resolved, run the BIOS and turned off the ECO POWER mode from the Brightness option.

2 Bronze
2 Bronze

Bought this laptop 3 days ago, facing the same exact issue.

Thanks very much Mayank...unfortunately, I tried both tricks, but still doesnot work...

Hey bro,

 

You can look into your Intel Graphics Command Center and check options under the Power.

Disable all the battery saving stuff.

 

See if it helps.

 

If the above setting don't work then go to control panel and then search for power. Under power options select choose a power plan and then select balanced power plan. See if it helps.

In my case this of Inspiron 5510 the second trick does the job. 

Check if it works for you.

I have inspiron 7306 2n1 ... I have the same problem, and I donot have the "Eco Mode" option in the BIOS system

 

2 Bronze
2 Bronze

I have exactly the same problem with Inspiron 7306 2n1...I am looking for help with this please

Boot into the BIOS setup using F12 button.

 

Go to the DISPLAY section and then disable EcoPower which is the main culprit. That should solve your issue.

Also, I would recommend you to do the same in future whenever you buy a new laptop from DELL. It is so much intrusive by DELL to keep the option enabled by default.

 

Let me know if it helps and mark the solution as accepted if the solution works for you.

Top Contributor
Latest Solutions