Dr.diSousa
2 Iron

root user seems to lost permissions

Jump to solution

Hi, I'm getting these errors executing isi status with root user.

Any idea?

login as: root
Using keyboard-interactive authentication.
Password:
Last login: Wed Aug 13 19:47:58 2014 from p0mficsaas1-3
Copyright (c) 2001-2012 EMC Corporation. All Rights Reserved.
Copyright (c) 1992-2011 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.

Isilon OneFS v7.0.2.8


P0mficsaas1-1# isi status
Cluster Health:   [n/a ]

!! No information on the cluster is available:
!! [/ifs/.ifsvar/modules/flexnet/flx_config.xml] file could not be
!! opened: Invalid argument

P0mficsaas1-1# isi job status

!! status command failed: Permission denied

P0mficsaas1-1# whoami

root

P0mficsaas1-1#

The same in the four nodes. I've also rebooted one node and the problem is still there....

Thanks in advance.

Dario

IPM

Labels (1)
Tags (1)
0 Kudos
1 Solution

Accepted Solutions
Dr.diSousa
2 Iron

Re: root user seems to lost permissions

Jump to solution

Hi... Found the issue..

Customer had a problem with the ICAP Server (Antivirus) and they had the settings configured to not allow acces to file if we're unable to scan it...

After change this option all started to work fine again....

Thanks for your help!

Regards

Dario

IPM

0 Kudos
4 Replies
Highlighted

Re: root user seems to lost permissions

Jump to solution

Dario,

I would suggest contacting support .  Have you recently created an SMB share in the WebUI at /ifs?  There is an option when creating any SMB share called 'Apply Windows Default ACLs'.  If a new share at /ifs is created and this option is not changed, it changes the permissions on all data under /ifs, including /ifs/.ifsvar.  Take a look at the file identified upon login:

ls -le /ifs/.ifsvar/modules/flexnet/flx_config.xml

Mine show: (sorry can't copy and paste for some reason at the moment:

(6,4,0)  root     wheel

~Chris

chughh
2 Iron

Re: root user seems to lost permissions

Jump to solution

Hello,

Please check if /ifs/.ifsvar/modules/flexnet/flx_config.xml exist on all nodes also if not then copy flexnet.xml from healthy node to node where file i not available.

# md5 /ifs/.ifsvar/modules/flexnet/flx_config.xml  <output should be same>

then try isi status it should work fine.

Dr.diSousa
2 Iron

Re: root user seems to lost permissions

Jump to solution

Hi... Found the issue..

Customer had a problem with the ICAP Server (Antivirus) and they had the settings configured to not allow acces to file if we're unable to scan it...

After change this option all started to work fine again....

Thanks for your help!

Regards

Dario

IPM

0 Kudos
securityjm
1 Nickel

Re: root user seems to lost permissions

Jump to solution

Was this setting changed on the isilon or the ICAP server? I don't see anything on the isilon side that matched this description.

0 Kudos