bisebaer
1 Nickel

RE: Bios bug: Latitude 7440

I have the same CPU speed problem when waking from sleep with my Latitude E5540, but only since I updated to bios A12. (I also updated to Windows 10 but I don't think it's related to that update?)

Strange thing is that when I put the laptop to sleep by closing the lid, and I then open the lid, the problem occurs; but when I press the power button to put the laptop to sleep (and even close the lid), the problem doesn't occur when I wake the machine from sleep ...

Very annoying.

0 Kudos
lithetails
1 Nickel

RE: Bios bug: Latitude 7440

Nope, no news from Dell.

0 Kudos
Doug Smythies
1 Nickel

RE: Bios bug: Latitude 7440

For linux users suffering from CPU frequencies lower that what should be the minimum available for their processor (for 4th gen, typically less than 800 MHz, and typically about 600 MHz), for 5th gen less than 500MHz) I am looking for additional confirming evidence that the root issue is that Clock Modulation is enabled. Method of test:

1.) (needed once per boot) sudo modprobe msr
2.) before any suspend: sudo rdmsr -a 0x19a
3.) after a suspend that results in the low CPU frequencies:
 sudo rdmsr -a 0x19a
4.) If the result from step 3 is that bit 4 is 1, then:
 sudo wrmsr -a 0x19a 0x0
and check it:
 sudo rdmsr -a 0x19a
5.) Are the CPU frequencies O.K. now?

Depending on your linux distribution, a recent version of msr-tools
might be requiredto provide wrmsr and rdmsr.

For anybody from Dell that sees this: Can you confirm or deny that
you use Clock Modulation in your BIOS when you resume from
suspend on battery?

Note 1: The current version of the (linux) intel_pstate CPU frequency
scaling driver is not compatible with any use of Clock Modulation,
resulting in driving the target pstate to minimum, regardless of load.
What does that mean? Most typically, the Clock Modulation is 75%,
and so you end up stuck at around 600 MHz. There will still some
variation in CPU frequency, done by the processor itself within the range
of pstate 8.

Note 2: Myself, I do not suffer from this issue. I'm just attempting to get to
the root issue of all the complaints about CPU frequency stuck below what
should be the minimum for the processor.

0 Kudos
n13260
1 Nickel

RE: Bios bug: Latitude 7440

I am experiencing CPU frequencies lower that what should be the minimum permanently, not only after suspend. I followed your instructions immediately after boot and login.

  • Dell XPS13 (9343)
  • BIOS A05
  • BIOS: Intel SpeedStep, Intel TurboBoost enabled
  • Ubuntu 15.04 (installed from scratch)

xx@yy:~$ lscpu
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    2
Core(s) per socket:    2
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 61
Model name:            Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz
Stepping:              4
CPU MHz:               499.984
CPU max MHz:           2700,0000
CPU min MHz:           500,0000
BogoMIPS:              4389.97
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              256K
L3 cache:              3072K
NUMA node0 CPU(s):     0-3
xx@yy:~$ sudo modprobe msr
[sudo] password for xx:
xx@yy:~$ sudo rdmsr -a 0x19a
e
e
e
e
xx@yy:~$ sudo wrmsr -a 0x19a 0x0
xx@yyi:~$ sudo rdmsr -a 0x19a
0
0
0
0

After this I put some load on the processer by running a simple shell-script and starting programs like vmware player, libre office wirter and in parallel greped repeatedly for the CPU-frequency:


xx@yyi:~$ lscpu |grep MHz
CPU MHz:               499.984
CPU max MHz:           2700,0000
CPU min MHz:           500,0000
xx@yy:~$ lscpu |grep MHz

... the output never changed.

P.S.: cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_driver
intel_pstate

I did several tests, the CPU-frequency seems to be frozen at 499,984 MHz. Only once during my tests I experienced a slight increase to a maximum of something like 501 MHz, however I am not able to reproduce this.

I also disabled SpeedStep in BIOS, expecting the frequency to be 2.200 MHz constantly, but it remained 499,984.

Thanks for all your effort and support!

0 Kudos
Doug Smythies
1 Nickel

RE: Bios bug: Latitude 7440

@n13260: Your situation is different. The minimum pstate for your processor is 5 and so 500 MHZ without Clock Modulation is O.K. I can see that I need to edit my post, and bit 4 of the register indicates if Clock Modulation is enabled or not, and in your case it wasn't.

Often (not always), CPU frequencies stuck at minimum are because the BIOS is limiting the frequency . You can check via:

cat /sys/devices/system/cpu/cpu*/cpufreq/bios_limit

Although that file might not be there.  See also.

0 Kudos
Bimme
1 Copper

RE: Bios bug: Latitude 7440

I had a similar problem that got even worse when using the latest bios.

But sometimes I got as low as 100 MHz which is way below the minimum speed.

Dell came out and replaced the motherboard and CPU, I haven't had the problem since then.

0 Kudos
n13260
1 Nickel

RE: Bios bug: Latitude 7440

@Doug, thank you for your hint!

After switching to acpi-cpufreq driver CPU frequencies are not stuck any longer, under load they go up to  ~2200GHz, as expected and as defined:

cat /sys/devices/system/cpu/cpu*/cpufreq/cpuinfo_max_freq
2201000

This is exactly the value shown in bios_limit. However, BIOS system information defines maximum clock speed with 2.200 GHz, not 2.201 GHz.

Using acpi-cpufreq driver and disabling SpeedStep in BIOS is now also working with the expected CPU frequency of 2.2 GHz.


Using intel_pstate driver CPU frequency remains stuck (independent whether thermald is running or stopped) bios_limit does not exist in this environment.

0 Kudos
n13260
1 Nickel

RE: Bios bug: Latitude 7440

@Bimme
Are you successfully running intel_pstate driver now?

0 Kudos
Doug Smythies
1 Nickel

RE: Bios bug: Latitude 7440

@N13260: I am aware of another person with your same issues. It might be kernel version dependent, because it didn't happen when he tried kernel 4.2. I have asked him to go back and try his original kernel, which was Ubuntu 3.16.0-28. I would like to understand your root issue, however I don't know that this is the place to do it.


EDIT: I made a mistake in kernel version, Fixed. The other person was not able to repeat their results with that kernel.

0 Kudos
n13260
1 Nickel

RE: Bios bug: Latitude 7440

@Doug,

I have tested with kernel 4.2 - same issue. Relocated this issue to:

en.community.dell.com/.../19655706

0 Kudos