Laptops General - Read Only

Last reply by 08-14-2016 Unsolved
Start a Discussion
3 Silver

Keyboard debouncing utility: Solution / workaround for key-bounce issues on certain Dell notebooks

I recently purchased a Dell 1470 notebook and immediately noticed that the keys were "bouncing" (multiple keystrokes registered for a single keypress).  The problem is not isolated to just my laptop or model; as you will find here, it is showing up on others as well.  If you are experiencing this problem, I feel for you. 

The problem was sporadic, but occurred often enough to make my typing look like that of a third-grader (no offense intended to any third-graders out there).  The problem persisted, even after three keyboard change-outs along with an OS wipe/ factory restore and also a motherboard swap-out.  A thorny problem, indeed.  At that point, it was determined that the problem was driver-related.  The keyboard driver is supplied by Microsoft, thus placing me at the complete mercy of the driver development team(s). Searching revealed no resolutions to this issue, no driver updates or patches, neither at Microsoft, nor at Dell, nor on the WorldWideWeb.

Now, being a firmware/software developer myself, I am familiar with keyboard bounce... it exists in all interfaces that have an electro-mechanical switch involved.  The objective is to turn the "chatter" at the switch closure into a clean change of state... "off" to "on", with no chatter at the boundary.   (If you are curious about the topic, you can read about it in detail here.)  Computer keyboards certainly fall into that category.  I realized that the problem existed either in the keyboard driver, the keyboard controller, or the design of the keyboard itself.  I also realized that this issue is not glaringly common enough to garner much priority from developers.  Hence, at least for the forseeable future, this was an "orphan" issue.

Not being a driver developer myself, I took this issue as an excuse to learn AutoHotkey.  I knew about it enough to figure that it could be used to build a keybounce-filtering utility.  Sure enough, I have written an AHK script that does just that: it detects the bounce pattern in the key stream and filters them out on their way to Windows.  You can get it here:

KeybounceFilter.ahk   <-- AutoHotkey script (requires AHK installed)

KeybounceFilter.exe  <-- Compiled script (runs all by itself, no AHK install needed)

AHK forum post

If you are already familiar with AHK and have it installed (it's a great tool BTW), then just download and run the AHK script.  If not, then you might prefer the compiled script (it's the EXE above).  With the EXE, you won't need to install AHK at all.  Just download the EXE into a safe place, then create a shortcut to it, and place that shortcut into your Startup folder (Start > All Programs > Startup).  The script will then run automatically on the next startup.

The filter has a "window time" where it looks for bounces (repeats).  Keybounces usually last in the 10's of milliseconds, being as low as 1 msec for a clean switch closure and as high as 100 msec or more for a particularly dirty one.  I set the default gating window to 40 msec, as a working ballpark figure.  I didn't want to make it too high, because this gating time also sets the upper limit on the auto-repeat rate.  In fact, if you find while running the script that your auto-repeat is choppy or doesn't work at all, you'll want to lower the auto-repeat rate until it works again (don't worry, you'll get it back).  Just go to Control Panel > Keyboard > Repeat Rate and adjust the slider down until it works reliably again.  (note: that has changed: see updates/edits below...)  If you do find that you still get double keys (or triples... I feel for you), then you should increase the gating time.  To do it, right click on the shortcut to the script that you created above, then select "Properties".  Click inside the "Target" box, and at the end of the line, after the "KeybounceFilter.exe", add a space, and then a number for the gate time in milliseconds, then click "Apply".  So for example, if you want the gate time to be  50 msec rather than the default of 40 msec, then the Target Line should look like this:

C:\Users\<path to the script>\KeybounceFilter.exe 50

You will then need to re-run the script (restart, or just right-click the little "H" icon in the tray, select "Exit", then re-run the shortcut).  Also remember to re-adjust the keyboard repeat rate afterward.  The optimal choice of gating time is therefore striking a balance between the quality of the filtering achieved and the maximum repeat rate that will be available to you.  (note: that has changed: see updates/edits below...)  The filtering probably won't be 100% perfect, but it should go a very long way to helping maintain your sanity (no guarantees, of course).

That's it.  I hope this helps a lot of you out there to keep from pulling all of your hair out!

Edit (2-17-2011): Due to popular request, the script has been updated to now support cAPSLOCK functionality (boo!! hiss!!). The dreaded cAPSLOCK is now enabled by default (no, say it isn't so!!).  Not to be left stuck in this horrible state, cAPSLOCK may still be readily disabled (yay!) by passing a second non-zero numerical argument to the command line. So for example, in the Properties>Target line of the Startup Shortcut, disabling cAPSLOCK with the same 50 msec gate time as in the above example would look like this:

C:\Users\<path to the script>\KeybounceFilter.exe 50 1

Note that for practical reasons, Shift+cAPSLOCK will also be disabled in this mode, but both Ctrl+cAPSLOCK and Alt+cAPSLOCK will still perform the dreaded cAPSLOCK function (just in case you really need it).  Note also that passing zero (0) for the second argument acts the same as passing no second argument, i.e. it leaves cAPSLOCK still enabled (boo!).  Enjoy and God Bless!

Edit (3-13-2011): Due to popular request (and because it was really bugging me, too), the script has been updated to allow the keyboard auto-repeat feature to work (much more) properly.  Before this change, the gate time for the bounce filter would set an upper limit on the repeat rate, with longer gate times resulting in lower allowable repeat rates.  Now, you can set the auto-repeat rate as high as you like, and it will fly as intended. (In fact, the faster that you set it, the better that it will work!)  The feature works by setting an upper limit on how many bounces are filtered in a row.  In practice, real key bounces should result in fewer than three or four strikes in a row, so the default switchover is set to pass key repeats with more than 3 in a row.  This does add a slight delay to the auto-repeat before it really "kicks in".  You can lower the delay by either increasing the auto-repeat rate (yay!) or lowering the switchover threshold by passing a third numerical argument to the command line.  So for example, setting the Properties>Target line of the Startup Shortcut described above as follows:

C:\Users\<path to the script>\KeybounceFilter.exe 50 1 2

would set the switchover threshold to 2, while also disabling cAPSLOCK and setting the 50 msec gate time as before.  The danger of lowering the switchover threshold is that really bad bounces (undesired repeats of three or more) would begin to get through.  So use caution, and season to taste.  This update should now remove the one large remaining peeve that existed from the start of this utility.  As always, enjoy, and God Bless!

Replies (62)
3 Silver

This is too funny.  I couldn't remember how I left the filter keys settings.  So after you posted, I went into the "Ease of Use" center and the "use filter keys" were enabled.  When I clicked on change settings, it actually had BOTH bullets highlighted - BOTH Turn On Bounce Keys and Turn On Repeat Keys.  It's a radio button, so this is supposed to be impossible.  LOL.  It must have something to do with having registry edits.  I canceled out of that screen and left "as is", just as the link instructed to do.

Oh oh... now you've done it! Two radio buttons enabled at once?  That spells the doom of the world as we know it. You were wise not to change the control panel settings when you saw that ominous sign... you might have been pulled into the Windows Vortex.

I remember when radios actually had mechanical buttons that physically moved the dial to a station that you had preselected (usually by pulling the button out and then pushing it back in). If that mechanism wasn't complicated enough, they also had an interlock that would only let you push one button in at a time. Some radios would have some "play" in the mechanism so if you did push in two buttons at once, the dial would move to somewhere in between the two stations that you selected. So I guess it's not totally impossible to have two radio buttons pushed in at once?   ;)

3 Silver

Thanks so much for this utility - I have had the keyboard replaced already and the problem still exists on my Dell XPS 1647.

So far so good :emotion-1:

Glad it worked for you too! (And welcome to the club.)

2 Bronze
2 Bronze

Thanks so much for this utility - I have had the keyboard replaced already and the problem still exists on my Dell XPS 1647.

So far so good :emotion-1:

2 Bronze
2 Bronze

Did you just do the regedit / value change / reboot, or did you also check the boxes in the FilterKeys Control Panel?

Are these the values that you used:

My Computer\HKEY_CURRENT_USER\Control Panel\Accessibility\Keyboard Response
    AutoRepeatDelay = 500
    AutoRepeatRate = 50
    BounceTime = 35  (Reduce to a lower number like 25 or 15 if your intentional double strokes are filtered.)

If so then you could indeed try lowering BounceTime. My registry has another field "DelayBeforeAcceptance" (defaults to zero) which I cannot find any documentation on. (Just curious about that one.)

Yes, I regedited.  The AutoRepeatDelay and AutoRepeatRate were already set to the numbers above.  I just changed the BounceTime to 35.  I intended on reducing the Bounce, as you prescribe, to a lower number later this evening.

This is too funny.  I couldn't remember how I left the filter keys settings.  So after you posted, I went into the "Ease of Use" center and the "use filter keys" were enabled.  When I clicked on change settings, it actually had BOTH bullets highlighted - BOTH Turn On Bounce Keys and Turn On Repeat Keys.  It's a radio button, so this is supposed to be impossible.  LOL.  It must have something to do with having registry edits.  I canceled out of that screen and left "as is", just as the link instructed to do.

I have the same DelayBeforeAcceptance field.  I will have to research that as well.  I'll let you know what turns up.  Keep me informed if you find something.  Thanks.

3 Silver

Did you just do the regedit / value change / reboot, or did you also check the boxes in the FilterKeys Control Panel?

Are these the values that you used:

My Computer\HKEY_CURRENT_USER\Control Panel\Accessibility\Keyboard Response
    AutoRepeatDelay = 500
    AutoRepeatRate = 50
    BounceTime = 35  (Reduce to a lower number like 25 or 15 if your intentional double strokes are filtered.)

If so then you could indeed try lowering BounceTime. My registry has another field "DelayBeforeAcceptance" (defaults to zero) which I cannot find any documentation on. (Just curious about that one.)

2 Bronze
2 Bronze

LitwDell, no I did not know of that registry setting for FilterKeys. That is really a terrific find. I have read through the whole thread, and based on their findings, that solution should work similarly to what my utility can do. The advantage there is that it is a feature built right in to Windows (XP onward). The downside is that it requires editing of the Registry, which can be dangerous if safety steps are not taken (e.g. backup the Registry, set a System Restore point, etc.).  Also, that method does not eliminate the side-effect of slowing down the auto-repeat rate, it will unfortunately still be limited by the filtering time. It does, however, appear to provide finer control over the settings. The method of choice appears to be given in Post #6 of that thread, with the option in a subsequent post to not bother with turning on FilterKeys at the Control Panel level.

I haven't tried it, so I can't report (yet) on how well either option works. But it does looks like a nice, built-in alternative to the KeyBounceFilter AHK utility, albeit still being a workaround to fixing the real problem at the source: lowering the bounces at the HARDWARE level (hard for Dell to do), or increasing the keybounce-gating time at the DRIVER level (not nearly as hard for Dell to do... but they would need to write and support the new driver).

I've used this registry tweak for the last 12 hours, with NO unintended double hits.  It needs additional tuning because there are side effects - sometimes now it won't show a letter on an intentional double-hit.  I haven't had time to toy with it, but I think it is a significant step in the right direction.  No doubt, the ideal solution will be a fix to the low-level driver.  I'm not holding my breath on that one, but you would think someone would take this problem more seriously - it is unbelievably annoying and makes the machine almost useless.  If I can't get this system to work exactly as I expect it to (just as my previous Dell worked), it is going back.

3 Silver

LitwDell, no I did not know of that registry setting for FilterKeys. That is really a terrific find. I have read through the whole thread, and based on their findings, that solution should work similarly to what my utility can do. The advantage there is that it is a feature built right in to Windows (XP onward). The downside is that it requires editing of the Registry, which can be dangerous if safety steps are not taken (e.g. backup the Registry, set a System Restore point, etc.).  Also, that method does not eliminate the side-effect of slowing down the auto-repeat rate, it will unfortunately still be limited by the filtering time. It does, however, appear to provide finer control over the settings. The method of choice appears to be given in Post #6 of that thread, with the option in a subsequent post to not bother with turning on FilterKeys at the Control Panel level.

I haven't tried it, so I can't report (yet) on how well either option works. But it does looks like a nice, built-in alternative to the KeyBounceFilter AHK utility, albeit still being a workaround to fixing the real problem at the source: lowering the bounces at the HARDWARE level (hard for Dell to do), or increasing the keybounce-gating time at the DRIVER level (not nearly as hard for Dell to do... but they would need to write and support the new driver).

2 Bronze
2 Bronze

Hi Oliver,

I also tried that FilterKeys approach, but I was disappointed that the minimum filtering time offered by Windows was 0.5 seconds (500 milliseconds).  That was way too slow for my typing... I couldn't wait that long to type words with double letters, like "school", which would come out as "schol". It became as much a problem as the original problem. My utility should allow you to set the filtering time down to well below 50 milliseconds, which will still allow for pretty decent typing speed, as long as your keyboard bounce is not too severe.

On that topic... I have noticed recently that the bouncing on my Dell Inspiron 1470 keyboard has gotten worse. I had to up the filtering time to 70 msec to keep the output clean. Oh well, at least I can still type with the thing!

KingdomSeeker288 - Have you seen this proposed solution to double-hits?  (found this on a 2008 thread).  I thought you might have some feedback on this approach - did you know this registry setting existed (was modifiable)?

http://forum.eeeuser.com/viewtopic.php?pid=364796#p364796

2 Bronze
2 Bronze

 

I just received my system two weeks ago, and I have the exact same problem.  I've read threads going back to early 2009 with reports of this problem.  I'm running in circles with Dell support.  I may try the scripts provided above (thanks to the author for posting it), but as mentioned - this really doesn't feel like a permanent fix.  This keyboard double-hit is driving me crazy.

 

3 Silver

Hi Oliver,

I also tried that FilterKeys approach, but I was disappointed that the minimum filtering time offered by Windows was 0.5 seconds (500 milliseconds).  That was way too slow for my typing... I couldn't wait that long to type words with double letters, like "school", which would come out as "schol". It became as much a problem as the original problem. My utility should allow you to set the filtering time down to well below 50 milliseconds, which will still allow for pretty decent typing speed, as long as your keyboard bounce is not too severe.

On that topic... I have noticed recently that the bouncing on my Dell Inspiron 1470 keyboard has gotten worse. I had to up the filtering time to 70 msec to keep the output clean. Oh well, at least I can still type with the thing!

Top Contributor
Latest Solutions