lionsroar
1 Nickel

RE: Precision M4800 : Input lag at log in, Switchable graphics not functioning, GPU fan "chirping" when it starts up.

Jump to solution

UPDATE  9/29/2017

Laptop Has Returned from Dell :

MotherBoard Replaced, GPU Replaced (verified by vram change from Samsung to Elpida), Display replaced.

Dell did NOT address all issues listed on service request.

DID not get my original packing back that secured the entirety of the PC- I had to supply this.

Item arrived with LOOSE screws inside the laptops case, requiring complete tear down to find before powering on.


This required about an hour and a half to do : additional screw issues were found : missing screws securing I/O daughter card on left side of PC. Keyboard Screws are stripped. Some Screws securing the motherboard are totally stripped. Missing Screws that secured palmrest.

see this screw? it rattled around loose, prevented me from opening the lid until i shook the PC to dislodge it. It was not placed here for the photo.

This stripped screw? why is it stripped?

had to use screws I had on hand to replace the missing ones I could get out : some stripped screws remain because I cannot get them out to replace. it will be nearly impossible to remove the motherboard again if needed.

Brand NEW display hinges...Pop and creak especially if opening slowly. Will Upload a Vid to youtube and link here.

TrackPad and Point Stick are NOT detected by dells drivers : You install the Dell Driver, ALPS errors and does not show either point stick or trackpad- neither function with the driver loaded. This is a CLEAN install of windows 7, with the trackpad driver installed. NOTHING ELSE.



 Works in Bios, works in Windows before driver installation, works in Ubuntu.

 

 

Monologue of all this here :

 

I am still a VERY unhappy camper...

Can Someone at dell Please make this right? I'm So very tired of fighting this 2,000 dollar laptop.

It is currently NOT being used and just sitting on the return box again...

Systems:

Primary AMD FX Desktop : AsROCK 970A-G/3.1, FX-8350 4.55Ghz@1.4v on air, RX580+ 8GB under clocked and undervolted (silent), 16GB Corsair Dominator Ram, MX100 512GB boot SSD, 525GB MX500 Program SSD, 525GB MX500 Game SSD, 2TB of Platter Drive Storage

Lenovo W520 :i7-2860QM, Quadro 2000M OC, FHD 95% Gamut Display, 16GB Ram, Dual 500GB SSD's
0 Kudos
ST1980
1 Copper

RE: Precision M4800 : Input lag at log in, Switchable graphics not functioning, GPU fan "chirping" when it starts up.

Jump to solution

It's been 1.5 years since the last M5100 driver update and it remains the only usable release on UHD configs (official AMD drivers are all plagued by freezes: 15.301, 16Q4, 17Q1, 17Q1.1, 17Q2, 17Q2.1, 17Q3 - all of them). Are there any plans to release an updated driver containing the UHD freeze fix?

strongchai
1 Copper

RE: Precision M4800 : Input lag at log in, Switchable graphics not functioning, GPU fan "chirping" when it starts up.

Jump to solution

I am also waiting for the new updated usable M5100 driver for UHD configs. I am confused that why Dell didn't release a vbios fix to remain this problem. Then we may be able to update the official drivers from AMD.

0 Kudos