Chevelles240
1 Copper

Unable to Install Windows on XPS 13 (9350)

Hi everyone,

I recently purchased an XPS 13 Signature Edition (7 days ago) and love this laptop but have had numerous problems with it out of the box. I had Windows 10 Home preinstalled and ran Microsoft's big update for Windows 10 called Threshold or 1511 from Windows Update. After this update finished the laptop was no longer able to detect any network adapter hardware. I wasn't able to install the driver for the adapter without the installation wizard failing and the Device Manager included nothing regarding the network adapter anymore.

Instead of trying to troubleshoot this any further I just decided to format the computer again. This is where things went down hill quickly. I will admit, I don't know much about UEFI, Secure boot or GPT, so I think my lack of understanding potentially caused the following problem.

I loaded a bootable OS iso on a USB drive and plugged it into the computer. The issue was the computer wasn't detecting the thumb drive. Upon further research, I had to enable Legacy Option Roms and disable Secure Boot in the BIOS (UEFI). Upon doing this I was able to see the USB drive under Legacy Boot after pressing F12.

When I go to the point where it asks if I want to create a new partition or format current partitions I tried formatting the main partition but received an error message stating windows can't be installed because it's a gpt partition type. What I did afterwards was delete all 4 partitions listed.

The problem was I did not want to install an OS using the old school partitioning method. I wanted to be able to use UEFI, GPT, and so on. I am not sure what happened after removing those partitions but now I can't doing anything to this computer.

I am unable to create a partition when Legacy Boot is enabled because I am told no hard drive could be found. So I went back and enabled Secure Boot and disabled Legacy Boot Options rom so I could install windows on a UEFI partition. I even got a UEFI recovery media drive from Dell and I cant use any of the restore/recovery features without errors. Everything results in a generic error message or states a required partition is missing.

If I run ePSA Pre-boot System Assessment (Dell Diagnostics) I receive an error message stating Hard Drive - Not Installed. The odd thing is the BIOS can see my hard drive but nothing else seems to see it. If I run Device Configuration from the boot screen my hard drive is also listed as Non-Raid Physical Disks: PCIe 1.0, PM951 NVMe Samsung 256GB S29NNXAG919783, 238.6GB. I even restored the BIOS back to Defaults and Factory Settings.

Would anyone be able to offer some assistance on how to fix this? I am stuck one what I can do from here and speaking with Dell Technicians over the phone didn't get far either.

0 Kudos
5 Replies
claimstreamer
1 Copper

RE: Unable to Install Windows on XPS 13 (9350)

After days work i found the solution. You first need to update your BIOS to version 1.1.7 at downloads.dell.com/.../XPS_9350_1.1.7.exe. Then set Secure boot "Disabled", SATA Operation Default (RAID on), Advanced Boot Options to "Enable Legacy..." and Boot Sequence to "Legacy". 
After that make a bootable W7 USB stick with USB Download Tool at www.microsoft.com/.../windows-usb-dvd-download-tool.
After that you have to make your USB stick USB3.0 compatible with the Windows 7* USB 3.0 Creator Utility at downloadcenter.intel.com/.../25476.
After that you download these NVME driver at 1drv.ms/1Q39G8m to your USB stick.
Boot it and browse to the folder where you have put your drivers and enjoy.

MdSaiful
1 Copper

RE: Unable to Install Windows on XPS 13 (9350)

Thanks a lot Bro @CLAIMSTREAMER. your suggestion work for me.  

chasedardaman
1 Copper

RE: Unable to Install Windows on XPS 13 (9350)

@mdsaiful @claimstreamer I am having the same issue but the link to the driver is not working. Is there another link or place that I can get the link?

0 Kudos
MdSaiful
1 Copper

RE: Unable to Install Windows on XPS 13 (9350)

Actually which driver did you mention that not working. To download driver go to dell help & support site then search driver by using  device tag (Dont use any other option) otherwise driver didn't work.  Thanks

0 Kudos
Highlighted
Rangdaa
1 Nickel

RE: Unable to Install Windows on XPS 13 (9350)

 Bootable flash drive with USB 3 drivers created. I have copied the NVME drivers (Driver64) to the root of the flash drive and to other likely folders as well.

 Laptop boots into the flash drive and I proceed with installing W7. After a short while, I get the “A required CD/DVD drive device is missing” etc etc. If I click OK then I get the “No device drivers were found etc etc”.

 When I click “Browse” the folder structure I get is “Computer” then “Boot (X)”.

 Clicking on “BOOT (X)” offers me, Program Files, Sources, Users, Windows. Clicking on any of these does not offer the Driver 64 folder.

 I did try installing Setup NVME but on running this it tells me that “The setup program ended prematurely because of the following error Device not detected”.

0 Kudos