Highlighted
2 Bronze

Latitude 3440 Keyboard Not Working

Jump to solution

I just replaced a broken LCD screen,  following a detailed step by step process.   Screen and touchpad work fine,  but  the keyboard doesn't work at all.  I checked the cable connection and it is seated fine.  I tried a process known to work on another Dell laptop model: take out battery,  ensure off AC power,  hold power button down 15-30 secs, replace battery and power up.  No luck.  Any ideas?

0 Kudos
2 Solutions

Accepted Solutions
Highlighted
3 Argentum

Re: Latitude 3440 Keyboard Not Working

Jump to solution

Hi Mrcpuhead,

This can be an issue with the keyboard cable, or the port on the motherboard. You can connect an external keyboard and check if that works. As the system is quite old to find the replacement parts.

You might check for a local service center and get the system checked for better understanding before purchasing any parts further.

Dell-Parnoshree C
Social Media Support
#IWork4Dell
Dell Support Videos
Drivers and Downloads
Driver order

View solution in original post

0 Kudos
Highlighted
2 Bronze

Re: Latitude 3440 Keyboard Not Working

Jump to solution

I'm embarrassed to say it was a dumb mistake.  I had the keyboard ribbon cable upside down when I plugged it back into the connector.  Works fine when oriented properly!

View solution in original post

0 Kudos
2 Replies
Highlighted
3 Argentum

Re: Latitude 3440 Keyboard Not Working

Jump to solution

Hi Mrcpuhead,

This can be an issue with the keyboard cable, or the port on the motherboard. You can connect an external keyboard and check if that works. As the system is quite old to find the replacement parts.

You might check for a local service center and get the system checked for better understanding before purchasing any parts further.

Dell-Parnoshree C
Social Media Support
#IWork4Dell
Dell Support Videos
Drivers and Downloads
Driver order

View solution in original post

0 Kudos
Highlighted
2 Bronze

Re: Latitude 3440 Keyboard Not Working

Jump to solution

I'm embarrassed to say it was a dumb mistake.  I had the keyboard ribbon cable upside down when I plugged it back into the connector.  Works fine when oriented properly!

View solution in original post

0 Kudos