Last reply by 06-30-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

WD19 docking stations - network dropout, USB dropout across multiple models

We are facing issues with WD19s losing Ethernet connections pretty consistently and also USB dropping out randomly throughout the day.

This happens with our latitude 5400 laptops.

The issue persists after we had the motherboard and other parts replaced, 3 new WD19's, and fresh installs of OEM image and latest BIOS and drivers on laptop and dock.

The issue does NOT occur with the WD15 dock and 5400 latitude.

Dell indicated moths ago there would be an August update of the docks firmware. This has not been released.

Has Dell acknowledged this as a known issue ?- there seems to be multiple posts with this same issue with other laptop models.

We were planning on purchasing this model for our fleet...

Dell, any comment? 

Replies (372)

I'm not aware of issues with USB connections dropping. The issue we're seeing is that users who need to remote to their docked laptops from another location are having their remote sessions dropped intermittently. When I was able to recreate the issue, I observed that the wired network connection had dropped and it had switched over to wifi. My assumption is that users are not noticing when they are working locally on their machines because the switch from wired to wireless is happening without interrupting their work. I have not had reports of USB devices disconnecting as of yet which would definitely affect users working directly on their machine versus remotely.

I tried the latest 10.33.0419.2019 Realtek USB GBE Ethernet Controller Driver for Dell TB16/WD15/DS1000/TB18DC/WD19/WD19TB/WD19DC Dock driver as well as 10.28.1002.2018 and another version that was installed by Windows 10 when I uninstalled and deleted the existing driver. So far these changes have not resolved the issue. Last night I switched one user to a WD15 dock (which we were previously deploying) using the10.33.0419.2019 driver and she reported no drops in remote desktop during her shift.

All other drivers and BIOS are up to date on the machines I've been troubleshooting.

@medavies thanks for getting in touch. When this issue occurs do you get an error message like this image.png

And this in the device manager


What troubleshooting ave you attempted so far - i.e is the system running the latest drivers and BIOS revision?

I'll drop you a private message to get your tag details


Social Media Support
I'm based in the UK and I'm usually available Monday to Friday 9am-4pm GMT
Get Support on Twitter @DellCaresPro

2 Bronze
2 Bronze

I am also having this issue with the Latitude 7400 model.

Same problem here with Latitude 5491 on WD19: After more than 10 minutes on lock screen, it loses network connections.

Apparently the function "stop devices..." under Settings > USB is no longer available in Windows 10 1903.
Instead, I went to Device Manager > Network adapters > Realtek USB network controller and changed the following:

- "Advanced" tab > Idle Power Saving > Set to Disabled.

- Power Management tab > Uncheck "allow this computer to turn off this device to save power".


PullingMyHairOut1, I am curious if this fix has proven to help and if so did you find a GPO for the setting?

I have this issue too and after finding this thread, I've found this possible fix for Window 10.

Open the Settings panel and point your mouse to the USB section in Devices. Then untick the last box where it says Stop devices when my screen is off to help save battery.

Hopefully this fixes the issue. I'm trying to find an GPO to apply it to all of our computers.

We are also facing issues with WD19s  losing Ethernet connections pretty consistently and also USB dropping out randomly throughout the day.

This happens with our latitude 5400

The issue persists after we had the motherboard and other parts replaced, and fresh installs of OEM image.

We have also updated all BIOS and drivers.

Having similar issues here. Trying to fully use the WD19 docking station doesn't work. A Precision 7540 WD19DC docking station and three external 4k displays. The mentioned workarounds have worked for me at times and sometime not. BIOS and video drivers, firmware are all updated. The only constant workaround that I have found is to run two DP from the dock and the third visual display from the HDMI cable port on the laptop itself. Also, having the ethernet cable connected to the laptop works with no issues.     


In some cases, just reconnecting the USB-C cable will do the trick.

In other instances, we'll disconnect the USB-C cable, then the power to the Dell Dock...  Reconnect the power to the Dell Dock, followed by the USB-C cable.

We also have the new 7400.  We are seeing a similar issue where the system screen just goes black. With the system set to "do nothing" when closing the lid, if you re-open the lid, the screen is black.  The backlight is on but no output from screen.  Sometimes happens when disconnecting from the dock as well (WD19).  

Top Contributor
Latest Solutions