Linux General

Last reply by 04-17-2020 Unsolved
Start a Discussion
1 Copper
1 Copper
3594

Area-51m, firmware bug failed to parse event in TPM final events log

Hello,

I just recently got an Alienware Area-51m. Although not supported by Dell, I have been trying to install Ubuntu 18.04, 19.10, and the 20.04 (Daily Build), however, I always get hit with this [Firmware Bug]: Failed to parse event in TPM final events log (Image attached below). I disabled TPM and Secure Boot in the Bios, the error goes away, however, I still get the "glitches".

Alienware Area-51m specs:

  • 9th Generation Intel Core i7-9700K (8-Core, 12MB Cache, up to 4.9GHz w/ Turbo Boost)

  • NVIDIA GeForce RTX 2080 8GB GDDR6 (OC Ready)

  • 32GB, 2x16GB, DDR4, 2400MHz

  • 512GB PCIe M.2 SSD + 1TB (+8GB SSHD) Hybrid Drive

Alienware Error.jpg

Labels (2)
Replies (2)
2 Bronze
2 Bronze
3223

Were you able to solve this issue? I have a similar machine (Alienware Aurora) and am seeing the exact same problem trying to install Ubuntu 18.04 or 19.10

2 Bronze
2 Bronze
3163

These notes are off the top of my head so they may be a little sloppy but hopefully it's enough for you to get past your issue. Basically you want to install and run Ubuntu with the "nomodeset" kernel parameter long enough to update all the drivers. When the display comes up in the proper resolution, go back and remove the parameter. This is just one way to do that:

  • Use Ubuntu 19.10 (has 'safe graphics' option)
  • Install Ubuntu with Safe Graphics (or screen will be corrupted)
  • If when on reboot the display glitches when booting your installed Ubuntu OS, boot the Ubuntu install drive again
  • Quit the install, and it will drop you back into the LiveCD version
    • Or maybe just pick the LiveCD with Safe Graphics to begin with...
  • Do the “Boot Repair”
  • Run Software Updater
    • Install all updates
    • Reboot
    • Display now appears correctly using the Open Source driver
  • Run Software & Updates (optional, if you want the closed-source nvidia driver)
    • Under “Additional Drivers” pick the nvidia proprietary drivers (435 or whatever is latest)
  • Install Grub Customizer
    • Remove the nomodeset option from Ubuntu, with Linux 5.3.0-46-generic
  • Reboot one more time
 
Note that I installed on a 2.5" drive. If you want to install on nvme you have to disable "raid mode" in BIOS.
Latest Solutions
Top Contributor