Linux General

Last reply by 03-04-2020 Solved
Start a Discussion
2 Bronze
2 Bronze

XPS 13 9360 Ubuntu 16.04 + DA200 no HDMI

Hi all,

as the post's subject says, i just received my XPS 13 with Ubuntu 16.04.

The problem is that i can't make work the HDMI connection with the DA200 Adapter.

The external monitor is a Dell U2417H and its resolution is 1920x1080, 60Hz (so it should be ok for the adapter). 

The external monitor is recognized into the display settings, if I try to take a screenshot it also appears correctly, but there is no signal and the monitor is black.

This is really frustrating.

Solution (1)

Accepted Solutions
2 Bronze
2 Bronze

There is a patch that landed upstream here:

Once that makes it into the distros it will resolve the problem.

View solution in original post

Replies (10)
7 Thorium

Hi foska,

Thanks for posting.

the da200 adapter is not a displaylink device. It's a "docking station" adapter that connects to the usb-c port, and provides hdmi, vga, ethernet, and usb ports.

currently there seems to be a problem with the graphics on this device. the laptop does see an external screen, but it will remain black. only when a low resolution is chosen (usually much lower than the preferred resolution of the monitor or tv that is attached) the display "works".

more information and details about this issue is available from these bug reports:

2 Bronze
2 Bronze

Thanks for the answer.

Both the reports are related to Skylake and  Intel HD 520, my XPS version is Kabylake with Intel HD 620. So i guess the bug isn't solved yet.

2 Bronze
2 Bronze

Hi Robert,

I just updated my 9360 to BIOS to 1.2.3, hoping that that this would cure the issue. However, now there is no HDMI video output at all while with 1.0.7 BIOS at least modes up to 1024x768 worked. As before the external display is recognized but the screen stays black, always. Kind of a disappointment.

2 Bronze
2 Bronze

I'm in the same boat, totally blank output. but registers in Displays.

From what I can see the monitor getting connected to a USB-C to HDMI adapter wrongly registers as a Display Port

Here is the output of xrandr after pluggin in the adapter to my monitor, notice HDMI1 and HDMI2 are not connected. This is using a 3rd party adapter. I had exactly the same output using the DA200 usb-c multi adapter too.

linux-mint 18.1 (ubuntu 16.04)
with kernel 4.8.11

Screen 0: minimum 8 x 8, current 5120 x 1800, maximum 32767 x 32767
eDP1 connected primary 3200x1800+0+0 (normal left inverted right x axis y axis) 294mm x 165mm
   3200x1800     59.98*+  47.99  
   2880x1620     60.00  
   2560x1440     60.00  
   2048x1536     60.00  
   1920x1440     60.00  
   1856x1392     60.01  
   1792x1344     60.01  
   2048x1152     60.00  
   1920x1200     59.95  
   1920x1080     60.00    59.93  
   1600x1200     60.00  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1600x900      60.00  
   1280x1024     60.02  
   1440x900      59.89  
   1280x960      60.00  
   1368x768      60.00  
   1360x768      59.80    59.96  
   1152x864      60.00  
   1280x720      60.00  
   1024x768      60.00  
   1024x576      60.00  
   960x540       60.00  
   800x600       60.32    56.25  
   864x486       60.00  
   640x480       59.94  
   720x405       60.00  
   640x360       60.00  
DP1 connected 1920x1200+3200+0 (normal left inverted right x axis y axis) 597mm x 336mm
   1920x1200     59.95* 
   1920x1080     60.00    50.00    59.94    24.00    23.98  
   1920x1080i    60.00    50.00    59.94  
   1600x1200     60.00  
   1680x1050     59.88  
   1280x1024     75.02    60.02  
   1280x800      59.91  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  
DP2 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
2 Bronze
2 Bronze

Hi Foska:

I was looking for a solution for this problem and found it in

Jeremy uses the Apple USB-C Digital AV Multiport Adapter. I tried it and worked fine. Curious thing that Dell adapter doesn't work but Apple one does.

2 Bronze
2 Bronze


Is there any solution for this problem?

Otherwise I will have to return the DA200 I received today...



2 Bronze
2 Bronze

There is a patch that landed upstream here:

Once that makes it into the distros it will resolve the problem.

2 Bronze
2 Bronze

Really, really thank you!!!

I did miss that!!

I used the patch on Ubuntu 16.04 with kernel 4.13.10 and it worked!!

2 Bronze
2 Bronze

Kernel 4.10.13 obviously!

Sorry for double post but I could not find an "edit comment function".

Latest Solutions
Top Contributor