Linux General

Last reply by 08-25-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze

XPS Plus 9320 webcam webcamera not detected


I got my brand new Dell XPS Plus 9320. It came with Windows but I installed Linux on it.

The webcam is not detected.

I have double-checked it is enabled in the UEFI menu.


I am running PopOS, which is based on Ubuntu 22.04

Replies (11)

Hello, we see you are looking for assistance. If you need our help, you could start a direct message with us and we will be happy to assist you.

Find your Service Tag

If still under warranty, click the "Get help now" icon on the right to start a live chat session. To send us a private message, click our DELL-Cares username. Our Forum profile page will then appear. On the right, click "Send this user a private message".

2 Bronze
2 Bronze

For transparency's sake, and in case someone else finds this post:

I talked to @DELL-Cares on direct messages and they asked me to install Windows to verify if this is a software problem or not.

I will not do that for now because I do not have the time for that. I will use an external camera for now and ask in other Linux forums to see if someone else found the same issue.


I have the same thing. It's not detected in fedora 36. I know my camera is working fine, since I tested it in the default windows installation before installing fedora.

2 Bronze
2 Bronze

I installed Ubuntu 22.04 and web camera is not detected.

Is there any suggestion to fix it?  Thanks.

2 Bronze
2 Bronze

So, I got an XPS 9320 Developer Edition which had Ubuntu preinstalled (or some version of Ubuntu anyhow). On that preinstalled OS, surprisingly the webcam, mic, sound, fingerprint all worked out of the box. However, when I replaced Ubuntu with Manjaro, I had the issue of webcam not being detected. So, I think there is some driver that exists for linux that the Ubuntu setup had, but we just need to er somehow figure out what that is and obtain it...


Did you have a particular Ubuntu version that worked? And any link to a recover image or something please? Thanks in advance 

2 Bronze
2 Bronze
1921 will provide you the recovery image if you enter your service tag. the Ubuntu i was using was fossa (20.04)


Did you happen to make a backup of the OS drive beforehand? If, for some reason, Dell has ripped the Ubuntu recovery ISO from the site, and now I can't find it. If you do the vanilla Ubuntu install, all you have to do is search for the IPUP6 drivers and follow that rabbit hole.


For most of us, it is throwing an error, "they are aware of it."

Latest Solutions
Top Contributor