Wintersdang
1 Nickel

U2518D, HDMI switching

Jump to solution

HI

i've recently bought an U2518D and i have an problem when connect the montor by HDMI to PC (I5-7500, GTX 1070 driver 388.71, windows 10 1709)

the monitor setting didn't show up the option HDMI 2.0 input, only HDMI 1.4 input  when i press and hold the green check mark for a few second

when i turn on the option smart HDR the screen go black and checking the signal again but the screen won't come back until i press and hold the button choose the option HDMI 1.4

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator

RE: U2518D, HDMI switching

Jump to solution

 

HDMI 1.4 Disabled = HDMI 2.0 Enabled

So if you only see "HDMI 1.4 Enable or Disable", the act of disabling HDMI 1.4 enables HDMI 2.0.

OK, Your connected via HDMI to HDMI cable.
* Press the Menu button
* Go to Input Source
* Select HDMI and hold down the button for 8 seconds
* Take a picture of the image that now appears and post it here
* Choose HDMI 1.4 Disable. This should flip it back to HDMI 2.0

Try this to get M2T103 installed =
* Turn the computer and U2518D off
* Disconnect the HDMI cable from both
* Connect the U2518D to the GTX 1070 via the provided DP to mDP cable =
GTX 1070 DP out port -> DP to mDP cable --> U2518D mDP in port
* Turn the U2518D on, then the computer
* If needed, press the U2518D Input Source button and choose mDP
* Try to install the M2T103 firmware update

0 Kudos
7 Replies
Moderator
Moderator

RE: U2518D, HDMI switching

Jump to solution

Your statements are confusing?
"the monitor setting didn't show up the option HDMI 2.0 input, only HDMI 1.4 input"
* You should see the option Enable or Disable HDMI 1.4. Choosing HDMI 1.4 Disabled = HDMI 2.0

"until i press and hold the button choose the option HDMI 1.4"
* That one means that you went to HDMI 2.0 if it is asking you to change back to HDMI 1.4?

The U2518D out of box default is HDMI 2.0. If you unboxed and connected via the HDMI cable and it did not not work, forcing you to back down to HDMI 1.4, the fault is the video card driver or the video card, not the U2518D.

Instructions =
* Press the Menu button
* Go to Input Source
* Select HDMI and hold down the button for 8 seconds. A choice should appear to Enable or Disable HDMI 1.4

SmartHDR has nothing to do with HDMI 1.4 or 2.0. SmartHDR is only enabled for HDR movie or game content after you have enabled HDR within Windows 10 Display Settings.

Dell HDR is a two step process. You have to change both the Windows 10 Display setting and in the monitor OSD (On Screen Display).

When using the Windows desktop or any other non-HDR content, HDR should be Off
* If applicable for your monitor model, change the monitor OSD -Color -Preset Modes to any non-HDR mode
* If applicable for your monitor model, change the monitor OSD -Display -Smart HDR to Off
* Right click on Windows 10 Display Settings
* Switch HDR and advanced colors to Off

When using an HDR Game or Movie, HDR should be On
* If applicable for your monitor model, change the monitor OSD -Color -Preset Modes to Game HDR or Movie HDR
* If applicable for your monitor model, change the monitor OSD -Display -Smart HDR to On, Normal REC 2020, or Vivid DCI-P3
* Right click on Windows 10 Display Settings
* Switch HDR and advanced colors to On

0 Kudos
Wintersdang
1 Nickel

RE: U2518D, HDMI switching

Jump to solution

Sorry for my bad english, i will tried my best to make thing simple

- i have a Dell U2518D (monitor) connect to Asus GTX 1070 (VGA) by HDMI 2.0 cable

- i turned on PC and monitor got no signal from HDMI

- i opened the input source setting on monitor select HDMI then press and hold the checkmark button for a few second and only HDMI 1.4 option appear (no HDMI 2.0 option)

- i selected HDMI 1.4 and got the signal but the windows display setting dont have HDR option, i open monitor setting select “smartHDR on” and my screen go black “no signal”. The monitor stay on black for a long time unitil i do the press and hold the checkmark select the HDMI 1.4 again and got my screen back but still no HDR option

- i’m not sure where the problem is. The monitor ? The VGA ? The cable ? Pls help...

i’m using windows 10 home 1709 and Nvidia 388.71 latest driver for the VGA

0 Kudos
Moderator
Moderator

RE: U2518D, HDMI switching

Jump to solution

The GTX 1070 video card should be able to do HDMI 2.0. So when connected via the HDMI to HDMI cable, and you press the Input Source for 8 seconds, the option to Disable HDMI 1.4 should appear. Is there another HDMI 2.0 monitor to test on the GTX 1070? Or another computer to test on the U2518D? The U2518D Smart HDR will NOT work until you first turn ON  HDR and advanced colors in the Windows 10 Display Settings.

0 Kudos
CraigVT01
1 Copper

RE: U2518D, HDMI switching

Jump to solution

I have the EXACT same problem as this gentleman and it doesn't look like the problem was solved.

I have a GTX 1070.  Yes, it has HDMI 2.0.  I use it with my HDR TV all the time.

When I connect my U2518D via HDMI 2.0 (yes the HDMI cable is a 2.0 high speed cable that works fine with all other 2.0 compatible devices like my PS4Pro), the ONLY option is HDMI 1.4 Enable or Disable.  There is no 2.0 option.  I'm using Firmware M2T102.

I tried updating firmware from M2T102 to M2T103 and it would not update.  It got stuck at Verifying update.

Is there a fix for this or should I return the monitor?

Thanks

 

0 Kudos
Moderator
Moderator

RE: U2518D, HDMI switching

Jump to solution

 

HDMI 1.4 Disabled = HDMI 2.0 Enabled

So if you only see "HDMI 1.4 Enable or Disable", the act of disabling HDMI 1.4 enables HDMI 2.0.

OK, Your connected via HDMI to HDMI cable.
* Press the Menu button
* Go to Input Source
* Select HDMI and hold down the button for 8 seconds
* Take a picture of the image that now appears and post it here
* Choose HDMI 1.4 Disable. This should flip it back to HDMI 2.0

Try this to get M2T103 installed =
* Turn the computer and U2518D off
* Disconnect the HDMI cable from both
* Connect the U2518D to the GTX 1070 via the provided DP to mDP cable =
GTX 1070 DP out port -> DP to mDP cable --> U2518D mDP in port
* Turn the U2518D on, then the computer
* If needed, press the U2518D Input Source button and choose mDP
* Try to install the M2T103 firmware update

0 Kudos
dee.em
1 Copper

RE: U2518D, HDMI switching

Jump to solution

Same issue here with a GTX1080Ti. This graphics card supports HDMI 2.0b and the cable is 2.0 compliant.

Signal to U2518D over HDMI is only recognised after 1.4 setting has been ENABLED on the monitor.

 

0 Kudos
Moderator
Moderator

RE: U2518D, HDMI switching

Jump to solution

 

The U2518D out of box default is HDMI 2.0. HDMI 2.0 is hardwired into the monitor hardware. I doubt that it is defective.

Did you install the latest Nvidia driver?
Did you install the M2T103 firmware update?
Was this purchased new directly from Dell?
What is the 20 digit S/N and A0x revision?

0 Kudos