Highlighted
jgrathwohl
1 Copper

[NMM 8.2.1/Exchange 2013 CU9/Server 2012 R2] NSR_SNAP_TYPE setting not being read

womp.png

Getting the error above when trying to backup my Exchange 2013 databases. The application information it's wanting is definitely defined but it's not seeing it I geuss? If I don't include the -A key=-s, it will complain about not defining any -A options.

Checkpoint is disabled, data domain backup is unchecked, and *@* is added to remote access. I've been searching around awhile today for a fix to this but haven't found anything.

Backup command:

nsrsnap_vss_save -A key=-s

Application information:

NSR_SNAP_TYPE=vss

NSR_VSS_FORCE_SYSTEM_PROVIDER=yes

CIRCULAR_PROMOTION_POLICY=Promote

NSR_ALT_PATH=D:\Temp

NSR_EXCH_CHECK=no

NSR_ESE_UTIL_SEQUENTIAL=False

NSR_ESE_UTIL_THROTTLE=False

NSR_CHECK_JET_ERRORS=none

NSR_EXCH2010_ACTIVE=yes

NSR_EXCH2010_BACKUP=all

NSR_EXCH2010_DAG=DAG.FQDN.here

NSR_EXCH_CHECK=no

NSR_EXCH_RETAIN_SNAPSHOTS=yes

Most of the above were auto-filled when doing the client setup wizard but I've added some from our currently working Exchange 2010 clients that we had to add to get them working previously. The default options put in did not work either.

0 Kudos
1 Reply
CarlosRojas
4 Tellurium

Re: [NMM 8.2.1/Exchange 2013 CU9/Server 2012 R2] NSR_SNAP_TYPE setting not being read

Hi jgrathwohl

This looks to me as a configuration issue.

Please let's try to clean up a bit your applicaiton information variables, so please use only the following ones:

NSR_SNAP_TYPE=vss

NSR_ALT_PATH=D:\Temp

NSR_VSS_FORCE_SYSTEM_PROVIDER=yes

CIRCULAR_PROMOTION_POLICY=Promote

NSR_EXCH_CHECK=no

NSR_CHECK_JET_ERRORS=none

NSR_EXCH_BACKUP=all

NSR_EXCH2010_DAG=DAG.FQDN.here

In this case you had NSR_EXCH_CHECK=no duplicated.

Also the correct syntax is NSR_EXCH_BACKUP=all, not NSR_EXCH2010_BACKUP=all.

If you are not going to retain snapshots you don't need NSR_EXCH_RETAIN_SNAPSHOTS=yes

Please copy and past exactly what I wrote below as Application Information and give it another try.

Thank you,

Carlos

0 Kudos