ALFNetworker
2 Bronze

NetWorker backups in queued status

Hello,

The company I work for is unable to upgrade the NetWorker at this time; we are running 7.5.2. I have an appointment with our EMC rep on Oct. 25th to discuss upgrade options, because we need it. But this will not help me right now, so I am hoping someone will help guide me through this process.

The issue is that I have several groups that will go into a queued status which causes the Oracle backups to go into a queued status. Once I manually stop the non-oracle backups, they (Oracle) will run fine. I figured that I would just stop and restart the NetWorker using the following commands:

nsrjb -II

H:\net stop nsrexecd

H:\sc qc nsrd

Rename temp and jobsdb

H:\net start nsrd

I checked to see if this worked by starting one of the groups that were being queued and it still will not run the backup; if I run the oracle backups, they will run fine without issue, but it is the other group that are non-oracle based that are causing the problems.

I opened a chat session earlier this morning and the tech though that changing the Parellelism to max would help the issue, but it did not. I think that I just need to reset the groups connection, or maybe I am missing something. So any ideas would be greatful.

Tags (1)
0 Kudos
3 Replies
cmartinjr
2 Bronze

Re: NetWorker backups in queued status

Hello,

This could be a couple of different things:

1) Sounds like you’re hitting the limit for number of jobs that can be run at once. I don’t remember what the default number is, but if you’re inside the networker console go to the configuration tab, right click on your networker server and go to the setup tab. Under the backup section there is a parallelism that can be increased. This number is the total number of save streams the networker environment can run at once. Increase this number then retry your backup. The tuning and admin guide will give some insight on parallelism, cause it can get kinda messy.. ☺

2) It could also be waiting on writable devices. If you’re writing your oracle backups and other backups to the same pool on the same set of devices it’s possible you could be running into this issue. The fix there would be to add more devices to the pool, or adjust the group parallelism

Thanks.

danag2
1 Copper

Re: NetWorker backups in queued status

Another thing is to check the device stream settings (default is 4). The fact that once you stop one group the other runs fine suggests it is a either a device settings or Server Parallelism setting. So recheck the following attributes on your Backup Server.

1.) Properties when highlighting the Backup Server on the configuration Tab or the Devices tab.

Server_Properties.jpg

2.) Increase it on the client for the Backup Server itself.:

Configuration_Tab_Server_Properties.jpg

3.) The Properties on the device as seen on the Library.

Device_Properties.jpg

4.) Group Parallelism Settings

Group_Properties.jpg

ALFNetworker
2 Bronze

Re: NetWorker backups in queued status

I wanted to update this, because I know how frustrating it is when an issue is resolved and the original poster does not reply to update the status. This has been fixed, even if the parallesim were changed (which did not fix the issue). The issue itself was that the NetWorker was not reading the drive where the data was being stored to backup, so the virtual drive was disconnected. I checked the disk management and was worried because I had a notification next to the virtual drive that it was unrecognizable and unreadable. My boss and I fought with this issue for a few days before we decided to just power down the SAN unit that hosted the drive, unseated and reseated the drives one by one, and then powered on the SAN unit again and low and behold there was the drive again. Backups are running now and I want to thank you for your replies and shared information. They did not work, but it is still information that should be documented and recorded for PM measures, so thank you!