NetWorker

Last reply by 10-29-2022 Unsolved
Start a Discussion
2 Bronze
2 Bronze
276

Networker 9.1.1 Save Set Recovery, No data in target directory

Hi,

I'm trying to recover a backup of a machine from 2018 from tape. Unfortunately, the save set has aged out of the media index. It was marked as 'Recyclable', but I've used mminfo to set it as 'Recoverable'.

I'm tried a save set recovery via the Networker GUI & Linux CLI. 

The process completes successfully, but no data is written to the target directory. I can see all of the volumes being mounted and read on the tape library. The Recover session says all 3TB was restored, but its not being written anywhere.

 

Any ideas or pointers would be appreciated!

 

Thanks, 

Replies (6)
5 Tungsten
263

What you tell us, cannot be completely correct:

  -  mminfo is just the tool to query the media index.It cannot change its content.

  -  To change the save set status you usually use "nsrmm -o recoverable -S ssid".

However, this was an unnecessary step as NW will only automatically delete a save set from tape if it needs to relabel/recycle it or if you do this manually. 'Recyclable' only means that the save set has expired and is 'free' to be overwritten.

Of course we cannot really know what your restore problem is - it could be that you do not have the appropriate rights for the destination.

To debug this, may I suggest that you use the command line and add more verbosity to the process. You should also save the output to a file so that you can search it later for keywords. The appropriate command would be something like:

  recover -v -S ssid [options] > file

Please see the Command Line Reference for all details and options.

NetWorker supports up to 5 'v's but in your case 1 'v' should already do the job.

 

245

Hey, You are correct I put the wrong command into the original post. nsrmm was used. 

Ill try this and see what the logs turn up. Thanks!

2 Bronze
2 Bronze
243

No luck with the logs, unless im doing it incorrectly. 

recover -v -S <ssid> -d <destination> > recovertest.log ... nothing is written to the logfile, and no files are recovered. 

I've tested another backup with a browsable save-set (it even comes off the same Tape!), its able to restore to the same destination. So im confident permissions are correct. 

 

Originally, I had been following 'EMC_NetWorker_9.1.X_AdminGuide' Page 492 'Adding information about recyclable save sets to the client file index' as an attempt to make the save-set browsable again. But now id settle for dumping the whole tape to file haha.

5 Tungsten
228

Instead of using "-v" you could also increase the debug level by using "-D#". NetWorker supports level numbers from 1 to 9. For your purpose you should not use a level higher than 3.

May I also suggest that you look at the server's daemon.raw file to see whether it has specific messages here which might help.

 

 

2 Bronze
2 Bronze
177

I managed to get the tapes scanned into the indices to perform a browsable recovery. I think the issue doing that originally was the retention date was in the past, I moved it to the end of this year, and it worked. 

Thanks for your assistance @bingo.1 I'll try that debug option if I encounter any future errors. 

 

161

Now as you mention it, I remember this issue which I encountered years ago. I think this has been resolved but I never re-tested it for some years.

BTW - do not forget that you do not need to scan the media if you recover the whole save set. All you need is media db information ... which you have already. That's enough.

 

Latest Solutions
Top Contributor