luke_m_edwards
1 Copper

Using nsrpush for NMM updates

I'm trying to used nsrpush to update the version of NetWorker & NMM.  It works via the GUI but I can't get it to work from the command line.  It works from the command line when I only have the NetWorker software package to update.  When the NMM module is installed on the client it fails. 

I'm running NW 8.1.3 & NMM 3.1.  The documentation says to use nsrpush to update from these versions.  I also read that both packages need to be updated at the same time but I'm not clear on the syntax for specifying two packages at the same time from the command line. 

This command works fine for client that do not have the NMM installed:

nsrpush -u -p NetWorker -v 8.2.4.9 clientname

This command fails for clients with the NMM installed:

nsrpush -u -p NetWorker -p "NetWorker Module for Microsoft" -v 8.2.4.9 clientname


156178:nsrpush: Client Push unable to detach from the current operation: RPC send operation failed; peer = ::1:[8506], errno = An existing connection was forcibly closed by the remote host.


RPC send operation failed; peer = ::1:[8506], errno = An existing connection was forcibly closed by the remote host.

I get the same error if I try to update the two packages independently.

Tags (1)
0 Kudos
1 Reply
Jalli Raj
1 Copper

Re: Using nsrpush for NMM updates

Seems like ports are being blocked. please check firewall connections if any

0 Kudos