Start a Conversation

Unsolved

M

12 Posts

646

July 1st, 2019 07:00

6248 switch intra vlan routing performance issue for some protocols.

Experiencing a bizarre performance issue in our network that seems to only be affecting people in 2 different VLANs.  Our Oracle ERP system is web based, we also have a simple intranet home page on a different server. Both of those web servers reside in VLAN 1.


HTTP traffic from PC's located in VLAN 110 and VLAN 180 to either of these destinations in VLAN1 is extremely slow as if the user is on a dial up connection. Web pages can take several minutes to load.  If I access the administrative share on the ERP server, or intranet web server from the users PC, I can transfer a file across the network to either server at about 95 MBs so that doesn't seem to be impaired in any way.


What could possibly cause HTTP traffic from only certain VLAN to have such poor performance, while computers in other VLANs do not exhibit the performance issue at all ? and why are other protocols seemingly not affected ?


If I reconfigure the switch port the client PC is connected to, to a different VLAN like 160 the HTTP performance issue goes away.


The two servers in question are virtual machines, they are located on different hosts in the VMWare cluster so are using different Network cards and ports to connect to the network. Clients in other VLANs do not experience the performance issue when accessing those web pages.


I've also noticed random periods of time where the performance issue goes away and things move normally.
I'm in need of some suggestions of how to track down whatever is happening here.

the switch stack has been restarted,
The switch stack was flashed to the latest firmware this past weekend in an attempt to resolve the issue.

***************** Show Running Config ***********
!Current Configuration:
!System Description "PowerConnect 6248, 3.3.18.1, VxWorks 6.5"
!System Software Version 3.3.18.1
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 10,20,30,100,110,120,130,140,150,160,170-172,175,180,185,190,200
vlan 220
vlan routing 1 1
vlan routing 110 2
vlan routing 120 3
vlan routing 100 4
vlan routing 140 6
vlan routing 130 7
vlan routing 150 8
vlan routing 200 9
vlan routing 160 10
vlan routing 30 11
vlan routing 170 12
vlan routing 171 13
vlan routing 172 14
vlan routing 175 15
vlan routing 180 16
vlan routing 185 17
vlan routing 220 18
vlan routing 190 19
exit
clock timezone -5 minutes 0 zone "EST"
stack
member 1 5
member 2 5
member 3 2
member 4 2
exit
switch 1 priority 1
ip address none
ip address vlan 10
logging facility local5
ip routing
ip route 0.0.0.0 0.0.0.0 10.100.100.3

ip helper-address 10.100.100.203 domain
ip helper-address 10.100.100.203 dhcp
ip helper-address 10.100.100.254 dhcp
ip helper-address 10.100.100.203 ntp
interface vlan 1
routing
ip address 10.100.100.239 255.255.255.0
exit
interface vlan 20
name "guestwifi"
exit
interface vlan 30
name "varmour-vlan30"
routing
ip address 10.100.30.1 255.255.255.0
exit
interface vlan 100
routing
exit
interface vlan 110
name "desgn_engr"
routing
ip address 10.100.110.1 255.255.255.0
exit
interface vlan 120
name "press room - Hudson bldg"
routing
ip address 10.100.120.1 255.255.255.0
exit
interface vlan 130
name "3rd_floor"
routing
ip address 10.100.130.1 255.255.255.0
exit
interface vlan 140
name "Bobst Area"
routing
ip address 10.100.140.1 255.255.255.0
exit
interface vlan 150
name "Shipping - Warehouse"
routing
ip address 10.100.150.1 255.255.255.0
exit
interface vlan 160
name "Fifth_Floor_PC"
routing
ip address 10.100.160.1 255.255.255.0
exit
interface vlan 170
name "Packetfence"
routing
exit
interface vlan 171
name "Registration"
routing
exit
interface vlan 172
name "Isolation"
routing
exit
interface vlan 175
name "Wifi"
routing
ip address 10.100.75.1 255.255.255.0
exit
interface vlan 180
name "Wired_LAN"
routing
ip address 10.100.80.1 255.255.255.0
exit
interface vlan 185
name "Printers"
routing
ip address 10.100.85.1 255.255.255.0
exit
interface vlan 190
routing
ip address 10.100.190.1 255.255.255.0
exit
interface vlan 200
name "voip"
routing
ip address 10.100.200.1 255.255.255.0
exit
interface vlan 220
name "Guest_Wifi"
routing
ip address 10.100.22.1 255.255.255.0
exit
username " " password level 15 encrypted
dot1x system-auth-control
aaa authentication dot1x default radius
aaa authorization network default radius
voice vlan
radius-server key " "
radius-server host auth 10.100.X.X
name "Packetfence"
usage 802.1x
exit

monitor session 1 mode
line ssh
exec-timeout 1200
exit
spanning-tree priority 4096
!
interface ethernet 1/g1
description 'Watchguard Firewall Connection'
spanning-tree portfast
dot1x port-control force-authorized
exit
!
interface ethernet 1/g2
spanning-tree portfast
switchport mode general
switchport general pvid 171
switchport general allowed vlan add 171-172,180,185
switchport general allowed vlan add 200 tagged
dot1x port-control mac-based
dot1x re-authentication
dot1x unauth-vlan 171
dot1x mac-auth-bypass
exit
!
interface ethernet 1/g3
spanning-tree portfast
switchport mode general
switchport general pvid 171
switchport general allowed vlan add 171-172,180,185
switchport general allowed vlan add 200 tagged
dot1x port-control mac-based
dot1x re-authentication
dot1x unauth-vlan 171
dot1x mac-auth-bypass
exit
!
interface ethernet 1/g4
spanning-tree portfast
switchport mode general
switchport general pvid 171
switchport general allowed vlan add 171-172,180,185
switchport general allowed vlan add 200 tagged
dot1x port-control mac-based
dot1x re-authentication
dot1x unauth-vlan 171
dot1x mac-auth-bypass
exit
!
interface ethernet 1/g5
description 'Joels Office'
spanning-tree portfast
dot1x port-control force-authorized
exit
!
interface ethernet 1/g6
description 'Cisco VoIP ATA'
spanning-tree portfast
dot1x port-control force-authorized
exit
!
interface ethernet 1/g7
spanning-tree portfast
switchport mode general
switchport general pvid 171
switchport general allowed vlan add 171-172,180,185
switchport general allowed vlan add 200 tagged
dot1x port-control mac-based
dot1x re-authentication
dot1x unauth-vlan 171
dot1x mac-auth-bypass
exit
!
interface ethernet 1/g8
spanning-tree portfast
switchport mode general
switchport general pvid 171
switchport general allowed vlan add 171-172,180,185
switchport general allowed vlan add 200 tagged
dot1x port-control mac-based
dot1x re-authentication
dot1x unauth-vlan 171
dot1x mac-auth-bypass
exit
!
interface ethernet 1/g9
description 'Mail Room plus Wifi'
spanning-tree portfast
switchport mode general
switchport general pvid 160
switchport general allowed vlan add 160
switchport general allowed vlan add 200 tagged
dot1x port-control force-authorized
exit
!
interface ethernet 1/g10
spanning-tree portfast
switchport mode general
switchport general pvid 171
switchport general allowed vlan add 171-172,180,185
switchport general allowed vlan add 200 tagged
dot1x port-control mac-based
dot1x re-authentication
dot1x unauth-vlan 171
dot1x mac-auth-bypass
exit
!
interface ethernet 1/g11
description 'Rons Office'
spanning-tree portfast
switchport mode general
switchport general pvid 160
switchport general allowed vlan add 160
switchport general allowed vlan add 200 tagged
dot1x port-control force-authorized
exit
!
interface ethernet 1/g12
spanning-tree portfast
switchport mode general
switchport general pvid 171
switchport general allowed vlan add 171-172,180,185
switchport general allowed vlan add 200 tagged
dot1x port-control mac-based
dot1x re-authentication
dot1x unauth-vlan 171
dot1x mac-auth-bypass
exit
!
interface ethernet 1/g13
spanning-tree portfast
switchport mode general
switchport general pvid 171
switchport general allowed vlan add 171-172,180,185
switchport general allowed vlan add 200 tagged
dot1x port-control mac-based
dot1x re-authentication
dot1x unauth-vlan 171
dot1x mac-auth-bypass
exit
!
interface ethernet 1/g14
spanning-tree portfast
switchport mode general
switchport general pvid 160
switchport general allowed vlan add 160
switchport general allowed vlan add 200 tagged
dot1x port-control force-authorized
exit
!
interface ethernet 1/g15
spanning-tree portfast
switchport mode general
switchport general pvid 171
switchport general allowed vlan add 171-172,180,185
switchport general allowed vlan add 200 tagged
dot1x port-control mac-based
dot1x re-authentication
dot1x unauth-vlan 171
dot1x mac-auth-bypass
exit
.
.

interface ethernet 4/g47
dot1x port-control force-authorized
exit
!
interface ethernet 4/g48
dot1x port-control force-authorized
exit
!
interface loopback 1
exit
snmp-server community rw
snmp-server community ro
exit
****** show version / Sysinfo *******
System Description............................. PowerConnect 6248, 3.3.18.1
VxWorks 6.5
Machine Type................................... PowerConnect 6248
Machine Model.................................. PCT6248
Part Number.................................... BCM56314
Software Version............................... 3.3.18.1
System Up Time................................. 1 days, 21h:04m:00s
10/100 Ethernet/802.3 interface(s)............. 40
Gig Ethernet/802.3 interface(s)................ 51
10Gig Ethernet/802.3 interface(s).............. 0
Virtual Ethernet/802.3 interface(s)............ 19

Management Standby Preconfig Plugged-in Switch Code
Switch Switch Status Model ID Model ID Status Version
------ ------------ ------------- ------------- --------------------- --------
1 Mgmt Switch PCT6248P PCT6248P OK 3.3.18.1
2 Stack Member PCT6248P PCT6248P OK 3.3.18.1
3 Stack Member PCT6248 PCT6248 OK 3.3.18.1
4 Stack Member PCT6248 PCT6248 OK 3.3.18.1

 

 

Moderator

 • 

8.7K Posts

July 1st, 2019 09:00

Hi,

Is everything going through the one switch or are their other devices in between? You may want to mirror one of those ports and use wireshark to see if there are dropped packets or something else going on. It looks like you are up to date on firmware and have moved the management vlan from vlan 1, which are common reasons for performance issues.

No Events found!

Top