w60
1 Nickel

How to create new port channel on auto-lag enabled switch when ports are already in portmode hybrid?

All,

  I am totally new to dell switches (cisco background) and have been asked to create a port channel split over a pair of existing dell aggregator enclosure switches. All the other ports which are connected to the servers except the ports in question I am trying to configure are in port channel.

I have read that they cannot be in a port mode to do auto-lag port channel but I seem to be totally failing to workout how to:

1) Create a new port channel

2) Take the existing ports out of the port mode

3) Add the port to the new port channel.

When I try to create a new port channel interface  I get as shown below

agg1(conf)#int po16
Error: Command allowed only for uplink Lag.

The port(s) I am try to change currently have this config:

interface TenGigabitEthernet 0/1
 mtu 12000
 portmode hybrid
 switchport
 vlan tagged 220,223,950
 flowcontrol rx on tx off
!
 protocol lldp
  advertise management-tlv management-address system-name
  dcbx port-role auto-downstream
 no shutdown

And I am trying to get them in to the same config as this example port on the same switch (with a different port channel unique to the t0/1 port on both dell aggregators)

interface TenGigabitEthernet 0/2
 mtu 12000
 vlan tagged 220,223,950
 flowcontrol rx on tx off
!
 port-channel-protocol LACP
  port-channel 1 mode active
!
 protocol lldp
  advertise management-tlv management-address system-name
  dcbx port-role auto-downstream
 no shutdown

which is then tied to :


!
interface Port-channel 1
 mtu 12000
 portmode hybrid
 switchport
 vlt-peer-lag port-channel 1
 no shutdown
 link-bundle-monitor enable

I am sure I must be missing some top level command somewhere that allow me to configure but I seem to be going round in circles and the only guides seem to be coming from a fresh switch setup (and concerned I am going to impact the setup of the other ports.

Any pointers would be greatly appreiciated

0 Kudos
10 Replies
murmanov
2 Iron

RE: How to create new port channel on auto-lag enabled switch when ports are already in portmode hybrid?

If this ports are not in production try to apply following commands:

default int te0/1

int te0/1
port-channel-protocol LACP
port-channel 100 mode active

int po100
mtu 12000
portmode hybrid
switchport
vlt-peer-lag port-channel 100
no shutdown
link-bundle-monitor enable

int te0/1
flowcontrol rx on tx off
protocol lldp
advertise management-tlv management-address system-name
dcbx port-role auto-downstream

I believe you should apply your vlans on the configured port-channel and you can try to enter no auto-lag enable on the port level as well. Can check this clearly since I don't have aggregators at this moment

0 Kudos
w60
1 Nickel

RE: How to create new port channel on auto-lag enabled switch when ports are already in portmode hybrid?

Thanks - unfortunately the switch does not take the command to default the interface config back. (the only option off default is default  vlan:

agg1(conf)#default ?
vlan-id                 Set default VLAN Id

I tried pulling the vlans tagged on to the interfaces I am trying t change but this did not seem to get me any further

0 Kudos
murmanov
2 Iron

RE: How to create new port channel on auto-lag enabled switch when ports are already in portmode hybrid?

Did you tried to configure

no auto-lag enable

on the port level.

Also you should add interface to port-channel first, than it should allow you to add port-channel configs. What switch says, when you trying to add those commands?

int te0/1
port-channel-protocol LACP
port-channel 100 mode active

0 Kudos
w60
1 Nickel

RE: How to create new port channel on auto-lag enabled switch when ports are already in portmode hybrid?

Thanks -unfortunately per below output I tried removing the vlans and the auto-lag but it doesnt give me any the option to issue the port channel cmd (I''ve listed the ones available under the interface below):

agg1#sho run int t0/1
!
interface TenGigabitEthernet 0/1
 mtu 12000
 portmode hybrid
 switchport
 vlan tagged 220,223,950
 flowcontrol rx on tx off
 no negotiation auto
!
 protocol lldp
  advertise management-tlv management-address system-name
  dcbx port-role auto-downstream
 no shutdown
agg1#conf t
agg1(conf)#
agg1(conf)#int t0/1
agg1(conf-if-te-0/1)#no  vlan tagged 220,223,950
agg1(conf-if-te-0/1)#no auto-lag enable
Configure interface on peer VLT to sync auto-lag configuration.

agg1#sho run int t0/1
!
interface TenGigabitEthernet 0/1
 mtu 12000
 portmode hybrid
 switchport
 no auto-lag enable
 flowcontrol rx on tx off
 no negotiation auto
!
 protocol lldp
  advertise management-tlv management-address system-name
  dcbx port-role auto-downstream
 no shutdown

agg1(conf-if-te-0/1)#port-channel-protocol LACP
                                    ^
% Error: Invalid input at "^" marker.
agg1(conf-if-te-0/1)#port-channel 100 mode active
                                    ^
% Error: Invalid input at "^" marker.
agg1(conf-if-te-0/1)#?
auto-lag                        Enable the auto LAG feature on interface
description                     Interface description(max length 240)
end                             Exit from configuration mode
exit                            Exit from interface configuration mode
fcoe-map                        Fcoe Map configuration
keepalive                       Enable keepalive
negotiation                     Select autonegotiation mode
no                              Negate a command or set its defaults
protocol                        Configure a protocol
remote-fault-signaling          Ignore the remote fault signaling for selected interface
show                            Show interface configuration information
shutdown                        Shutdown the selected interface
speed                           Interface speed parameter
vlan                            Specify tagged or untagged VLAN(s)

agg1#sho inv
System Type            : I/O-Aggregator
System Mode            : 1.0
Software Version       : 9.9(0.0P17)

Unit Type                      Serial Number  Part Number  Rev  Piece Part ID            Rev  Svc Tag  Exprs Svc Code
---------------------------------------------------------------------------------------------------------------------
* 0  I/O-Aggregator            CN*********  07N58NA00    A00  CN-07N58N-28298-64G-0003 A00  ******  348 919 527 8

 * - Management Unit


Software Protocol Configured
--------------------------------------------------------------
  FIP Snooping
  IGMP
  iSCSI
  LLDP
  NTP
  SNMP

0 Kudos
w60
1 Nickel

RE: How to create new port channel on auto-lag enabled switch when ports are already in portmode hybrid?

Just bumping in case anyone has any suggestions on how to get the ports in to an port channel -- thanks

0 Kudos
Moderator
Moderator

RE: How to create new port channel on auto-lag enabled switch when ports are already in portmode hybrid?

What mode is the switch in? You may need to change to PMUX mode.

# stack-unit unit iom-mode programmable-mux

Once that is done you should have some further commands available.

Page 145: http://dell.to/2qD2UNz

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
w60
1 Nickel

RE: How to create new port channel on auto-lag enabled switch when ports are already in portmode hybrid?

Thanks for the reply I VLT mode (if I found the right cmd to advise):

agg1#show system stack-unit 0 iom-mode
Unit    Boot-Mode               Next-Boot
------------------------------------------------
0        vlt                    vlt

Looking at going in the PMUX mode, it sounds like you have to reboot to change the mode. Is there any other impact (i.e. would any of the existing VLT config be lost)?

0 Kudos
Moderator
Moderator

RE: How to create new port channel on auto-lag enabled switch when ports are already in portmode hybrid?

Sorry, I did not catch that, so this switch is setup as a VLT peer with another switch? In that case you will need to leave it in vlt mode. I will keep doing some research.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
w60
1 Nickel

RE: How to create new port channel on auto-lag enabled switch when ports are already in portmode hybrid?

Thanks -- to confirm it is in VLT mode with another aggregator in the same chassis. All the other ports going to the servers are in port channels which are working without issue. Just the first port T0/1 on both aggregators are not in a channel

0 Kudos