MichaelCain
Copper

Slow LAN performance through PowerConnect Switches

I'm having a problem getting the full throughput potential of my PowerConnect 5548 switch.  I've run tests with iperf and file transfers using all manor of clients (Windows, Linux, Dell, Lenovo, NetGear, virtual, physical, etc.) and cannot figure out how to get full link speed throughput.

Right now I've got two NetGear ReadyNAS devices transferring 6 TB between them and it is plateaued at 53 Mbit/sec.  All ports report 1000M/full duplex.  No interface errors.

The fastest test I've run was with iperf.exe at 300 Gbit/sec.

I'm reading throughput via SNMP with WhatsUp Gold.

The switch's running config is included below.  Any suggestions?

spanning-tree pathcost method short
vlan database
vlan 10-11
exit
voice vlan oui-table add 000181 Nortel__________________
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 001049 Shoretel________________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00907a Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
iscsi target port 860 address 0.0.0.0
iscsi target port 3260 address 0.0.0.0
iscsi target port 9876 address 0.0.0.0
iscsi target port 20002 address 0.0.0.0
iscsi target port 20003 address 0.0.0.0
iscsi target port 25555 address 0.0.0.0
no qos
qos statistics queues 2 all low all
hostname pnsw080
logging host 192.168.1.113 facility local6
username xxxxxxx password encrypted xxxxxxxxxxxxxxx privilege 15
snmp-server location "xxxxxxx"
snmp-server contact "IT Infrastructure"
snmp-server community xxxxxxx ro view Default
clock source sntp
sntp server 192.168.0.51 poll
!
interface vlan 1
ip address 192.168.0.80 255.255.254.0
!
interface vlan 10
name ScaleBackplane
!
interface vlan 11
name "ScaleBackplane 2"
!
interface gigabitethernet1/0/1
flowcontrol off
description "uplink to pnsw437 g7"
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree link-type point-to-point
channel-group 1 mode on
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/2
description "uplink to pnsw437 g8"
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree link-type point-to-point
channel-group 1 mode on
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/3
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/4
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/5
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/6
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/7
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/8
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/9
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/10
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/11
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/12
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/13
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/14
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/15
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/16
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/17
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/18
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/19
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/20
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/21
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/22
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/23
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/24
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/25
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/26
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/27
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/28
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/29
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
switchport access vlan 11
!
interface gigabitethernet1/0/30
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/31
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
switchport access vlan 11
!
interface gigabitethernet1/0/32
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/33
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
switchport access vlan 11
!
interface gigabitethernet1/0/34
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/35
description "ReadyNAS gi1/0/35"
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/36
flowcontrol off
description "ReadyNAS gi1/0/36"
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/37
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
switchport access vlan 10
!
interface gigabitethernet1/0/38
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/39
flowcontrol off
description pnups31
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/40
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/41
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/42
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/43
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/44
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface gigabitethernet1/0/45
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
switchport access vlan 10
!
interface gigabitethernet1/0/46
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
switchport access vlan 10
!
interface gigabitethernet1/0/47
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
switchport access vlan 10
!
interface gigabitethernet1/0/48
flowcontrol off
gvrp vlan-creation-forbid
gvrp registration-forbid
spanning-tree portfast
spanning-tree cost 2000000
spanning-tree bpduguard enable
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface tengigabitethernet1/0/1
gvrp vlan-creation-forbid
gvrp registration-forbid
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface tengigabitethernet1/0/2
gvrp vlan-creation-forbid
gvrp registration-forbid
lldp optional-tlv sys-name
lldp management-address 192.168.0.80
!
interface Port-channel1
flowcontrol off
description "LAG to pnsw437"
gvrp vlan-creation-forbid
gvrp registration-forbid
!
interface Port-channel2
flowcontrol off
!
interface Port-channel10
description ReadyNAS
gvrp vlan-creation-forbid
gvrp registration-forbid
!
ip route 0.0.0.0 0.0.0.0 192.168.1.1
0 Kudos
1 Reply
Moderator
Moderator

Re: Slow LAN performance through PowerConnect Switches

Which Netgear ready NAS are you using? I have seen some benchmarks for some of the Ready NAS devices that are right in line with your 53 Mbit/Sec  reading.

The following document references EqualLogic iSCSI optimization, but the tips and recommendations it has should help here as well. Such as Jumbo frames, flow control, portfast and unicast storm control tips in appendix A.

www.dell.com/.../Dell_EqualLogic_%20iSCSI_Optimization_for_Dell_Power_onnect_%20Switches.pdf

Here is a good article from netgear in reference to ReadyNAS performance.

http://www.readynas.com/?p=310

And we always recommend having the latest firmware loaded to ensure the switch is running as optimal as it can.

www.dell.com/.../powerconnect-5548

Keep us updated,

Thanks.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos