jjburnett
1 Copper

Speed and Routing Issues on 6248

We have a client that had an outside source configure these power connect 6248s. There are two and they are in a stack. I'm a Cisco guy so there are commands that confuse me and I'm unsure about the best practices with Dell.

This was a new install. With a new EQL San, new Dell servers and new dell switches. 

The client is having speed issues - file transfers are in the 20 mb range and random hiccups and stalls throughout the day. Pings ping at 1-2 ms then jump to over a 100 for 1-2 pings then back down to 1-2ms.

I've checked the utilization for memory and cpu and its all fine. I really feel like its mis-configured... Maybe with the routing and VLANS. Any thoughts would be appreciated. 

Confg:


!System Description "PowerConnect 6248, 3.3.7.2, VxWorks 6.5"
!System Software Version 3.3.7.2
!Cut-through mode is configured as disabled
!
configure
boot host auto-save
vlan database
vlan 2-6,100
vlan routing 1 1
vlan routing 2 2
vlan routing 3 3
vlan routing 4 4
vlan routing 5 5
vlan routing 6 6
vlan routing 100 7
exit
sntp unicast client enable
sntp server 10.4.59.61


clock summer-time recurring USA
clock timezone -5 minutes 0 zone "EST"
stack
member 1 2
member 2 2
exit
ip address none
ip domain-name *snip*
ip name-server 10.4.59.61
logging console error
logging buffered error
ip routing
ip route 10.21.58.0 255.255.255.0 10.254.251.1
ip route 10.21.57.0 255.255.255.0 10.254.251.1
ip route 10.21.59.0 255.255.255.0 192.168.1.2
ip route 10.21.60.0 255.255.255.0 192.168.1.2
ip route 10.254.252.0 255.255.255.0 10.254.251.1
ip route 0.0.0.0 0.0.0.0 10.4.57.253
ip route 10.21.61.0 255.255.255.0 192.168.1.2
ip helper-address 10.4.59.61
interface vlan 1


routing
ip address 10.4.57.254 255.255.255.0
exit
interface vlan 2
name "VDI"
routing
ip address 10.4.58.254 255.255.255.0
exit
interface vlan 3
name "servers"
routing
ip address 10.4.59.254 255.255.255.0
exit
interface vlan 4
name "management"
routing
ip address 10.4.60.254 255.255.255.0
exit
interface vlan 5
name "WAN"
routing


ip address 10.254.251.5 255.255.255.0
exit
interface vlan 6
name "iSCSI"
routing
exit
interface vlan 100
name "labL3"
routing
ip address 192.168.1.1 255.255.255.252
exit

username "admin" password 4e762ee7b57dd4c704bc5d0959dc32ec level 15 encrypted
spanning-tree mode stp
spanning-tree priority 4096
!
interface ethernet 1/g1
channel-group 1 mode on
exit
!
interface ethernet 1/g2
channel-group 2 mode on


exit
!
interface ethernet 1/g3
channel-group 3 mode on
exit
!
interface ethernet 1/g4
channel-group 4 mode on
exit
!
interface ethernet 1/g5
channel-group 5 mode auto
exit
!
interface ethernet 1/g6
channel-group 5 mode auto
exit
!
interface ethernet 1/g7
spanning-tree portfast
exit


!
interface ethernet 1/g8
spanning-tree portfast
exit
!
interface ethernet 1/g9
spanning-tree portfast
exit
!
interface ethernet 1/g10
spanning-tree portfast
exit
!
interface ethernet 1/g11
spanning-tree portfast
exit
!
interface ethernet 1/g12
spanning-tree portfast
exit
!


interface ethernet 1/g13
channel-group 13 mode on
exit
!
interface ethernet 1/g14
channel-group 14 mode on
exit
!
interface ethernet 1/g15
channel-group 15 mode on
spanning-tree portfast
switchport access vlan 4
exit
!
interface ethernet 1/g16
channel-group 16 mode on
exit
!
interface ethernet 1/g17
spanning-tree portfast
switchport access vlan 4


exit
!
interface ethernet 1/g18
spanning-tree portfast
exit
!
interface ethernet 1/g19
spanning-tree portfast
switchport access vlan 4
exit
!
interface ethernet 1/g20
spanning-tree portfast
switchport access vlan 4
exit
!
interface ethernet 1/g21
spanning-tree portfast
switchport access vlan 4
exit
!


interface ethernet 1/g22
spanning-tree portfast
switchport access vlan 4
exit
!
interface ethernet 1/g23
spanning-tree portfast
switchport access vlan 4
exit
!
interface ethernet 1/g24
spanning-tree portfast
switchport access vlan 4
exit
!
interface ethernet 1/g25
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6


exit
!
interface ethernet 1/g26
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!
interface ethernet 1/g27
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!
interface ethernet 1/g28
storm-control broadcast
storm-control multicast


spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!
interface ethernet 1/g29
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!
interface ethernet 1/g30
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!


interface ethernet 1/g31
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!
interface ethernet 1/g32
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!
interface ethernet 1/g33
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216


switchport access vlan 6
exit
!
interface ethernet 1/g34
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!
interface ethernet 1/g35
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!
interface ethernet 1/g36
storm-control broadcast


storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!
interface ethernet 1/g37
spanning-tree portfast
exit
!
interface ethernet 1/g38
spanning-tree portfast
exit
!
interface ethernet 1/g39
channel-group 39 mode on
exit
!
interface ethernet 1/g40
channel-group 40 mode on
exit


!
interface ethernet 1/g41
channel-group 41 mode on
exit
!
interface ethernet 1/g42
channel-group 42 mode on
exit
!
interface ethernet 1/g43
channel-group 43 mode on
exit
!
interface ethernet 1/g44
spanning-tree portfast
switchport access vlan 100
exit
!
interface ethernet 1/g45
spanning-tree portfast
exit


!
interface ethernet 1/g46
spanning-tree portfast
switchport access vlan 5
exit
!
interface ethernet 1/g47
description 'ShoreTel_Phone_System'
spanning-tree portfast
exit
!
interface ethernet 1/g48
spanning-tree portfast
exit
!
interface ethernet 2/g1
channel-group 1 mode on
exit
!
interface ethernet 2/g2
channel-group 2 mode on


exit
!
interface ethernet 2/g3
channel-group 3 mode on
exit
!
interface ethernet 2/g4
channel-group 4 mode on
exit
!
interface ethernet 2/g5
channel-group 5 mode auto
exit
!
interface ethernet 2/g6
channel-group 5 mode auto
exit
!
interface ethernet 2/g7
spanning-tree portfast
exit


!
interface ethernet 2/g8
spanning-tree portfast
exit
!
interface ethernet 2/g9
spanning-tree portfast
exit
!
interface ethernet 2/g10
spanning-tree portfast
exit
!
interface ethernet 2/g11
spanning-tree portfast
exit
!
interface ethernet 2/g12
spanning-tree portfast
exit
!


interface ethernet 2/g13
channel-group 13 mode on
exit
!
interface ethernet 2/g14
channel-group 14 mode on
exit
!
interface ethernet 2/g15
channel-group 15 mode on
spanning-tree portfast
switchport access vlan 4
exit
!
interface ethernet 2/g16
channel-group 16 mode on
exit
!
interface ethernet 2/g17
spanning-tree portfast
switchport access vlan 4


exit
!
interface ethernet 2/g18
spanning-tree portfast
exit
!
interface ethernet 2/g19
spanning-tree portfast
switchport access vlan 4
exit
!
interface ethernet 2/g20
spanning-tree portfast
switchport access vlan 4
exit
!
interface ethernet 2/g21
spanning-tree portfast
switchport access vlan 4
exit
!


interface ethernet 2/g22
spanning-tree portfast
switchport access vlan 4
exit
!
interface ethernet 2/g23
spanning-tree portfast
switchport access vlan 4
exit
!
interface ethernet 2/g24
spanning-tree portfast
switchport access vlan 4
exit
!
interface ethernet 2/g25
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6


exit
!
interface ethernet 2/g26
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!
interface ethernet 2/g27
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!
interface ethernet 2/g28
storm-control broadcast
storm-control multicast


spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!
interface ethernet 2/g29
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!
interface ethernet 2/g30
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!


interface ethernet 2/g31
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!
interface ethernet 2/g32
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!
interface ethernet 2/g33
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216


switchport access vlan 6
exit
!
interface ethernet 2/g34
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!
interface ethernet 2/g35
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!
interface ethernet 2/g36
storm-control broadcast


storm-control multicast
spanning-tree portfast
mtu 9216
switchport access vlan 6
exit
!
interface ethernet 2/g37
spanning-tree portfast
exit
!
interface ethernet 2/g38
spanning-tree portfast
exit
!
interface ethernet 2/g39
channel-group 39 mode on
exit
!
interface ethernet 2/g40
channel-group 40 mode on
exit


!
interface ethernet 2/g41
channel-group 41 mode on
exit
!
interface ethernet 2/g42
channel-group 42 mode on
exit
!
interface ethernet 2/g43
channel-group 43 mode on
exit
!
interface ethernet 2/g44
spanning-tree portfast
exit
!
interface ethernet 2/g45
spanning-tree portfast
exit
!


interface ethernet 2/g46
spanning-tree portfast
switchport access vlan 5
exit
!
interface ethernet 2/g47
description 'ShoreTel_Phone_System'
spanning-tree portfast
exit
!
interface ethernet 2/g48
spanning-tree portfast
exit
!
interface port-channel 1
description 'Trunk to ESX01'
hashing-mode 6
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 1-5
exit


!
interface port-channel 2
description 'Trunk to ESX 02'
hashing-mode 6
spanning-tree portfast
switchport mode trunk
switchport trunk allowed vlan add 1-5
exit
!
interface port-channel 3
description 'Trunk to ESX 03'
hashing-mode 6
spanning-tree portfast
switchport access vlan 2
exit
!
interface port-channel 4
description 'Trunk to ESX 04'
hashing-mode 6
spanning-tree portfast
switchport access vlan 2


exit
!
interface port-channel 5
hashing-mode 6
spanning-tree portfast
switchport access vlan 3
exit
!
interface port-channel 6
description 'Uplink back to old Core'
exit
!
interface port-channel 13
description 'Channel to MGMT on ESX 01'
hashing-mode 6
spanning-tree portfast
switchport access vlan 4
exit
!
interface port-channel 14
description 'Channel to MGMT on ESX 02'


hashing-mode 6
spanning-tree portfast
switchport access vlan 4
exit
!
interface port-channel 15
description 'Channel to MGMT on ESX 03'
hashing-mode 6
spanning-tree portfast
switchport access vlan 4
exit
!
interface port-channel 16
description 'Channel to MGMT on ESX 04'
hashing-mode 6
spanning-tree portfast
switchport access vlan 4
exit
!
interface port-channel 39
description 'Uplinks to IDF Switches'


switchport mode general
exit
!
interface port-channel 40
description 'Uplinks to IDF Switches'
switchport mode general
exit
!
interface port-channel 41
description 'Uplinks to IDF Switches'
switchport mode general
exit
!
interface port-channel 42
description 'Uplinks to IDF Switches'
switchport mode general
exit
!
interface port-channel 43
description 'Uplinks to IDF Switches'
switchport mode general


exit
exit
0 Kudos
6 Replies
Moderator
Moderator

Re: Speed and Routing Issues on 6248

The best practices are to enable flowcontrol, and have all Bcast, Mcast and Ucast modes disabled (show storm-control all).

Also ensure rstp (rapid spanning tree protocol) is enabled (show spanning-tree, look for mode: rstp

This is a link to a configuration portal:

en.community.dell.com/.../3615.rapid-equallogic-configuration-portal-by-sis.aspx

-joe

-Joe

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

Follow me on Twitter: @joesatdell 

0 Kudos
jjburnett
1 Copper

Re: Speed and Routing Issues on 6248

Thanks Joe. Your changes seem to help but not resolve the issues. When we try copying a 25 gig file across it - the copy now starts at 100~ (way higher than before) and sustains it for about 5 seconds then drops to ~60 and then finally copies around 20 ish.

Made the change for the iSCSI ports. I also ran spanning tree mode rstp from global config. When I run the show spanning tree I get this:

Name    State   Prio.Nbr    Cost       Sts  Role PortFast  Restricted

------  -------- --------- ----------  ---- ----- --------  -------

1/g1    Enabled  128.1             0   FWD  Disb      No      No

1/g2    Enabled  128.2             0   FWD  Disb      No      No

1/g3    Enabled  128.3             0   FWD  Disb      No      No

1/g4    Enabled  128.4             0   FWD  Disb      No      No

Name    State   Prio.Nbr    Cost       Sts  Role PortFast  Restricted

------  -------- --------- ----------  ---- ----- --------  -------

1/g5    Enabled  128.5             0   FWD  Disb      No      No

1/g6    Enabled  128.6             0   FWD  Disb      No      No

1/g7    Enabled  128.7             0   DIS  Disb     Yes      No

1/g8    Enabled  128.8             0   DIS  Disb     Yes      No

1/g9    Enabled  128.9             0   DIS  Disb     Yes      No

1/g10   Enabled  128.10            0   DIS  Disb     Yes      No

1/g11   Enabled  128.11            0   DIS  Disb     Yes      No

1/g12   Enabled  128.12            0   DIS  Disb     Yes      No

1/g13   Enabled  128.13            0   FWD  Disb      No      No

1/g14   Enabled  128.14            0   FWD  Disb      No      No

1/g15   Enabled  128.15            0   FWD  Disb     Yes      No

1/g16   Enabled  128.16            0   FWD  Disb      No      No

1/g17   Enabled  128.17            0   DIS  Disb     Yes      No

1/g18   Enabled  128.18            0   DIS  Disb     Yes      No

1/g19   Enabled  128.19            0   DIS  Disb     Yes      No

1/g20   Enabled  128.20            0   DIS  Disb     Yes      No

Name    State   Prio.Nbr    Cost       Sts  Role PortFast  Restricted

------  -------- --------- ----------  ---- ----- --------  -------

1/g21   Enabled  128.21        20000   FWD  Desg     Yes      No

1/g22   Enabled  128.22            0   DIS  Disb     Yes      No

1/g23   Enabled  128.23        20000   FWD  Desg     Yes      No

1/g24   Enabled  128.24       200000   FWD  Desg     Yes      No

1/g25   Enabled  128.25        20000   FWD  Desg     Yes      No

1/g26   Enabled  128.26        20000   FWD  Desg     Yes      No

1/g27   Enabled  128.27        20000   FWD  Desg     Yes      No

1/g28   Enabled  128.28        20000   FWD  Desg     Yes      No

1/g29   Enabled  128.29        20000   FWD  Desg     Yes      No

1/g30   Enabled  128.30        20000   FWD  Desg     Yes      No

1/g31   Enabled  128.31        20000   FWD  Desg     Yes      No

1/g32   Enabled  128.32        20000   FWD  Desg     Yes      No

1/g33   Enabled  128.33        20000   FWD  Desg     Yes      No

1/g34   Enabled  128.34        20000   FWD  Desg     Yes      No

1/g35   Enabled  128.35        20000   FWD  Desg     Yes      No

1/g36   Enabled  128.36        20000   FWD  Desg     Yes      No

Name    State   Prio.Nbr    Cost       Sts  Role PortFast  Restricted

------  -------- --------- ----------  ---- ----- --------  -------

1/g37   Enabled  128.37       200000   FWD  Desg     Yes      No

1/g38   Enabled  128.38       200000   FWD  Desg     Yes      No

1/g39   Enabled  128.39            0   FWD  Disb      No      No

1/g40   Enabled  128.40            0   FWD  Disb      No      No

1/g41   Enabled  128.41            0   FWD  Disb      No      No

1/g42   Enabled  128.42            0   FWD  Disb      No      No

1/g43   Enabled  128.43            0   FWD  Disb      No      No

1/g44   Enabled  128.44        20000   FWD  Desg     Yes      No

1/g45   Enabled  128.45        20000   FWD  Desg     Yes      No

1/g46   Enabled  128.46       200000   FWD  Desg     Yes      No

1/g47   Enabled  128.47       200000   FWD  Desg     Yes      No

1/g48   Enabled  128.48        20000   FWD  Desg     Yes      No

1/xg1   Enabled  128.49            0   DIS  Disb      No      No

1/xg2   Enabled  128.50            0   DIS  Disb      No      No

1/xg3   Enabled  128.51            0   DIS  Disb      No      No

1/xg4   Enabled  128.52            0   DIS  Disb      No      No

Name    State   Prio.Nbr    Cost       Sts  Role PortFast  Restricted

------  -------- --------- ----------  ---- ----- --------  -------

2/g1    Enabled  128.53            0   FWD  Disb      No      No

2/g2    Enabled  128.54            0   FWD  Disb      No      No

2/g3    Enabled  128.55            0   FWD  Disb      No      No

2/g4    Enabled  128.56            0   FWD  Disb      No      No

2/g5    Enabled  128.57            0   FWD  Disb      No      No

2/g6    Enabled  128.58            0   FWD  Disb      No      No

2/g7    Enabled  128.59        20000   FWD  Desg     Yes      No

2/g8    Enabled  128.60        20000   FWD  Desg     Yes      No

2/g9    Enabled  128.61        20000   FWD  Desg     Yes      No

2/g10   Enabled  128.62       200000   FWD  Desg     Yes      No

2/g11   Enabled  128.63        20000   FWD  Desg     Yes      No

2/g12   Enabled  128.64        20000   FWD  Desg     Yes      No

2/g13   Enabled  128.65            0   FWD  Disb      No      No

2/g14   Enabled  128.66            0   FWD  Disb      No      No

2/g15   Enabled  128.67            0   FWD  Disb     Yes      No

2/g16   Enabled  128.68            0   FWD  Disb      No      No

* Snip*

And the new config looks like this:

!Current Configuration:

!System Description "PowerConnect 6248, 3.3.7.2, VxWorks 6.5"

!System Software Version 3.3.7.2

!Cut-through mode is configured as disabled

!

configure

boot host auto-save

vlan database

vlan 2-6,100

vlan routing 1 1

vlan routing 2 2

vlan routing 3 3

vlan routing 4 4

vlan routing 5 5

vlan routing 100 7

exit

hostname "CRSW01SVIN"

sntp unicast client enable

sntp server 10.4.59.61

clock summer-time recurring USA

clock timezone -5 minutes 0 zone "EST"

stack

member 1 2

member 2 2

exit

ip address none

ip domain-name ****

ip name-server 10.4.59.61

logging console error

logging buffered error

ip routing

ip route 10.21.58.0 255.255.255.0 10.254.251.1

ip route 10.21.57.0 255.255.255.0 10.254.251.1

ip route 10.21.59.0 255.255.255.0 192.168.1.2

ip route 10.21.60.0 255.255.255.0 192.168.1.2

ip route 10.254.252.0 255.255.255.0 10.254.251.1

ip route 0.0.0.0 0.0.0.0 10.4.57.253

ip route 10.21.61.0 255.255.255.0 192.168.1.2

ip helper-address 10.4.59.61

interface vlan 1

routing

ip address 10.4.57.254 255.255.255.0

exit

interface vlan 2

name "VDI"

routing

ip address 10.4.58.254 255.255.255.0

exit

interface vlan 3

name "servers"

routing

ip address 10.4.59.254 255.255.255.0

exit

interface vlan 4

name "management"

routing

ip address 10.4.60.254 255.255.255.0

exit

interface vlan 5

name "WAN"

routing

ip address 10.254.251.5 255.255.255.0

exit

interface vlan 6

name "iSCSI"

exit

interface vlan 100

name "labL3"

routing

ip address 192.168.1.1 255.255.255.252

exit

username "admin" password 4e762ee7b57dd4c704bc5d0959dc32ec level 15 encrypted

monitor session 1 destination interface 1/g7

spanning-tree priority 4096

!

interface ethernet 1/g1

channel-group 1 mode on

exit

!

interface ethernet 1/g2

channel-group 2 mode on

exit

!

interface ethernet 1/g3

channel-group 3 mode on

exit

!

interface ethernet 1/g4

channel-group 4 mode on

exit

!

interface ethernet 1/g5

channel-group 5 mode auto

exit

!

interface ethernet 1/g6

channel-group 5 mode auto

exit

!

interface ethernet 1/g7

spanning-tree portfast

exit

!

interface ethernet 1/g8

spanning-tree portfast

exit

!

interface ethernet 1/g9

spanning-tree portfast

exit

!

interface ethernet 1/g10

spanning-tree portfast

exit

!

interface ethernet 1/g11

spanning-tree portfast

exit

!

interface ethernet 1/g12

spanning-tree portfast

exit

!

interface ethernet 1/g13

channel-group 13 mode on

exit

!

interface ethernet 1/g14

channel-group 14 mode on

exit

!

interface ethernet 1/g15

channel-group 15 mode on

spanning-tree portfast

switchport access vlan 4

exit

!

interface ethernet 1/g16

channel-group 16 mode on

exit

!

interface ethernet 1/g17

spanning-tree portfast

switchport access vlan 4

exit

!

interface ethernet 1/g18

spanning-tree portfast

exit

!

interface ethernet 1/g19

spanning-tree portfast

switchport access vlan 4

exit

!

interface ethernet 1/g20

spanning-tree portfast

switchport access vlan 4

exit

!

interface ethernet 1/g21

spanning-tree portfast

switchport access vlan 4

exit

!

interface ethernet 1/g22

spanning-tree portfast

switchport access vlan 4

exit

!

interface ethernet 1/g23

spanning-tree portfast

switchport access vlan 4

exit

!

interface ethernet 1/g24

spanning-tree portfast

switchport access vlan 4

exit

!

interface ethernet 1/g25

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 1/g26

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 1/g27

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 1/g28

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 1/g29

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 1/g30

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 1/g31

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 1/g32

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 1/g33

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 1/g34

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 1/g35

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 1/g36

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 1/g37

spanning-tree portfast

exit

!

interface ethernet 1/g38

spanning-tree portfast

exit

!

interface ethernet 1/g39

channel-group 39 mode on

exit

!

interface ethernet 1/g40

channel-group 40 mode on

exit

!

interface ethernet 1/g41

channel-group 41 mode on

exit

!

interface ethernet 1/g42

channel-group 42 mode on

exit

!

interface ethernet 1/g43

channel-group 43 mode on

exit

!

interface ethernet 1/g44

spanning-tree portfast

switchport access vlan 100

exit

!

interface ethernet 1/g45

spanning-tree portfast

exit

!

interface ethernet 1/g46

spanning-tree portfast

switchport access vlan 5

exit

!

interface ethernet 1/g47

description 'ShoreTel_Phone_System'

spanning-tree portfast

exit

!

interface ethernet 1/g48

spanning-tree portfast

exit

!

interface ethernet 2/g1

channel-group 1 mode on

exit

!

interface ethernet 2/g2

channel-group 2 mode on

exit

!

interface ethernet 2/g3

channel-group 3 mode on

exit

!

interface ethernet 2/g4

channel-group 4 mode on

exit

!

interface ethernet 2/g5

channel-group 5 mode auto

exit

!

interface ethernet 2/g6

channel-group 5 mode auto

exit

!

interface ethernet 2/g7

spanning-tree portfast

exit

!

interface ethernet 2/g8

spanning-tree portfast

exit

!

interface ethernet 2/g9

spanning-tree portfast

exit

!

interface ethernet 2/g10

spanning-tree portfast

exit

!

interface ethernet 2/g11

spanning-tree portfast

exit

!

interface ethernet 2/g12

spanning-tree portfast

exit

!

interface ethernet 2/g13

channel-group 13 mode on

exit

!

interface ethernet 2/g14

channel-group 14 mode on

exit

!

interface ethernet 2/g15

channel-group 15 mode on

spanning-tree portfast

switchport access vlan 4

exit

!

interface ethernet 2/g16

channel-group 16 mode on

exit

!

interface ethernet 2/g17

spanning-tree portfast

switchport access vlan 4

exit

!

interface ethernet 2/g18

spanning-tree portfast

exit

!

interface ethernet 2/g19

spanning-tree portfast

switchport access vlan 4

exit

!

interface ethernet 2/g20

spanning-tree portfast

switchport access vlan 4

exit

!

interface ethernet 2/g21

spanning-tree portfast

switchport access vlan 4

exit

!

interface ethernet 2/g22

spanning-tree portfast

switchport access vlan 4

exit

!

interface ethernet 2/g23

spanning-tree portfast

switchport access vlan 4

exit

!

interface ethernet 2/g24

spanning-tree portfast

switchport access vlan 4

exit

!

interface ethernet 2/g25

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 2/g26

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 2/g27

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 2/g28

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 2/g29

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 2/g30

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 2/g31

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 2/g32

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 2/g33

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 2/g34

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 2/g35

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 2/g36

spanning-tree portfast

mtu 9216

switchport access vlan 6

exit

!

interface ethernet 2/g37

spanning-tree portfast

exit

!

interface ethernet 2/g38

spanning-tree portfast

exit

!

interface ethernet 2/g39

channel-group 39 mode on

exit

!

interface ethernet 2/g40

channel-group 40 mode on

exit

!

interface ethernet 2/g41

channel-group 41 mode on

exit

!

interface ethernet 2/g42

channel-group 42 mode on

exit

!

interface ethernet 2/g43

channel-group 43 mode on

exit

!

interface ethernet 2/g44

spanning-tree portfast

exit

!

interface ethernet 2/g45

spanning-tree portfast

exit

!

interface ethernet 2/g46

spanning-tree portfast

switchport access vlan 5

exit

!

interface ethernet 2/g47

description 'ShoreTel_Phone_System'

spanning-tree portfast

exit

!

interface ethernet 2/g48

spanning-tree portfast

exit

!

interface port-channel 1

description 'Trunk to ESX01'

hashing-mode 6

spanning-tree portfast

switchport mode trunk

switchport trunk allowed vlan add 1-5

exit

!

interface port-channel 2

description 'Trunk to ESX 02'

hashing-mode 6

spanning-tree portfast

switchport mode trunk

switchport trunk allowed vlan add 1-5

exit

!

interface port-channel 3

description 'Trunk to ESX 03'

hashing-mode 6

spanning-tree portfast

switchport access vlan 2

exit

!

interface port-channel 4

description 'Trunk to ESX 04'

hashing-mode 6

spanning-tree portfast

switchport access vlan 2

exit

!

interface port-channel 5

hashing-mode 6

spanning-tree portfast

switchport access vlan 3

exit

!

interface port-channel 6

description 'Uplink back to old Core'

exit

!

interface port-channel 13

description 'Channel to MGMT on ESX 01'

hashing-mode 6

spanning-tree portfast

switchport access vlan 4

exit

!

interface port-channel 14

description 'Channel to MGMT on ESX 02'

hashing-mode 6

spanning-tree portfast

switchport access vlan 4

exit

!

interface port-channel 15

description 'Channel to MGMT on ESX 03'

hashing-mode 6

spanning-tree portfast

switchport access vlan 4

exit

!

interface port-channel 16

description 'Channel to MGMT on ESX 04'

hashing-mode 6

spanning-tree portfast

switchport access vlan 4

exit

!

interface port-channel 39

description 'Uplinks to IDF Switches'

switchport mode general

exit

!

interface port-channel 40

description 'Uplinks to IDF Switches'

switchport mode general

exit

!

interface port-channel 41

description 'Uplinks to IDF Switches'

switchport mode general

exit

!

interface port-channel 42

description 'Uplinks to IDF Switches'

switchport mode general

exit

!

interface port-channel 43

description 'Uplinks to IDF Switches'

switchport mode general

exit

snmp-server community *** rw

exit

Any other thoughts?

0 Kudos
jjburnett
1 Copper

Re: Speed and Routing Issues on 6248

I'll add to this. It seems to have helped a lot.

Now we get transfer speeds of 70-80 for the first 30 seconds or so and then its like the transfer just stops. Nothing moves then after 15-20 seconds the transfer resumes at 10-15.

0 Kudos
Moderator
Moderator

Re: Speed and Routing Issues on 6248

Ensure flowcontroll is configured end-to-end, so verify that the host NICs/HBAs that are facing the iSCSI network have flowcontrol enabled:

NIC's should be set so that they send pause frames if they are temporarily unable to process incoming I/O.  This setting will usually be called "Tx Pause" or "Generate".  If this mode is available, select it. If this granularity of control is not available, check to see if there is an "auto" or "enabled/disabled" option for flow control; if "auto" is available, use it, otherwise use "enabled.

You didn’t mention the OS of the host, i.e., ESX with Windows Server 2012 VM (for example).  There are specific settings for the various OS’s that greatly improve and stabilize performance.  Post the OS and NICs/HBAs models FW etc. (TOE or LAN configured) that you are using.

Also, note that the 6200’s are typically for “small” setups, 1-3 hosts, and 1-2 arrays, anything beyond this will result in poor performance with these switches.

-joe

-Joe

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

Follow me on Twitter: @joesatdell 

0 Kudos
jjburnett
1 Copper

Re: Speed and Routing Issues on 6248

Thanks Joe!

I'm sorry I left out most of the important information. There are 3 hosts and 1 array. The hosts are ESXi 5.1 with the array being an Equal Logic 6100.

I should mention that when we move a large file from one VM to another that are on the same host the speeds start around 120 ish and stay that way until about half done then do that same pause thing where the transfer speed steadily decreases down to 20 ish mb a second and then starts going again at 20mbs.

Does that makes this a SAN issue or a VMware issue? The servers are running a dell version of the ESXi image.

0 Kudos
Moderator
Moderator

Re: Speed and Routing Issues on 6248

Start with these key points…

Ensure you have the most current version of the FW on the Arrays (you can use either the v5 or v6 family)

Ensure the switch has the latest FW/OS

Ensure ESX is fully patched.

Ensure all NICs/HBAs have approved drivers at a version (or above_) listed here: en.community.dell.com/.../2661.equallogic-validated-components.aspx

Ensure the hosts VM have the proper iSCSI disk timeouts setup per the “iSCSI Initiator and Operating System Considerations” located on the Firmware download page (eqlsupport.dell.com).

Ensure you have the ESX host setup per Don’s (DELL-Donald Wi) recommendations (this is key to getting maximum performance and stability on ESX): en.community.dell.com/.../19516886.aspx

Any direct attached VM (i.e., storage direct or also known as guest attached volumes), have the proper Time out and NIC settings (flow control, TCP offload disabled if not using it, jumbo, etc.)

-joe

-Joe

Social Media and Community Professional
#IWork4Dell
Get Support on Twitter - @dellcarespro

Follow me on Twitter: @joesatdell 

0 Kudos