Highlighted
dwathen
1 Nickel

Trunking between PC6248 stack and PC5324

The end goal of my project is to set up guest internet on PC5324 port g1 with a WAP on vlan 172 with no access to other vlans.  Other ports on the PC5324 will belong to vlan 11.  As the first step I created a trunk on PC6248 port 1/g7 and added vlan 11 and 172.  I created a trunk on PC5324 port g21 and added vlan 11 and 172.  I added PC5324 port g3 to vlan 11 and connected a laptop.  I added PC5324 port g1 to vlan 172.   Vlan 1 is the management interface (192.168.11.1 /24).  CAT5e connects PC6248 1/g7 to PC5324 g21.  The next hop for vlan 11 from the PC5324 is 192.168.11.254 (vlan 11 on PC6248 port 1/g7).  From the PC6248 I can ping 192.168.11.254 but not 192.168.11.1.  From the PC5324 I can ping 192.168.11.1 but not 192.168.11.254.  I tested the cable and ports as the source of the disconnect.  Can someone help me discover what I'm overlooking?  The config information is listed below for both devices.

PC5324 config...

console> enable

console# show vlan

Vlan       Name                   Ports                Type     Authorization
---- ----------------- --------------------------- ------------ -------------
 1           1              g(2,4-24),ch(1-8)         other       Required
 11         11                   g(3,21)            permanent     Required
172         172                  g(1,21)            permanent     Required

console# show run
interface ethernet g21
switchport mode trunk
exit
vlan database
vlan 11,172
exit
interface ethernet g3
switchport access vlan 11
exit
interface ethernet g21
switchport trunk allowed vlan add 11
exit
interface ethernet g1
switchport access vlan 172
exit
interface ethernet g21
switchport trunk allowed vlan add 172
exit
interface vlan 1
ip address 192.168.11.1 255.255.255.0
exit
ip default-gateway 192.168.11.254
console# ping 192.168.11.1
Pinging 192.168.11.1 with 56 bytes of data:

56 bytes from 192.168.11.1: icmp_seq=1. time=0 ms
56 bytes from 192.168.11.1: icmp_seq=2. time=0 ms
56 bytes from 192.168.11.1: icmp_seq=3. time=0 ms
56 bytes from 192.168.11.1: icmp_seq=4. time=0 ms

----192.168.11.1 PING Statistics----
4 packets transmitted, 4 packets received, 0% packet loss
round-trip (ms) min/avg/max = 0/0/0

console# ping 192.168.11.254
Pinging 192.168.11.254 with 56 bytes of data:

PING: no reply from 192.168.11.254
PING: timeout
PING: no reply from 192.168.11.254
PING: timeout
PING: no reply from 192.168.11.254
PING: timeout
PING: no reply from 192.168.11.254
PING: timeout

----192.168.11.254 PING Statistics----
4 packets transmitted, 0 packets received, 100% packet loss

console#

 

PC6248 config...

User:admin
Password:******
datacenter-sw01>enable

datacenter-sw01#show interfaces switchport ethernet 1/g7

Port: 1/g7
VLAN Membership mode:Trunk Mode

Operating parameters:
PVID: 1
Ingress Filtering: Enabled
Acceptable Frame Type: VLAN Only
Default Priority: 0
GVRP status:Disabled
Protected:Disabled

Port 1/g7 is member in:

VLAN    Name                              Egress rule   Type
----    --------------------------------- -----------   --------
11      LAB                               Tagged        Static
172     Guest_Internet                    Tagged        Static

Static configuration:
PVID: 1
Ingress Filtering: Enabled
Acceptable Frame Type: VLAN Only
--More-- or (q)uit

Port 1/g7 is statically configured to:

VLAN    Name                              Egress rule
----    --------------------------------- -----------
11      LAB                               Tagged
172     Guest_Internet                    Tagged

Forbidden VLANS:
VLAN    Name
----    ---------------------------------

datacenter-sw01#ping 192.168.11.254
Pinging 192.168.11.254 with 64 bytes of data:
64 bytes from 192.168.11.254: icmp_seq = 0. time < 10ms
64 bytes from 192.168.11.254: icmp_seq = 1. time < 10ms
64 bytes from 192.168.11.254: icmp_seq = 2. time < 10ms
64 bytes from 192.168.11.254: icmp_seq = 3. time < 10ms

----192.168.11.254 PING Statistics----
4 packets transmitted,4 packets received,0% packet loss
round-trip (ms) min/avg/max = 0/0/0

 

datacenter-sw01#ping 192.168.11.1
Pinging 192.168.11.1 with 64 bytes of data:

----192.168.11.1 PING Statistics----
4 packets transmitted,0 packets received,100% packet loss
round-trip (ms) min/avg/max = 0/NaN/0

 

datacenter-sw01#

 

0 Kudos
9 Replies
Moderator
Moderator

Re: Trunking between PC6248 stack and PC5324

General links are mostly used today for legacy equipment.  However, on the PowerConnect 62xx series switches, you must use General mode if you want to allow management traffic onto the switch over the PVID.  If you use Trunk mode, you will not have the default VLAN on those ports.  The ports will only allow tagged traffic. So I would suggest changing from Trunk to General mode and set the PVID to 1.

console(config)# interface ethernet 1/g7

console(config-if)# switchport mode general

console(config-if)# switchport general allowed vlan add 11,172 tagged

console(config-if)# switchport general pvid 1

console(config-if)# end

Once that is changed you should be able to ping between the switches.

Thanks

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
dwathen
1 Nickel

Re: Trunking between PC6248 stack and PC5324

Thank you for your help with this issue.  I can ping both directions on both vlans (11,172) but not the management interface (VLAN 1  192.168.11.1 /24) on the PC5324.  I can access the PC5324 through the console.  Listed below are the ping results from a Windows command prompt and from putty.  The putty results are opposite from the Windows results.  How can I establish remote access to the PC5324 on vlan 1?

C:\Documents and Settings\administrator>ipconfig /all

<text omitted>

Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . : USEMCO.LOCAL

       Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Cont

roller

       Physical Address. . . . . . . . . : 00-14-22-F3-8A-61

       Dhcp Enabled. . . . . . . . . . . : Yes

       Autoconfiguration Enabled . . . . : Yes

       IP Address. . . . . . . . . . . . : 192.168.11.101

       Subnet Mask . . . . . . . . . . . : 255.255.255.0

       Default Gateway . . . . . . . . . : 192.168.11.254

       DHCP Server . . . . . . . . . . . : 192.168.0.24

       DNS Servers . . . . . . . . . . . : 192.168.0.24

                                           192.168.0.1

       Lease Obtained. . . . . . . . . . : Friday, April 19, 2013 1:58:39 PM

       Lease Expires . . . . . . . . . . : Saturday, April 27, 2013 1:58:39 PM

C:\Documents and Settings\administrator>ping 192.168.11.254

Pinging 192.168.11.254 with 32 bytes of data:

Reply from 192.168.11.254: bytes=32 time=1ms TTL=64

Reply from 192.168.11.254: bytes=32 time=1ms TTL=64

Reply from 192.168.11.254: bytes=32 time=1ms TTL=64

Reply from 192.168.11.254: bytes=32 time=1ms TTL=64

Ping statistics for 192.168.11.254:

   Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

   Minimum = 1ms, Maximum = 1ms, Average = 1ms

C:\Documents and Settings\administrator>ping 192.168.11.1

Pinging 192.168.11.1 with 32 bytes of data:

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Ping statistics for 192.168.11.1:

   Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\Documents and Settings\administrator>

console>

console> enable

console# ping 192.168.11.1

Pinging 192.168.11.1 with 56 bytes of data:

56 bytes from 192.168.11.1: icmp_seq=1. time=20 ms

56 bytes from 192.168.11.1: icmp_seq=2. time=0 ms

56 bytes from 192.168.11.1: icmp_seq=3. time=0 ms

56 bytes from 192.168.11.1: icmp_seq=4. time=0 ms

----192.168.11.1 PING Statistics----

4 packets transmitted, 4 packets received, 0% packet loss

round-trip (ms) min/avg/max = 0/5/20

console# ping 192.168.11.254

Pinging 192.168.11.254 with 56 bytes of data:

PING: no reply from 192.168.11.254

PING: timeout

PING: no reply from 192.168.11.254

PING: timeout

PING: no reply from 192.168.11.254

PING: timeout

PING: no reply from 192.168.11.254

PING: timeout

----192.168.11.254 PING Statistics----

4 packets transmitted, 0 packets received, 100% packet loss

console#

0 Kudos
Moderator
Moderator

Re: Trunking between PC6248 stack and PC5324

Did we make the changes to port g7 on the 6248? whats the config look like on that port now?

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
dwathen
1 Nickel

Re: Trunking between PC6248 stack and PC5324

User:admin

Password:******

datacenter-sw01>enable

datacenter-sw01#show interfaces switchport ethernet 1/g7

Port: 1/g7

VLAN Membership mode:General Mode

Operating parameters:

PVID: 1

Ingress Filtering: Enabled

Acceptable Frame Type: Admit All

Default Priority: 0

GVRP status:Disabled

Protected:Disabled

Port 1/g7 is member in:

VLAN    Name                              Egress rule   Type

----    --------------------------------- -----------   --------

1       Default                           Untagged      Default

11      LAB                               Tagged        Static

100     DATACENTER                        Tagged        Static

172     Guest_Internet                    Tagged        Static

Static configuration:

PVID: 1

--More-- or (q)uit

Ingress Filtering: Enabled

Acceptable Frame Type: Admit All

Port 1/g7 is statically configured to:

VLAN    Name                              Egress rule

----    --------------------------------- -----------

11      LAB                               Tagged

100     DATACENTER                        Tagged

172     Guest_Internet                    Tagged

Forbidden VLANS:

VLAN    Name

----    ---------------------------------

datacenter-sw01#

0 Kudos
Moderator
Moderator

Re: Trunking between PC6248 stack and PC5324

That looks great on g7, lets go to the 5324 and do the same configuration on g21. Then do the show interface command on g21, make sure they look the same. Then test for the connectivity. Other than that I am not seeing what might be causing this to occur, but I will continue looking into it.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
dwathen
1 Nickel

Re: Trunking between PC6248 stack and PC5324

PC5324 config and cli ping results...

console>

console> enable

console# show interfaces switchport ethernet g21

Port : g21

Port Mode: General

Gvrp Status: disabled

Ingress Filtering: true

Acceptable Frame Type: admitAll

Ingress UnTagged VLAN ( NATIVE 😞 1

Port is member in:

Vlan               Name               Egress rule Port Membership Type

---- -------------------------------- ----------- --------------------

1                  1                  Untagged          System

11                 11                  Tagged           Static

100                100                  Tagged           Static

172                172                  Tagged           Static

Forbidden VLANS:

Vlan               Name

---- --------------------------------

Classification rules:

Protocol based VLANs:

Group ID Vlan ID

-------- -------

console#

Microsoft Windows XP [Version 5.1.2600]

(C) Copyright 1985-2001 Microsoft Corp.

U:\>ipconfig /all

Windows IP Configuration

       Host Name . . . . . . . . . . . . : datacenter

       Primary Dns Suffix  . . . . . . . : USEMCO.LOCAL

       Node Type . . . . . . . . . . . . : Unknown

       IP Routing Enabled. . . . . . . . : No

       WINS Proxy Enabled. . . . . . . . : No

       DNS Suffix Search List. . . . . . : USEMCO.LOCAL

                                           USEMCO.LOCAL

Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . : USEMCO.LOCAL

       Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Cont

roller

       Physical Address. . . . . . . . . : 00-14-22-F3-8A-61

       Dhcp Enabled. . . . . . . . . . . : Yes

       Autoconfiguration Enabled . . . . : Yes

       IP Address. . . . . . . . . . . . : 192.168.11.101

       Subnet Mask . . . . . . . . . . . : 255.255.255.0

       Default Gateway . . . . . . . . . : 192.168.11.254

       DHCP Server . . . . . . . . . . . : 192.168.0.24

       DNS Servers . . . . . . . . . . . : 192.168.0.24

                                           192.168.0.1

       Lease Obtained. . . . . . . . . . : Friday, April 19, 2013 3:37:35 PM

       Lease Expires . . . . . . . . . . : Saturday, April 27, 2013 3:37:35 PM

Ethernet adapter Wireless Network Connection:

       Connection-specific DNS Suffix  . :

       Description . . . . . . . . . . . : Intel(R) PRO/Wireless 2915ABG Networ

k Connection

       Physical Address. . . . . . . . . : 00-16-6F-5E-DF-50

       Dhcp Enabled. . . . . . . . . . . : Yes

       Autoconfiguration Enabled . . . . : Yes

       IP Address. . . . . . . . . . . . : 172.16.11.230

       Subnet Mask . . . . . . . . . . . : 255.255.255.0

       Default Gateway . . . . . . . . . : 172.16.11.1

       DHCP Server . . . . . . . . . . . : 172.16.11.1

       DNS Servers . . . . . . . . . . . : 192.168.0.1

                                           192.168.0.24

                                           8.8.8.8

       Lease Obtained. . . . . . . . . . : Tuesday, April 23, 2013 2:11:16 PM

       Lease Expires . . . . . . . . . . : Wednesday, April 24, 2013 2:11:16 PM

U:\>ping 192.168.11.1

Pinging 192.168.11.1 with 32 bytes of data:

Request timed out.

Request timed out.

Request timed out.

Request timed out.

Ping statistics for 192.168.11.1:

   Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

U:\>ping 192.168.11.254

Pinging 192.168.11.254 with 32 bytes of data:

Reply from 192.168.11.254: bytes=32 time=1ms TTL=64

Reply from 192.168.11.254: bytes=32 time=1ms TTL=64

Reply from 192.168.11.254: bytes=32 time=1ms TTL=64

Reply from 192.168.11.254: bytes=32 time=1ms TTL=64

Ping statistics for 192.168.11.254:

   Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

   Minimum = 1ms, Maximum = 1ms, Average = 1ms

U:\>

0 Kudos
Moderator
Moderator

Re: Trunking between PC6248 stack and PC5324

I have been looking back through the information we have here to try and identify any other suggestions, but not finding anything with what we have. The next step is to get a full running config from each switch. I can look through the entire config for any possible suggested changes.

If we plug another workstation/laptop into the 6248. Can we ping from workstation to workstation on VLAN 1? 

Thanks.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
dwathen
1 Nickel

Re: Trunking between PC6248 stack and PC5324

What is the best way to get the full config to you?  The PC6248 config is many pages and I'm concerned about security if I post the config for my datacenter core on an open forum.

0 Kudos
Moderator
Moderator

Re: Trunking between PC6248 stack and PC5324

DM sent here on the forums.

Thanks

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos