openmanage network manager does not login to switch

Hi

I m trying to integrate my powerconnect 8164F to onm5.1.2

I can use ssh or web browser to access to the switch

When i try to discover it through ssh i got the following messages

1 Did not Respond to Authentication. Please click here for the list of devices that did not respond....

here is my config

username "root" password d099d6579632d7cb200fd5952c2e22e3 privilege 15 encrypted
username "manager" password f9901d343224d3692d3a129cd7dac1e4 privilege 1 encrypted
ip ssh server
ip ssh pubkey-auth
ip ssh protocol 2
enable password d099d6579632d7cb200fd5952c2e22e3 encrypted

In the configuration for authentification i put
user id : manager
enable id : root
and the password for both
but it doesn't work
is there a way to debug this problem?
0 Kudos
6 Replies
Anonymous
Not applicable

Re: openmanage network manager does not login to switch

What firmware is the switch on?

Managed devices can only be discovered once. So it may have already been discovered, we just need to update the list. The state of previously discovered devices can be updated by selecting Action - Resync from the Equipment Inventory.

The device may also be listed as Discovered Entities, rather than specific vendors' devices. This can mean the following:

• The equipment's driver not installed

• The driver installed but not seeded to database

• Monitored devices must be configured to connect and send SNMP traps to the element management system.

Something else to check out is the SNMP community string. The SNMP community strings public for read-only and private for read-write are included as default authentications, but may not match those on the equipment being discovered. If that occurs, discovery fails. Devices unreachable using the selected SNMP authentication credential appear listed in the Current License Doesn't Support Following Devices section of the discovery results.

It looks like the switch has an enable password, I would double check and make sure the OMNM software has the enable password entered as well.

Thanks

0 Kudos

Re: openmanage network manager does not login to switch

well the firmware is 5.1.0.3.

I don't understand why you re are talking about snmp?

i was testing discovering through ssh

my switches has an enable password but where can i find the enable id?

0 Kudos
Anonymous
Not applicable

Re: openmanage network manager does not login to switch

Sorry about the SNMP thing. The Enable ID looks like it should be su according to this part of the user guide.

"In Authentication Manager, enter su in the Enable User ID field and enter the root user’s password in Enable User Password in that same authentication. This enables full device management functionality with root access."

We should try that out and see if makes any difference. Can you grab me the output of show authentication methods? ill keep looking into this some more.

0 Kudos
Anonymous
Not applicable

Re: openmanage network manager does not login to switch

Ok, got some more information. The enable ID we can leave blank, then enter the enable password. User ID needs to be your privilege level 15 user, root. Then also make sure the rsa and dsa keys are generated.

console(config)#crypto key generate rsa

console(config)#crypto key generate dsa

Then try the discovery again.

Thanks.

0 Kudos
vt1012
3 Argentium

Re: openmanage network manager does not login to switch

The user ID and the enable ID for the Dell 81xx switch are in essence the same.  If you have set a login ID (for telnet/ssh into the switch), then the enable ID is already set to the same automatically (other switches sometimes require a separate enable ID).  The IDs are the same, but the passwords can be different for the User prompt vs. Enable prompt.   The enable password is only needed in OMNM if you have activated it on the switch (which is required for most OMNM management).  If you have, then enter both the user ID and enable ID with the same ID used when you login to the switch from telnet/ssh, but set both (different) passwords to access the corresponding CLI prompts.  

If you didn't set an enable password on the switch, then you can use the telnet/ssh login password for both the user password and the enable password in OMNM, just to be safe, though only the user password should be required.  

Rediscover the device, making sure you are using SSH and not telnet authentication.  You will also need to authenticate with SNMP as required.

0 Kudos

Re: openmanage network manager does not login to switch

well i have put that in omnm

protocol type sshv2

user id : root

user passwd : root password

enable id : blank

enable password : enable password

here is my config

cnsnetprd001#show authentication methods

Login Authentication Method Lists

---------------------------------

defaultList         :  none

networkList         :  local

Enable Authentication Method Lists

----------------------------------

enableList          :  enable   none

enableNetList       :  enable

Line     Login Method List    Enable Method List

-------  -----------------    ------------------

Console  defaultList          enableList

Telnet   networkList          enableNetList

SSH      networkList          enableNetList

HTTPS       :local

HTTP        :local

DOT1X       :

the enable password is enabled

but i keep getting the following messages when i want to discover the device

Did not Respond to Authentication. Please click here for the list of devices that did not respond. Will attempt to manage these as default devices

0 Kudos