Chirag11
1 Nickel

H330 with Intel RAID expander - RES3TV360 - Direct Mapping Mode error

Jump to solution

Hello,

I have a Dell H330 Raid card, I want to be able to plug in additional hard drives and so purchased the Intel Raid Expander - RES3TV360. 

However as soon as I plug a SAS3 cable to the expander and boot up, I get an error 

"Attached Enclosure dosen't support in controller's Direct mapping mode" 

This is before connecting any backplanes, or drives to the expander card. I have already checked the cables, used alternate ports etc. but problem persists. So issue seems to be that the H330 does not want to work with this expander??? 

Are there any jumper settings or configurations that will disable the Direct mapping mode? 

This is using an R230 server (just acting as Storage Server). 

0 Kudos
1 Solution

Accepted Solutions
Chirag11
1 Nickel

RE: H330 with Intel RAID expander - RES3TV360 - Direct Mapping Mode error

Jump to solution

I found my own answer... Posting here for others benefits.

So all the PERC Cards have something called directpdmapping. This could be on or off. In my case this was ON. If you use an expander, this needs to be set to OFF. 

Here is how to do it. 

There is no setting on the Ctrl+R at boot time for this. You must be booted into the operating system that is on the same server as where the PERC card is installed. 

First you need to download the "perccli" - this is the command line utility. 

You can find download here - https://www.dell.com/support/home/us/en/04/Drivers/DriversDetails?driverId=3XDPP

There are Windows (will not work in DOS mode) and Linux files. 

If you dont have OS installed, you can create a bootable USB (I created Ubuntu Desktop iso) and use Rufus to write the iso to a USB flash drive. Then boot from this drive. 

Note that the linux download is a rpm file - but you just need to extract it - no need to install it. You should get a file structure of opt/Megaraid/perccli/perccli or opt/Megaraid/perccli/perccli64 

You can find the complete guide here - click here 

or full path http: // topics-cdn.dell.com/pdf/poweredge-rc-h730_reference%20guide_en-us.pdf

Command to check the directpdmapping - 

perccli /c0 show directpdmapping

Command to set mapping to OFF


perccli /c0 set directpdmapping=off

on 64-bit system replace perccli with perccli64

Reboot the machine for changes to take effect, and verify again that the directpdmapping is off. 

Thats it! 

1 Reply
Chirag11
1 Nickel

RE: H330 with Intel RAID expander - RES3TV360 - Direct Mapping Mode error

Jump to solution

I found my own answer... Posting here for others benefits.

So all the PERC Cards have something called directpdmapping. This could be on or off. In my case this was ON. If you use an expander, this needs to be set to OFF. 

Here is how to do it. 

There is no setting on the Ctrl+R at boot time for this. You must be booted into the operating system that is on the same server as where the PERC card is installed. 

First you need to download the "perccli" - this is the command line utility. 

You can find download here - https://www.dell.com/support/home/us/en/04/Drivers/DriversDetails?driverId=3XDPP

There are Windows (will not work in DOS mode) and Linux files. 

If you dont have OS installed, you can create a bootable USB (I created Ubuntu Desktop iso) and use Rufus to write the iso to a USB flash drive. Then boot from this drive. 

Note that the linux download is a rpm file - but you just need to extract it - no need to install it. You should get a file structure of opt/Megaraid/perccli/perccli or opt/Megaraid/perccli/perccli64 

You can find the complete guide here - click here 

or full path http: // topics-cdn.dell.com/pdf/poweredge-rc-h730_reference%20guide_en-us.pdf

Command to check the directpdmapping - 

perccli /c0 show directpdmapping

Command to set mapping to OFF


perccli /c0 set directpdmapping=off

on 64-bit system replace perccli with perccli64

Reboot the machine for changes to take effect, and verify again that the directpdmapping is off. 

Thats it!